aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-06-30 23:54:09 +0800
committerantoine <antoine@FreeBSD.org>2013-06-30 23:54:09 +0800
commit0af8b1e8141981824b7fb30c8a1e9673620dbd6a (patch)
treeb38f4fc1b7145f0f5e644c5f9159973f1fc4a0e3 /devel
parent62798a57c836ec77deea8e3af6d298950a0d8056 (diff)
downloadfreebsd-ports-gnome-0af8b1e8141981824b7fb30c8a1e9673620dbd6a.tar.gz
freebsd-ports-gnome-0af8b1e8141981824b7fb30c8a1e9673620dbd6a.tar.zst
freebsd-ports-gnome-0af8b1e8141981824b7fb30c8a1e9673620dbd6a.zip
New port: py-olefileio_pl
A python module to read Microsoft OLE2 files
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-olefileio_pl/Makefile35
-rw-r--r--devel/py-olefileio_pl/distinfo2
-rw-r--r--devel/py-olefileio_pl/pkg-descr10
-rw-r--r--devel/py-olefileio_pl/pkg-plist3
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7abbbec02a8f..a49ccef598ac 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3610,6 +3610,7 @@
SUBDIR += py-ocempgui
SUBDIR += py-ode
SUBDIR += py-odfpy
+ SUBDIR += py-olefileio_pl
SUBDIR += py-omniorb
SUBDIR += py-optik
SUBDIR += py-orbit
diff --git a/devel/py-olefileio_pl/Makefile b/devel/py-olefileio_pl/Makefile
new file mode 100644
index 000000000000..5e547b7079df
--- /dev/null
+++ b/devel/py-olefileio_pl/Makefile
@@ -0,0 +1,35 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= olefileio_pl
+PORTVERSION= 0.25
+CATEGORIES= devel python
+MASTER_SITES= http://cdn.bitbucket.org/decalage/olefileio_pl/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= OleFileIO_PL-${PORTVERSION}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python module to read MS OLE2 files
+
+LICENSE= MIT
+
+USE_DOS2UNIX= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME=OleFileIO_PL
+
+PORT_OPTIONS= DOCS
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+PORTDOCS= README.txt
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-olefileio_pl/distinfo b/devel/py-olefileio_pl/distinfo
new file mode 100644
index 000000000000..bf3238976265
--- /dev/null
+++ b/devel/py-olefileio_pl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (OleFileIO_PL-0.25.zip) = 8c8219333ddf78d786c7f9e43a141934ddbd5a20e0e627e4b992ad54550b828a
+SIZE (OleFileIO_PL-0.25.zip) = 37370
diff --git a/devel/py-olefileio_pl/pkg-descr b/devel/py-olefileio_pl/pkg-descr
new file mode 100644
index 000000000000..b98d584396e7
--- /dev/null
+++ b/devel/py-olefileio_pl/pkg-descr
@@ -0,0 +1,10 @@
+OleFileIO_PL is a Python module to read Microsoft OLE2 files (also called
+Structured Storage, Compound File Binary Format or Compound Document File
+Format), such as Microsoft Office documents, Image Composer and FlashPix
+files, Outlook messages, ...
+This is an improved version of the OleFileIO module from PIL, the excellent
+Python Imaging Library, created and maintained by Fredrik Lundh. The API is
+still compatible with PIL, but the internal implementation has been improved
+significantly, with new features, bugfixes and a more robust design.
+
+WWW: http://www.decalage.info/python/olefileio
diff --git a/devel/py-olefileio_pl/pkg-plist b/devel/py-olefileio_pl/pkg-plist
new file mode 100644
index 000000000000..7b66b2b06c73
--- /dev/null
+++ b/devel/py-olefileio_pl/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/OleFileIO_PL.py
+%%PYTHON_SITELIBDIR%%/OleFileIO_PL.pyc
+%%PYTHON_SITELIBDIR%%/OleFileIO_PL.pyo