aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-02-22 17:37:40 +0800
committerkoobs <koobs@FreeBSD.org>2016-02-22 17:37:40 +0800
commit0bebc158414e7308dac76fd5e870bb659bc1e2e0 (patch)
treef7efe5dced4e6a6ff3e45e5410646f95e6342fc0 /devel
parentb34e6c5123f5cdd50a458b112e73c9b39044f4f1 (diff)
downloadfreebsd-ports-gnome-0bebc158414e7308dac76fd5e870bb659bc1e2e0.tar.gz
freebsd-ports-gnome-0bebc158414e7308dac76fd5e870bb659bc1e2e0.tar.zst
freebsd-ports-gnome-0bebc158414e7308dac76fd5e870bb659bc1e2e0.zip
devel/py-rauth: Update to 0.7.2, Modernize
- Update PORTVERSION and distinfo checksum (0.7.2) - Add LICENSE_FILE - Update RUN_DEPENDS (Switch to www/requests from requests1 - Update TEST dependencies and test target - Remove TESTS options bits accordingly - Patch setup.py to enable setuptools test command support - Update pkg-descr based on latest upstream text - Enable NO_ARCH (architecture independence)
Diffstat (limited to 'devel')
-rw-r--r--devel/py-rauth/Makefile26
-rw-r--r--devel/py-rauth/distinfo4
-rw-r--r--devel/py-rauth/files/patch-setup.py34
-rw-r--r--devel/py-rauth/pkg-descr9
4 files changed, 50 insertions, 23 deletions
diff --git a/devel/py-rauth/Makefile b/devel/py-rauth/Makefile
index ee28723db2df..463d5ec8c2e4 100644
--- a/devel/py-rauth/Makefile
+++ b/devel/py-rauth/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rauth
-PORTVERSION= 0.6.2
-PORTREVISION= 2
+PORTVERSION= 0.7.2
CATEGORIES= devel www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,29 +10,22 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Python library for OAuth 1.0/a, 2.0, and Ofly consumers
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests1>=1.2.3:${PORTSDIR}/www/py-requests1
-TEST_DEPENDS:= ${RUN_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}nose>=1.2.1:${PORTSDIR}/devel/py-nose \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.2.3:${PORTSDIR}/www/py-requests
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.2.1:${PORTSDIR}/devel/py-nose \
${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
${PYTHON_PKGNAMEPREFIX}pycrypto>=2.5:${PORTSDIR}/security/py-pycrypto
-OPTIONS_DEFINE= TESTS
-TESTS_DESC= Install tools for unit testing
-
-USE_GITHUB= yes
-GH_ACCOUNT= litl
-
USES= python
+USE_GITHUB= yes
USE_PYTHON= distutils autoplist
-.include <bsd.port.options.mk>
+GH_ACCOUNT= litl
-.if ${PORT_OPTIONS:MTESTS}
-BUILD_DEPENDS:= ${TEST_DEPENDS}
-.endif
+NO_ARCH= yes
-regression-test: build
- @cd ${WRKSRC} && nosetests
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/devel/py-rauth/distinfo b/devel/py-rauth/distinfo
index d6e181f62ba7..bb76c6a46c41 100644
--- a/devel/py-rauth/distinfo
+++ b/devel/py-rauth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (litl-rauth-0.6.2_GH0.tar.gz) = 14d6f694d9d87906533359dcbdf024319837b8d7506a9485cc9a53b48949cf81
-SIZE (litl-rauth-0.6.2_GH0.tar.gz) = 33251
+SHA256 (litl-rauth-0.7.2_GH0.tar.gz) = 224dcc283c11b60a1cda0082836570338def1134a92b0d874046c3d0acb8d9aa
+SIZE (litl-rauth-0.7.2_GH0.tar.gz) = 34688
diff --git a/devel/py-rauth/files/patch-setup.py b/devel/py-rauth/files/patch-setup.py
new file mode 100644
index 000000000000..ec3c9a39b67d
--- /dev/null
+++ b/devel/py-rauth/files/patch-setup.py
@@ -0,0 +1,34 @@
+--- setup.py.orig 2015-11-05 16:01:31 UTC
++++ setup.py
+@@ -20,14 +20,16 @@ about = {}
+ with open('rauth/__about__.py') as f:
+ exec(f.read(), about)
+
+-if sys.argv[-1] == 'test':
+- status = os.system('make check')
+- status >>= 8
+- sys.exit(status)
+-
+ install_requires = ['requests>=1.2.3']
++
++tests_require = [
++ 'nose',
++ 'mock',
++ 'pycrypto',
++]
++
+ if sys.version_info[0] == 2 and sys.version_info[1] < 7:
+- install_requires.append('unittest2>=0.5.1')
++ tests_require = ['unittest2>=0.5.1']
+
+ classifiers = ['Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+@@ -57,6 +59,8 @@ setup(name=about['__title__'],
+ url='https://github.com/litl/rauth',
+ packages=find_packages(),
+ install_requires=install_requires,
++ tests_require=tests_require,
++ test_suite='nose.collector',
+ license=about['__license__'],
+ keywords='oauth oauth2 rauth requests',
+ classifiers=classifiers,
diff --git a/devel/py-rauth/pkg-descr b/devel/py-rauth/pkg-descr
index f4cd873c8220..886657c42dc4 100644
--- a/devel/py-rauth/pkg-descr
+++ b/devel/py-rauth/pkg-descr
@@ -1,9 +1,10 @@
This package provides OAuth 1.0/a, 2.0, and Ofly consumer support. The
package is wrapped around the superb Python Requests.
-- Built on Python-Requests
-- Supports OAuth 1.0, 1.0a, 2.0 and Ofly]
-- Service wrappers for convenient connection initialization
-- Well tested (100% coverage)
+ * Supports OAuth 1.0/a, 2.0 and Ofly
+ * Service wrappers for convenient connection initialization
+ * Authenticated session objects providing nifty things like keep-alive
+ * Well tested (100% coverage)
+ * Built on Requests
WWW: https://github.com/litl/rauth