aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2018-03-08 17:11:54 +0800
committergahr <gahr@FreeBSD.org>2018-03-08 17:11:54 +0800
commit1d3cc01de0863b5c11721bca56efe78131e4ccc1 (patch)
tree04b73067cb54ec8a2bd768e6a3b7b01feccceafc /devel
parent55cbdbe93453e688cd50fdec531efa69a02ca244 (diff)
downloadfreebsd-ports-gnome-1d3cc01de0863b5c11721bca56efe78131e4ccc1.tar.gz
freebsd-ports-gnome-1d3cc01de0863b5c11721bca56efe78131e4ccc1.tar.zst
freebsd-ports-gnome-1d3cc01de0863b5c11721bca56efe78131e4ccc1.zip
devel/catch: update to 2.2.0
Release notes: https://github.com/catchorg/Catch2/releases/tag/v2.2.0 https://github.com/catchorg/Catch2/releases/tag/v2.1.2
Diffstat (limited to 'devel')
-rw-r--r--devel/catch/Makefile40
-rw-r--r--devel/catch/distinfo6
-rw-r--r--devel/catch/pkg-plist7
3 files changed, 15 insertions, 38 deletions
diff --git a/devel/catch/Makefile b/devel/catch/Makefile
index 605722ca7ceb..dc9ed7a6d7e2 100644
--- a/devel/catch/Makefile
+++ b/devel/catch/Makefile
@@ -3,7 +3,7 @@
PORTNAME= catch
DISTVERSIONPREFIX= v
-DISTVERSION= 2.1.1
+DISTVERSION= 2.2.0
CATEGORIES= devel
MAINTAINER= gahr@FreeBSD.org
@@ -12,45 +12,15 @@ COMMENT= Header-only test framework for C++
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-TEST_DEPENDS= cmake:devel/cmake
-
-USES= compiler:c++11-lang
+USES= compiler:c++11-lang cmake pathfix
USE_GITHUB= yes
GH_ACCOUNT= catchorg
GH_PROJECT= Catch2
-NO_BUILD= yes
-NO_ARCH= yes
-
-REPORTERS= catch_reporter_automake.hpp \
- catch_reporter_bases.cpp \
- catch_reporter_bases.hpp \
- catch_reporter_compact.cpp \
- catch_reporter_compact.h \
- catch_reporter_console.cpp \
- catch_reporter_console.h \
- catch_reporter_junit.cpp \
- catch_reporter_junit.h \
- catch_reporter_multi.cpp \
- catch_reporter_multi.h \
- catch_reporter_tap.hpp \
- catch_reporter_teamcity.hpp \
- catch_reporter_xml.cpp \
- catch_reporter_xml.h
-
-PLIST_FILES= include/catch.hpp \
- ${REPORTERS:S/^/include\//g}
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/single_include/catch.hpp \
- ${STAGEDIR}${PREFIX}/include
-.for r in ${REPORTERS}
- ${INSTALL_DATA} ${WRKSRC}/include/reporters/${r} \
- ${STAGEDIR}${PREFIX}/include
-.endfor
+CMAKE_ARGS= -DCMAKE_INSTALL_DOCDIR=${DOCSDIR}
+PORTDOCS= *
do-test:
- cd ${WRKSRC} && \
- ${LOCALBASE}/bin/cmake . && ${MAKE_CMD} && ./SelfTest
+ ${WRKSRC}/SelfTest
.include <bsd.port.mk>
diff --git a/devel/catch/distinfo b/devel/catch/distinfo
index a080d6542f8d..ee010367b804 100644
--- a/devel/catch/distinfo
+++ b/devel/catch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517227790
-SHA256 (catchorg-Catch2-v2.1.1_GH0.tar.gz) = c40d3c8133c9274946067007e911a55b0d0ad3ed7c59a1f258dfcdb6836d8eff
-SIZE (catchorg-Catch2-v2.1.1_GH0.tar.gz) = 481236
+TIMESTAMP = 1520498633
+SHA256 (catchorg-Catch2-v2.2.0_GH0.tar.gz) = dee151b8fb403b277e1c806be6c6978c3f92f12a7f457761fa08c0404c1aaedb
+SIZE (catchorg-Catch2-v2.2.0_GH0.tar.gz) = 487585
diff --git a/devel/catch/pkg-plist b/devel/catch/pkg-plist
new file mode 100644
index 000000000000..6f7624fbfeb3
--- /dev/null
+++ b/devel/catch/pkg-plist
@@ -0,0 +1,7 @@
+include/catch/catch.hpp
+include/catch/catch_reporter_automake.hpp
+include/catch/catch_reporter_tap.hpp
+include/catch/catch_reporter_teamcity.hpp
+lib/cmake/Catch2/Catch2Config.cmake
+lib/cmake/Catch2/Catch2ConfigVersion.cmake
+libdata/pkgconfig/catch.pc