aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2017-03-23 16:48:00 +0800
committerdumbbell <dumbbell@FreeBSD.org>2017-03-23 16:48:00 +0800
commit2328a676b900687e9adadc08c31b421b8b5cbae6 (patch)
tree16b58f6248bdfee61d1029fffb4a5efcb7a06e9c /devel
parentbaa1c38f21fb1aae6e515d97b44deba8c58ac4cc (diff)
downloadfreebsd-ports-gnome-2328a676b900687e9adadc08c31b421b8b5cbae6.tar.gz
freebsd-ports-gnome-2328a676b900687e9adadc08c31b421b8b5cbae6.tar.zst
freebsd-ports-gnome-2328a676b900687e9adadc08c31b421b8b5cbae6.zip
devel/cargo: Update to 0.17.0
Beside the new upstream release, the port was cleaned up a bit to be closer to the lang/rust* ports. PR: 217338 Reported by: jbeich Approved by: antoine Differential Revision: https://reviews.freebsd.org/D9906
Diffstat (limited to 'devel')
-rw-r--r--devel/cargo/Makefile26
-rw-r--r--devel/cargo/distinfo11
-rw-r--r--devel/cargo/distinfo.amd649
-rw-r--r--devel/cargo/distinfo.i3869
-rw-r--r--devel/cargo/files/patch-Cargo.lock168
-rw-r--r--devel/cargo/files/patch-tests_build-auth.rs20
-rw-r--r--devel/cargo/pkg-plist1
7 files changed, 24 insertions, 220 deletions
diff --git a/devel/cargo/Makefile b/devel/cargo/Makefile
index dd3c0d04c246..9905dfd735e7 100644
--- a/devel/cargo/Makefile
+++ b/devel/cargo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cargo
-PORTVERSION= 0.15.0
-PORTREVISION= 2
+PORTVERSION= 0.17.0
CATEGORIES= devel
MAINTAINER= dumbbell@FreeBSD.org
@@ -21,7 +20,7 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
# Main source archive from GitHub
# This is the source of Cargo, taken from GitHub.
#
-# :bootstrap
+# :cargo_bootstrap
# Like Rust, this is a prebuilt "cargo" used to bootstrap it, because
# Cargo is a standard Rust package itself.
#
@@ -34,12 +33,12 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
# This is a collection of mainly shell scripts which are used to
# install Cargo.
-MASTER_SITES= https://static.rust-lang.org/cargo-dist/:bootstrap \
- LOCAL/dumbbell/rust:registry
+MASTER_SITES= https://s3.amazonaws.com/rust-lang-ci/cargo-builds/:cargo_bootstrap
.if !defined(SKIP_CARGO_REGISTRY)
+MASTER_SITES+= LOCAL/dumbbell/rust:registry
DISTFILES+= ${CARGO_REGISTRY}:registry
.endif
-DISTINFO_FILE= ${.CURDIR}/distinfo.${ARCH}
+DIST_SUBDIR?= rust
USE_GITHUB= yes
GH_ACCOUNT= rust-lang
@@ -55,13 +54,16 @@ RUST_ARCH_x86_64= x86_64 # dragonfly
RUST_ARCH_amd64= x86_64
RUST_ARCH_i386= i686
RUST_TARGET= ${RUST_ARCH_${ARCH}}-unknown-${OPSYS:tl}
-CARGO_BOOT= 2016-11-02/${PORTNAME}-nightly-${RUST_TARGET}${EXTRACT_SUFX}
-CARGO_REGISTRY= ${PORTNAME}-registry-${DISTVERSIONFULL}_${PORTREVISION}.tar.xz
+
+CARGO_BOOTSTRAP_DIR?= fbeea902d2c9a5be6d99cc35681565d8f7832592
+CARGO_BOOTSTRAP_VERSION?= nightly
+CARGO_BOOTSTRAP= ${CARGO_BOOTSTRAP_DIR}/cargo-${CARGO_BOOTSTRAP_VERSION}-${RUST_TARGET}${EXTRACT_SUFX}
+CARGO_REGISTRY= ${PORTNAME}-registry-${DISTVERSIONFULL}.tar.xz
# We don't USES=cmake here, because cmake is not Cargo's build system.
# It's used by a bundled dependency (libgit2).
BUILD_DEPENDS= cmake:devel/cmake \
- ${RUST_PORT:T}>=1.5.0:${RUST_PORT}
+ ${RUST_PORT:T}>=1.14.0:${RUST_PORT}
LIB_DEPENDS= libssh2.so:security/libssh2 \
libcurl.so:ftp/curl
RUN_DEPENDS= rustc:${RUST_PORT}
@@ -82,13 +84,9 @@ OPTIONS_DEFAULT=BOOTSTRAP
BOOTSTRAP_DESC= Bootstrap using pre-built vendor snapshot
BOOTSTRAP_CONFIGURE_ON= --cargo="${WRKDIR}/${PORTNAME}-nightly-${RUST_TARGET}/cargo/bin/cargo"
BOOTSTRAP_CONFIGURE_OFF=--cargo="$$(command -v cargo)" # respect PATH
-BOOTSTRAP_DISTFILES= ${CARGO_BOOT}:bootstrap
+BOOTSTRAP_DISTFILES= ${CARGO_BOOTSTRAP}:cargo_bootstrap
BOOTSTRAP_MAKE_ENV= LD_LIBRARY_PATH="${WRKSRC}/target/snapshot/cargo/lib"
-post-extract-BOOTSTRAP-on:
- @${MKDIR} ${WRKSRC}/target/dl
- ${LN} -sf ${DISTDIR}/${CARGO_BOOT} ${WRKSRC}/target/dl/
-
post-patch:
# Fix mandir and don't install licenses outside of ${_LICENSE_DIR}
@${REINPLACE_CMD} -e 's,share/man,man,' \
diff --git a/devel/cargo/distinfo b/devel/cargo/distinfo
new file mode 100644
index 000000000000..aee951b3d320
--- /dev/null
+++ b/devel/cargo/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1489831804
+SHA256 (rust/cargo-registry-0.17.0.tar.xz) = 3cd3855141f6d2e24e32c5e49b0db3853fa4c7f0b28421899611ec74c3560a98
+SIZE (rust/cargo-registry-0.17.0.tar.xz) = 21855340
+SHA256 (rust/fbeea902d2c9a5be6d99cc35681565d8f7832592/cargo-nightly-x86_64-unknown-freebsd.tar.gz) = 1982409533dc06e32195325e7dabaf372834665d6ab11a07a0029d04d7e3da4a
+SIZE (rust/fbeea902d2c9a5be6d99cc35681565d8f7832592/cargo-nightly-x86_64-unknown-freebsd.tar.gz) = 4584208
+SHA256 (rust/fbeea902d2c9a5be6d99cc35681565d8f7832592/cargo-nightly-i686-unknown-freebsd.tar.gz) = ed027f7fae62001c6bcc3682143d77faac336acde72aa8e539662bb4c5691259
+SIZE (rust/fbeea902d2c9a5be6d99cc35681565d8f7832592/cargo-nightly-i686-unknown-freebsd.tar.gz) = 4500714
+SHA256 (rust/rust-lang-cargo-0.17.0_GH0.tar.gz) = fc689ca7a09f1e6a1c31e69f0e2616a93576a68e0e1d7f0ae4c0d3301ff21ff8
+SIZE (rust/rust-lang-cargo-0.17.0_GH0.tar.gz) = 638004
+SHA256 (rust/rust-lang-rust-installer-755bc3d_GH0.tar.gz) = 103a502bad7af80eef7ccd2dd2969a272a6fa3f237ebeaca083315a45878f07f
+SIZE (rust/rust-lang-rust-installer-755bc3d_GH0.tar.gz) = 19193
diff --git a/devel/cargo/distinfo.amd64 b/devel/cargo/distinfo.amd64
deleted file mode 100644
index b220bca74917..000000000000
--- a/devel/cargo/distinfo.amd64
+++ /dev/null
@@ -1,9 +0,0 @@
-TIMESTAMP = 1485297292
-SHA256 (cargo-registry-0.15.0_2.tar.xz) = 513eead0d81a73c23a3f3a79cac66370f2e3f1557204965a594088b2a85de050
-SIZE (cargo-registry-0.15.0_2.tar.xz) = 21517360
-SHA256 (2016-11-02/cargo-nightly-x86_64-unknown-freebsd.tar.gz) = 4d5e6203d8f6825debb99b4a9e4c8ac2177c55dd2d13458ad6fb972e947bf933
-SIZE (2016-11-02/cargo-nightly-x86_64-unknown-freebsd.tar.gz) = 4516956
-SHA256 (rust-lang-cargo-0.15.0_GH0.tar.gz) = 6ebe9e0de255d5bd912528bef0f57db7746e162c6d9875a89c6c8b2b40a21d64
-SIZE (rust-lang-cargo-0.15.0_GH0.tar.gz) = 631157
-SHA256 (rust-lang-rust-installer-755bc3d_GH0.tar.gz) = 103a502bad7af80eef7ccd2dd2969a272a6fa3f237ebeaca083315a45878f07f
-SIZE (rust-lang-rust-installer-755bc3d_GH0.tar.gz) = 19193
diff --git a/devel/cargo/distinfo.i386 b/devel/cargo/distinfo.i386
deleted file mode 100644
index c24ad144dda3..000000000000
--- a/devel/cargo/distinfo.i386
+++ /dev/null
@@ -1,9 +0,0 @@
-TIMESTAMP = 1485297292
-SHA256 (cargo-registry-0.15.0_2.tar.xz) = 513eead0d81a73c23a3f3a79cac66370f2e3f1557204965a594088b2a85de050
-SIZE (cargo-registry-0.15.0_2.tar.xz) = 21517360
-SHA256 (2016-11-02/cargo-nightly-i686-unknown-freebsd.tar.gz) = 417084d11dfbb0a37b19cbf8da1950a68e812d2ab60b13996f7c28c1058c8fa3
-SIZE (2016-11-02/cargo-nightly-i686-unknown-freebsd.tar.gz) = 4427612
-SHA256 (rust-lang-cargo-0.15.0_GH0.tar.gz) = 6ebe9e0de255d5bd912528bef0f57db7746e162c6d9875a89c6c8b2b40a21d64
-SIZE (rust-lang-cargo-0.15.0_GH0.tar.gz) = 631157
-SHA256 (rust-lang-rust-installer-755bc3d_GH0.tar.gz) = 103a502bad7af80eef7ccd2dd2969a272a6fa3f237ebeaca083315a45878f07f
-SIZE (rust-lang-rust-installer-755bc3d_GH0.tar.gz) = 19193
diff --git a/devel/cargo/files/patch-Cargo.lock b/devel/cargo/files/patch-Cargo.lock
deleted file mode 100644
index d94fc8cdf2f0..000000000000
--- a/devel/cargo/files/patch-Cargo.lock
+++ /dev/null
@@ -1,168 +0,0 @@
---- Cargo.lock.orig 2016-12-20 21:16:05 UTC
-+++ Cargo.lock
-@@ -19,11 +19,11 @@ dependencies = [
- "hamcrest 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
- "kernel32-sys 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
-- "libgit2-sys 0.6.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "libgit2-sys 0.6.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "log 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "miow 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
- "num_cpus 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
-- "openssl 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "openssl 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "psapi-sys 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "regex 0.1.80 (registry+https://github.com/rust-lang/crates.io-index)",
- "rustc-serialize 0.3.21 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -119,7 +119,7 @@ dependencies = [
- "curl-sys 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
- "openssl-probe 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
-- "openssl-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "openssl-sys 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "winapi 0.2.8 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -131,7 +131,7 @@ dependencies = [
- "gcc 0.3.38 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
- "libz-sys 1.0.10 (registry+https://github.com/rust-lang/crates.io-index)",
-- "openssl-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "openssl-sys 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "pkg-config 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
- "winapi 0.2.8 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-@@ -157,6 +157,11 @@ dependencies = [
- ]
-
- [[package]]
-+name = "error-chain"
-+version = "0.7.2"
-+source = "registry+https://github.com/rust-lang/crates.io-index"
-+
-+[[package]]
- name = "filetime"
- version = "0.1.10"
- source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -204,9 +209,9 @@ source = "registry+https://github.com/ru
- dependencies = [
- "bitflags 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
-- "libgit2-sys 0.6.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "libgit2-sys 0.6.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "openssl-probe 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
-- "openssl-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "openssl-sys 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "url 1.2.3 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -266,7 +271,7 @@ source = "registry+https://github.com/ru
-
- [[package]]
- name = "libgit2-sys"
--version = "0.6.4"
-+version = "0.6.6"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
- "cmake 0.1.18 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -275,7 +280,7 @@ dependencies = [
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
- "libssh2-sys 0.2.4 (registry+https://github.com/rust-lang/crates.io-index)",
- "libz-sys 1.0.10 (registry+https://github.com/rust-lang/crates.io-index)",
-- "openssl-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "openssl-sys 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "pkg-config 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -287,7 +292,7 @@ dependencies = [
- "cmake 0.1.18 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
- "libz-sys 1.0.10 (registry+https://github.com/rust-lang/crates.io-index)",
-- "openssl-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "openssl-sys 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "pkg-config 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -320,6 +325,16 @@ dependencies = [
- ]
-
- [[package]]
-+name = "metadeps"
-+version = "1.1.1"
-+source = "registry+https://github.com/rust-lang/crates.io-index"
-+dependencies = [
-+ "error-chain 0.7.2 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "pkg-config 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "toml 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+]
-+
-+[[package]]
- name = "miniz-sys"
- version = "0.1.7"
- source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -427,13 +442,13 @@ dependencies = [
-
- [[package]]
- name = "openssl"
--version = "0.9.1"
-+version = "0.9.5"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
- "bitflags 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "lazy_static 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
-- "openssl-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "openssl-sys 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
- [[package]]
-@@ -443,12 +458,12 @@ source = "registry+https://github.com/ru
-
- [[package]]
- name = "openssl-sys"
--version = "0.9.1"
-+version = "0.9.5"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
- "gdi32-sys 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
-- "pkg-config 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "metadeps 1.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
- "user32-sys 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -636,6 +651,7 @@ dependencies = [
- "checksum curl-sys 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)" = "218a149208e1f4e5f7e20f1d0ed1e9431a086a6b4333ff95dba82237be9c283a"
- "checksum docopt 0.6.86 (registry+https://github.com/rust-lang/crates.io-index)" = "4a7ef30445607f6fc8720f0a0a2c7442284b629cf0d049286860fae23e71c4d9"
- "checksum env_logger 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)" = "15abd780e45b3ea4f76b4e9a26ff4843258dd8a3eed2775a0e7368c2e7936c2f"
-+"checksum error-chain 0.7.2 (registry+https://github.com/rust-lang/crates.io-index)" = "318cb3c71ee4cdea69fdc9e15c173b245ed6063e1709029e8fd32525a881120f"
- "checksum filetime 0.1.10 (registry+https://github.com/rust-lang/crates.io-index)" = "5363ab8e4139b8568a6237db5248646e5a8a2f89bd5ccb02092182b11fd3e922"
- "checksum flate2 0.2.14 (registry+https://github.com/rust-lang/crates.io-index)" = "3eeb481e957304178d2e782f2da1257f1434dfecbae883bafb61ada2a9fea3bb"
- "checksum fs2 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)" = "640001e1bd865c7c32806292822445af576a6866175b5225aa2087ca5e3de551"
-@@ -649,12 +665,13 @@ dependencies = [
- "checksum kernel32-sys 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "7507624b29483431c0ba2d82aece8ca6cdba9382bff4ddd0f7490560c056098d"
- "checksum lazy_static 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "6abe0ee2e758cd6bc8a2cd56726359007748fbf4128da998b65d0b70f881e19b"
- "checksum libc 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)" = "044d1360593a78f5c8e5e710beccdc24ab71d1f01bc19a29bcacdba22e8475d8"
--"checksum libgit2-sys 0.6.4 (registry+https://github.com/rust-lang/crates.io-index)" = "b4a72539122e79e54cc5c4d5a7a5b53f03b667f7c22c7a0440433e658cf0440f"
-+"checksum libgit2-sys 0.6.6 (registry+https://github.com/rust-lang/crates.io-index)" = "c7a4e33e9f8b8883c1a5898e72cdc63c00c4f2265283651533b00373094e901c"
- "checksum libssh2-sys 0.2.4 (registry+https://github.com/rust-lang/crates.io-index)" = "ed089186abb468a78f7170177304751805e33c20e7aef4b8298884ce2080b5de"
- "checksum libz-sys 1.0.10 (registry+https://github.com/rust-lang/crates.io-index)" = "905c72a0c260bcd89ddca5afa1c46bebd29b52878a3d58c86865ea42402f88e6"
- "checksum log 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)" = "ab83497bf8bf4ed2a74259c1c802351fcd67a65baa86394b6ba73c36f4838054"
- "checksum matches 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)" = "efd7622e3022e1a6eaa602c4cea8912254e5582c9c692e9167714182244801b1"
- "checksum memchr 0.1.11 (registry+https://github.com/rust-lang/crates.io-index)" = "d8b629fb514376c675b98c1421e80b151d3817ac42d7c667717d282761418d20"
-+"checksum metadeps 1.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "829fffe7ea1d747e23f64be972991bc516b2f1ac2ae4a3b33d8bea150c410151"
- "checksum miniz-sys 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)" = "9d1f4d337a01c32e1f2122510fed46393d53ca35a7f429cb0450abaedfa3ed54"
- "checksum miow 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)" = "d5bfc6782530ac8ace97af10a540054a37126b63b0702ddaaa243b73b5745b9a"
- "checksum net2 0.2.26 (registry+https://github.com/rust-lang/crates.io-index)" = "5edf9cb6be97212423aed9413dd4729d62b370b5e1c571750e882cebbbc1e3e2"
-@@ -666,9 +683,9 @@ dependencies = [
- "checksum num-rational 0.1.35 (registry+https://github.com/rust-lang/crates.io-index)" = "54ff603b8334a72fbb27fe66948aac0abaaa40231b3cecd189e76162f6f38aaf"
- "checksum num-traits 0.1.36 (registry+https://github.com/rust-lang/crates.io-index)" = "a16a42856a256b39c6d3484f097f6713e14feacd9bfb02290917904fae46c81c"
- "checksum num_cpus 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "8890e6084723d57d0df8d2720b0d60c6ee67d6c93e7169630e4371e88765dcad"
--"checksum openssl 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)" = "1eb2a714828f5528e4a24a07c296539216f412364844d61fe1161f94558455d4"
-+"checksum openssl 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)" = "6a324049c1cf6496421e033daf0a460bc17cc1de11b421568492e2b1fd57a710"
- "checksum openssl-probe 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "756d49c8424483a3df3b5d735112b4da22109ced9a8294f1f5cdf80fb3810919"
--"checksum openssl-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)" = "95e9fb08acc32509fac299d6e5f4932e1e055bb70d764282c3ed8beaa87ab0e9"
-+"checksum openssl-sys 0.9.5 (registry+https://github.com/rust-lang/crates.io-index)" = "4e38c5a9261a179e63757eee43a1ee63f9033a2e99b8147aa4c245857a995af7"
- "checksum pkg-config 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)" = "8cee804ecc7eaf201a4a207241472cc870e825206f6c031e3ee2a72fa425f2fa"
- "checksum psapi-sys 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "abcd5d1a07d360e29727f757a9decb3ce8bc6e0efa8969cfaad669a8317a2478"
- "checksum rand 0.3.14 (registry+https://github.com/rust-lang/crates.io-index)" = "2791d88c6defac799c3f20d74f094ca33b9332612d9aef9078519c82e4fe04a5"
diff --git a/devel/cargo/files/patch-tests_build-auth.rs b/devel/cargo/files/patch-tests_build-auth.rs
deleted file mode 100644
index 6e127f2c820a..000000000000
--- a/devel/cargo/files/patch-tests_build-auth.rs
+++ /dev/null
@@ -1,20 +0,0 @@
---- tests/build-auth.rs.orig 2016-12-20 21:16:05 UTC
-+++ tests/build-auth.rs
-@@ -41,7 +41,7 @@ fn http_auth_offered() {
- assert_eq!(req, vec![
- "GET /foo/bar/info/refs?service=git-upload-pack HTTP/1.1",
- "Accept: */*",
-- "User-Agent: git/1.0 (libgit2 0.24.0)",
-+ "User-Agent: git/2.0 (libgit2 0.25.0)",
- ].into_iter().map(|s| s.to_string()).collect());
- drop(s);
-
-@@ -56,7 +56,7 @@ fn http_auth_offered() {
- "GET /foo/bar/info/refs?service=git-upload-pack HTTP/1.1",
- "Authorization: Basic Zm9vOmJhcg==",
- "Accept: */*",
-- "User-Agent: git/1.0 (libgit2 0.24.0)",
-+ "User-Agent: git/2.0 (libgit2 0.25.0)",
- ].into_iter().map(|s| s.to_string()).collect());
- });
-
diff --git a/devel/cargo/pkg-plist b/devel/cargo/pkg-plist
index aad7272b1313..81ffe9d167ac 100644
--- a/devel/cargo/pkg-plist
+++ b/devel/cargo/pkg-plist
@@ -3,6 +3,7 @@ etc/bash_completion.d/cargo
lib/rustlib/manifest-cargo
man/man1/cargo-bench.1.gz
man/man1/cargo-build.1.gz
+man/man1/cargo-check.1.gz
man/man1/cargo-clean.1.gz
man/man1/cargo-doc.1.gz
man/man1/cargo-fetch.1.gz