aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgrembo <grembo@FreeBSD.org>2014-11-05 01:49:16 +0800
committergrembo <grembo@FreeBSD.org>2014-11-05 01:49:16 +0800
commit26435bd0406453b9c47d2e7f97aba5fe8b96da5e (patch)
tree57cb5dfce7544d2f58e661722b9f1b2c0bc8d03e /devel
parent4b621c7d14a0c070cad9c78f9478b19488b2ffc4 (diff)
downloadfreebsd-ports-gnome-26435bd0406453b9c47d2e7f97aba5fe8b96da5e.tar.gz
freebsd-ports-gnome-26435bd0406453b9c47d2e7f97aba5fe8b96da5e.tar.zst
freebsd-ports-gnome-26435bd0406453b9c47d2e7f97aba5fe8b96da5e.zip
Remove shadowed variables from header.
See also http://www.zeroc.com/forums/patches/6336-minor-patch-basicstream-h-remove-shadowed-variables.html Approved by: mentors (implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/ice/Makefile2
-rw-r--r--devel/ice/files/patch-cpp-include-Ice-Basicstream.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 9138cfc90b94..c38b4481a817 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Ice
PORTVERSION= 3.5.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://download.zeroc.com/Ice/3.5/
diff --git a/devel/ice/files/patch-cpp-include-Ice-Basicstream.h b/devel/ice/files/patch-cpp-include-Ice-Basicstream.h
new file mode 100644
index 000000000000..e9832fe1132e
--- /dev/null
+++ b/devel/ice/files/patch-cpp-include-Ice-Basicstream.h
@@ -0,0 +1,20 @@
+--- cpp/include/Ice/BasicStream.h.orig 2014-11-04 18:12:19.183757485 +0100
++++ cpp/include/Ice/BasicStream.h 2014-11-04 18:13:37.223886887 +0100
+@@ -964,7 +964,7 @@
+
+ struct InstanceData
+ {
+- InstanceData(InstanceData* previous) : previous(previous), next(0)
++ InstanceData(InstanceData* prev) : previous(prev), next(0)
+ {
+ if(previous)
+ {
+@@ -1123,7 +1123,7 @@
+
+ struct InstanceData
+ {
+- InstanceData(InstanceData* previous) : previous(previous), next(0)
++ InstanceData(InstanceData* prev) : previous(prev), next(0)
+ {
+ if(previous)
+ {