aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-09-06 01:19:21 +0800
committerpi <pi@FreeBSD.org>2016-09-06 01:19:21 +0800
commit2a05b0e943c099e0d1d3a3be4fa05800b2c80ca4 (patch)
tree8e103b7aff18d27d724038ff35f73ec353919465 /devel
parent00c65f4186b5ba3d690f294535a06bf335199356 (diff)
downloadfreebsd-ports-gnome-2a05b0e943c099e0d1d3a3be4fa05800b2c80ca4.tar.gz
freebsd-ports-gnome-2a05b0e943c099e0d1d3a3be4fa05800b2c80ca4.tar.zst
freebsd-ports-gnome-2a05b0e943c099e0d1d3a3be4fa05800b2c80ca4.zip
New port: devel/py-numba
Numba gives you the power to speed up your applications with high performance functions written directly in Python. With a few annotations, array-oriented and math-heavy Python code can be just-in-time compiled to native machine instructions, similar in performance to C, C++ and Fortran, without having to switch languages or Python interpreters. WWW: http://numba.pydata.org/ PR: 211347 Submitted by: David Kalliecharan <dave@dal.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-numba/Makefile33
-rw-r--r--devel/py-numba/distinfo3
-rw-r--r--devel/py-numba/pkg-descr7
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1f88079c2ce3..a4d7a3eb2ef6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4273,6 +4273,7 @@
SUBDIR += py-noseofyeti
SUBDIR += py-notifier
SUBDIR += py-notify
+ SUBDIR += py-numba
SUBDIR += py-ocempgui
SUBDIR += py-ode
SUBDIR += py-odfpy
diff --git a/devel/py-numba/Makefile b/devel/py-numba/Makefile
new file mode 100644
index 000000000000..9315ba9433dc
--- /dev/null
+++ b/devel/py-numba/Makefile
@@ -0,0 +1,33 @@
+# Created by: David Kalliecharan <dave@dal.ca>
+# $FreeBSD$
+
+PORTNAME= numba
+PORTVERSION= 0.28.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dave@dal.ca
+COMMENT= Optimizing compiler for Python using LLVM
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>1.7:math/py-numpy
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}llvmlite>=0.12:devel/py-llvmlite \
+ ${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse
+
+# Uses Python 2.7, 3.4+
+USES= python fortran
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.pre.mk>
+
+# Requried for Python 2.7
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34 \
+ ${PYTHON_PKGNAMEPREFIX}singledispatch>0:devel/py-singledispatch \
+ ${PYTHON_PKGNAMEPREFIX}funcsigs>0:devel/py-funcsigs
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-numba/distinfo b/devel/py-numba/distinfo
new file mode 100644
index 000000000000..22c487a16720
--- /dev/null
+++ b/devel/py-numba/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1473095923
+SHA256 (numba-0.28.1.tar.gz) = d77d58a60acef5e52fb19c724084307f806e5b66d5a05499ae9f6a348c71ae24
+SIZE (numba-0.28.1.tar.gz) = 1124384
diff --git a/devel/py-numba/pkg-descr b/devel/py-numba/pkg-descr
new file mode 100644
index 000000000000..f5524a52be71
--- /dev/null
+++ b/devel/py-numba/pkg-descr
@@ -0,0 +1,7 @@
+Numba gives you the power to speed up your applications with high performance
+functions written directly in Python. With a few annotations, array-oriented
+and math-heavy Python code can be just-in-time compiled to native machine
+instructions, similar in performance to C, C++ and Fortran, without having to
+switch languages or Python interpreters.
+
+WWW: http://numba.pydata.org/