aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-08 06:40:13 +0800
committermiwi <miwi@FreeBSD.org>2009-01-08 06:40:13 +0800
commit2bbfcf85713c9b65894a09c2dbb5520d951d852c (patch)
treec25571bd480a88c6cc8e7cc04de038ffd90c03fa /devel
parente692258cd48179cb55005dd82db54d7bbbe35228 (diff)
downloadfreebsd-ports-gnome-2bbfcf85713c9b65894a09c2dbb5520d951d852c.tar.gz
freebsd-ports-gnome-2bbfcf85713c9b65894a09c2dbb5520d951d852c.tar.zst
freebsd-ports-gnome-2bbfcf85713c9b65894a09c2dbb5520d951d852c.zip
- Update to 0.5.0
PR: 130178 Submitted by: Wen Heping <wenheping@gmail.com> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/pear-PHP_UML/Makefile54
-rw-r--r--devel/pear-PHP_UML/distinfo6
2 files changed, 50 insertions, 10 deletions
diff --git a/devel/pear-PHP_UML/Makefile b/devel/pear-PHP_UML/Makefile
index 5283db44a7d4..cea9ccb6be06 100644
--- a/devel/pear-PHP_UML/Makefile
+++ b/devel/pear-PHP_UML/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PHP_UML
-PORTVERSION= 0.4.4
+PORTVERSION= 0.5.0
CATEGORIES= devel
MAINTAINER= wenheping@gmail.com
@@ -15,9 +15,32 @@ COMMENT= A PEAR Class to Create UML Representation of PHP Code
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+DEFAULT_PHP_VER= 5
+USE_PHP= spl
+
+OPTIONS= PEAR_CONSOLE_COMMANDLINE "PEAR::Console_CommandLine support" off
+
CATEGORY= PHP
-FILES= UML.php UML/Metamodel/EMOF.php \
- UML/Metamodel/PHP.php UML/PHP/Parser.php \
+FILES= UML.php \
+ UML/Exception.php UML/FilePatternFilterIterator.php \
+ UML/SimpleUID.php UML/Warning.php \
+ UML/Metamodel/Class.php UML/Metamodel/Enumeration.php \
+ UML/Metamodel/File.php UML/Metamodel/Interface.php \
+ UML/Metamodel/NamedElement.php UML/Metamodel/Operation.php \
+ UML/Metamodel/Package.php UML/Metamodel/Parameter.php \
+ UML/Metamodel/Property.php UML/Metamodel/Stereotype.php \
+ UML/Metamodel/Superstructure.php UML/Metamodel/Tag.php \
+ UML/Metamodel/Type.php UML/Metamodel/TypedElement.php \
+ UML/Output/common.xsl UML/Output/Exporter.php \
+ UML/Output/html/allclasses-frame.xsl UML/Output/html/classifier.xsl \
+ UML/Output/html/documentation-common.xsl UML/Output/html/documentation-generator.xsl \
+ UML/Output/html/index-all.xsl UML/Output/html/index.xsl \
+ UML/Output/html/main.xsl UML/Output/html/overview-frame.xsl \
+ UML/Output/html/overview-summary.xsl UML/Output/html/package-frame.xsl \
+ UML/Output/html/package-summary.xsl UML/Output/html/resources/inherit.gif \
+ UML/Output/html/resources/style.css UML/Output/php/classifier.xsl \
+ UML/Output/php/code-common.xsl UML/Output/php/code-generator.xsl \
+ UML/Output/php/main.xsl UML/PHP/Parser.php \
UML/XMI/AbstractBuilder.php UML/XMI/Builder.php \
UML/XMI/BuilderImpl1.php UML/XMI/BuilderImpl2.php
DOCS= LOGICIELS_A_UTILISER_AVEC_PHP_UML \
@@ -25,9 +48,11 @@ DOCS= LOGICIELS_A_UTILISER_AVEC_PHP_UML \
PHP_UML_metamodel_class_diagram.png \
PHP_UML_superstructure_class_diagram.png \
README SOFTWARES_TO_USE_WITH_PHP_UML \
- TODO argouml.png bouml.png rational_rose.png
-EXAMPLES= example1_rational_rose.png example2_bouml.png \
- example3_argouml.png test1.php.txt test2.php.txt \
+ TODO argouml.png bouml.png rational_rose.png readme.html
+EXAMPLES= PHP_UML_by_PHP_UML_v1.xmi PHP_UML_by_PHP_UML_v2.xmi \
+ example1_rational_rose.png example2_bouml.png \
+ example3_argouml.png example4_in_Bouml.png \
+ test1.php.txt test2.php.txt \
test3.php.txt test4.php.txt test5_cs.php.txt \
test_to_run.php test_with_api.php
TESTS= UmlParserTest.php UmlXmiTest.php \
@@ -51,6 +76,8 @@ TESTS= UmlParserTest.php UmlXmiTest.php \
suite/test2.php suite/test3.php \
suite/test4.php suite/test5_cs.php \
suite/test_namespace1.php \
+ suite/test_namespace2.php \
+ suite/test_namespace3.php \
suite/data-providers/EMOF_test_sample.php.obj \
suite/data-providers/PHP_UML_test_sample.php.obj \
suite/data-providers/PHP_test_sample.php.obj \
@@ -90,8 +117,21 @@ TESTS= UmlParserTest.php UmlXmiTest.php \
suite/data-providers/test3.php.obj \
suite/data-providers/test4.php.obj \
suite/data-providers/test5_cs.php.obj \
- suite/data-providers/test_namespace1.php.obj
+ suite/data-providers/test_namespace1.php.obj \
+ suite/data-providers/test_namespace2.php.obj \
+ suite/data-providers/test_namespace3.php.obj
+
+DATA= phpuml.xml
+
+SCRIPTFILES= phpuml
+
+post-extract:
+ @${MV} ${WRKSRC}/scripts/phpuml ${WRKSRC}/pear-phpuml
.include <bsd.port.pre.mk>
+.if defined(WITH_PEAR_CONSOLE_COMMANDLINE)
+RUN_DEPENDS+= ${PEARDIR}/Console/CommandLine.php:${PORTSDIR}/devel/pear-Console_CommandLine
+.endif
+
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/devel/pear-PHP_UML/distinfo b/devel/pear-PHP_UML/distinfo
index 2ceb23704bbd..450eac87f78e 100644
--- a/devel/pear-PHP_UML/distinfo
+++ b/devel/pear-PHP_UML/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/PHP_UML-0.4.4.tgz) = 6b64ab7c45f2e657bb0411057382dbc7
-SHA256 (PEAR/PHP_UML-0.4.4.tgz) = d5c36e1c15a3dc85deae1651c600f4b0463650feb4be63a075aac270405b2b17
-SIZE (PEAR/PHP_UML-0.4.4.tgz) = 438167
+MD5 (PEAR/PHP_UML-0.5.0.tgz) = 333fdb1e03ef0f079a05484d7aa2d729
+SHA256 (PEAR/PHP_UML-0.5.0.tgz) = 6e9f886f32d2ccbe114e282a61fb9d06a0e1671b9fa4d5b572e5df61b10ef0ac
+SIZE (PEAR/PHP_UML-0.5.0.tgz) = 513271