aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-11-13 03:09:33 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-11-13 03:09:33 +0800
commit31319b21c3990be1a84470b91524aaaaa5ba386e (patch)
tree1767214b3dbe5478326495e6a8a9e009f39f77a6 /devel
parent71317c545b759aa8fd60c37b415ec7cfbc02371b (diff)
downloadfreebsd-ports-gnome-31319b21c3990be1a84470b91524aaaaa5ba386e.tar.gz
freebsd-ports-gnome-31319b21c3990be1a84470b91524aaaaa5ba386e.tar.zst
freebsd-ports-gnome-31319b21c3990be1a84470b91524aaaaa5ba386e.zip
Add p5-Method-Signatures 20170211
Method::Signatures provides two new keywords, func and method, so that you can write subroutines with signatures instead of having to spell out my $self = shift; my($thing) = @_ func is like sub but takes a signature where the prototype would normally go. This takes the place of my($foo, $bar) = @_ and does a whole lot more. method is like func but specifically for making methods. It will automatically provide the invocant as $self (by default). No more my $self = shift. It also allows signatures, very similar to Perl 6 signatures. It also does type checking, understanding all the types that Moose (or Mouse) would understand. And it does all this with no source filters. WWW: http://search.cpan.org/dist/Method-Signatures/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Method-Signatures/Makefile33
-rw-r--r--devel/p5-Method-Signatures/distinfo3
-rw-r--r--devel/p5-Method-Signatures/pkg-descr18
-rw-r--r--devel/p5-Method-Signatures/pkg-plist8
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f94bdd469826..fdf90b660cc6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2839,6 +2839,7 @@
SUBDIR += p5-Metabase-Client-Simple
SUBDIR += p5-Metabase-Fact
SUBDIR += p5-Method-Alias
+ SUBDIR += p5-Method-Signatures
SUBDIR += p5-Method-Signatures-Simple
SUBDIR += p5-Minilla
SUBDIR += p5-Minion
diff --git a/devel/p5-Method-Signatures/Makefile b/devel/p5-Method-Signatures/Makefile
new file mode 100644
index 000000000000..848c84eb0846
--- /dev/null
+++ b/devel/p5-Method-Signatures/Makefile
@@ -0,0 +1,33 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Method-Signatures
+PORTVERSION= 20170211
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:BAREFOOT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Method and function declarations with signatures and no source filter
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-Any-Moose>=0.11:devel/p5-Any-Moose \
+ p5-Const-Fast>=0.006:devel/p5-Const-Fast \
+ p5-Devel-Declare>=0.006002:devel/p5-Devel-Declare \
+ p5-Lexical-SealRequireHints>=0.008:devel/p5-Lexical-SealRequireHints \
+ p5-Mouse>=0.64:devel/p5-Mouse \
+ p5-PPI>=1.203:textproc/p5-PPI \
+ p5-Sub-Name>=0.03:devel/p5-Sub-Name
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Exception>=0.29:devel/p5-Test-Exception \
+ p5-Test-Warn>=0.10:devel/p5-Test-Warn
+
+NO_ARCH= yes
+USE_PERL5= modbuild
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Method-Signatures/distinfo b/devel/p5-Method-Signatures/distinfo
new file mode 100644
index 000000000000..a1749a0872c8
--- /dev/null
+++ b/devel/p5-Method-Signatures/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510457723
+SHA256 (Method-Signatures-20170211.tar.gz) = 891a7c4bb23240871a50faffa1544a9c54450b776662f489fe0dbc0fad22c4e5
+SIZE (Method-Signatures-20170211.tar.gz) = 83637
diff --git a/devel/p5-Method-Signatures/pkg-descr b/devel/p5-Method-Signatures/pkg-descr
new file mode 100644
index 000000000000..1326d43f0f0c
--- /dev/null
+++ b/devel/p5-Method-Signatures/pkg-descr
@@ -0,0 +1,18 @@
+Method::Signatures provides two new keywords, func and method, so that you can
+write subroutines with signatures instead of having to spell out my $self =
+shift; my($thing) = @_
+
+func is like sub but takes a signature where the prototype would normally go.
+This takes the place of my($foo, $bar) = @_ and does a whole lot more.
+
+method is like func but specifically for making methods. It will automatically
+provide the invocant as $self (by default). No more my $self = shift.
+
+It also allows signatures, very similar to Perl 6 signatures.
+
+It also does type checking, understanding all the types that Moose (or Mouse)
+would understand.
+
+And it does all this with no source filters.
+
+WWW: http://search.cpan.org/dist/Method-Signatures/
diff --git a/devel/p5-Method-Signatures/pkg-plist b/devel/p5-Method-Signatures/pkg-plist
new file mode 100644
index 000000000000..d920ef848100
--- /dev/null
+++ b/devel/p5-Method-Signatures/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Method/Signatures.pm
+%%SITE_PERL%%/Method/Signatures/Modifiers.pm
+%%SITE_PERL%%/Method/Signatures/Parameter.pm
+%%SITE_PERL%%/Method/Signatures/Signature.pm
+%%SITE_PERL%%/Method/Signatures/Types.pm
+%%SITE_PERL%%/Method/Signatures/Utils.pm
+%%PERL5_MAN3%%/Method::Signatures.3.gz
+%%PERL5_MAN3%%/Method::Signatures::Modifiers.3.gz