aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-22 07:12:33 +0800
committeredwin <edwin@FreeBSD.org>2004-12-22 07:12:33 +0800
commit361fa1cd93f6c60413ff2d40cf778aff28c9b82d (patch)
tree642677ec41b6b1bc2e7302814bc7ecbed792c57b /devel
parent4eab2d842e90802575649be94f498495f38ce7d4 (diff)
downloadfreebsd-ports-gnome-361fa1cd93f6c60413ff2d40cf778aff28c9b82d.tar.gz
freebsd-ports-gnome-361fa1cd93f6c60413ff2d40cf778aff28c9b82d.tar.zst
freebsd-ports-gnome-361fa1cd93f6c60413ff2d40cf778aff28c9b82d.zip
[New Port] SimpleTest 1.0RC1, PHP unit testing framework\
Unit testing, mock objects and web testing framework for PHP built around test cases. If you know JUnit or some of the PHPUnit clones this will need no explanation. It also adds JWebUnit style testing including cookies, authentication and form handling WWW: http://sourceforge.net/projects/simpletest/ PR: ports/72061 Submitted by: Roman Neuhauser <neuhauser@chello.cz>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/simpletest/Makefile106
-rw-r--r--devel/simpletest/distinfo2
-rw-r--r--devel/simpletest/pkg-descr6
-rw-r--r--devel/simpletest/pkg-plist75
5 files changed, 190 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 30dfe2a9c6bd..62ada0c04902 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1352,6 +1352,7 @@
SUBDIR += sigslot
SUBDIR += silc-toolkit
SUBDIR += simgear
+ SUBDIR += simpletest
SUBDIR += simulavr
SUBDIR += skalibs
SUBDIR += smc
diff --git a/devel/simpletest/Makefile b/devel/simpletest/Makefile
new file mode 100644
index 000000000000..b57a897644cc
--- /dev/null
+++ b/devel/simpletest/Makefile
@@ -0,0 +1,106 @@
+# Ports collection makefile for: simpletest
+# Date created: 16 August 2004
+# Whom: Roman Neuhauser (<neuhauser@chello.cz>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= SimpleTest
+PORTVERSION= 1.0.r1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}/
+DISTNAME= php_simple_test_1.0RC1
+
+MAINTAINER= neuhauser@chello.cz
+COMMENT= Unit testing, mock objects and web testing framework for PHP
+
+USE_PHP= yes
+
+SIMPLETESTS?= unit
+
+.include <bsd.port.pre.mk>
+
+PHP_CONFIG?= ${LOCALBASE}/bin/php-config
+
+.if !defined(PEARDIR) && exists(${PHP_CONFIG})
+_PEARPREFIX!= ${PHP_CONFIG} --prefix
+_PEARDIR= share/pear
+PEARDIR= ${_PEARPREFIX}/${_PEARDIR}
+.endif
+WRKSRC= ${WRKDIR}/${PORTNAME:L}
+PLIST_SUB+= PEARDIR="${_PEARDIR}"
+.if !defined(NOPORTDOCS)
+DOCS= HELP_MY_TESTS_DONT_WORK_ANYMORE LICENSE README VERSION \
+ docs/expectation_documentation.html \
+ docs/form_testing_documentation.html \
+ docs/group_test_documentation.html \
+ docs/index.html \
+ docs/mock_objects_documentation.html \
+ docs/overview.html \
+ docs/partial_mocks_documentation.html \
+ docs/reporter_documentation.html \
+ docs/server_stubs_documentation.html \
+ docs/unit_test_documentation.html \
+ docs/web_tester_documentation.html
+.endif
+
+TESTS= test/acceptance_test.php \
+ test/adapter_test.php \
+ test/all_tests.php \
+ test/authentication_test.php \
+ test/browser_test.php \
+ test/dumper_test.php \
+ test/errors_test.php \
+ test/expectation_test.php \
+ test/form_test.php \
+ test/frames_test.php \
+ test/http_test.php \
+ test/live_test.php \
+ test/options_test.php \
+ test/page_test.php \
+ test/parser_test.php \
+ test/real_sites_test.php \
+ test/remote_test.php \
+ test/shell_test.php \
+ test/shell_tester_test.php \
+ test/simple_mock_test.php \
+ test/socket_test.php \
+ test/tag_test.php \
+ test/unit_tests.php \
+ test/url_test.php \
+ test/user_agent_test.php \
+ test/visual_test.php \
+ test/web_tester_test.php \
+ test/xml_test.php
+
+CLASSES= authentication.php browser.php dumper.php errors.php \
+ expectation.php extensions/pear_test_case.php \
+ extensions/phpunit_test_case.php form.php frames.php http.php \
+ mock_objects.php options.php page.php parser.php remote.php \
+ reporter.php scorer.php shell_tester.php simple_test.php \
+ socket.php tag.php unit_tester.php url.php user_agent.php \
+ web_tester.php xml.php
+
+pre-patch:
+ ${CP} -r ${WRKSRC}/test ${WRKSRC}/test.beforeinstall
+
+do-build:
+ cd ${WRKSRC}/test.beforeinstall && \
+ ${LOCALBASE}/bin/php -f ${SIMPLETESTS}_tests.php
+
+do-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+ ${MKDIR} ${DATADIR}/test
+.for f in ${TESTS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}/${f}
+.endfor
+ ${MKDIR} ${PEARDIR}/simpletest/extensions
+.for f in ${CLASSES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PEARDIR}/simpletest/${f}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/devel/simpletest/distinfo b/devel/simpletest/distinfo
new file mode 100644
index 000000000000..80c5446be443
--- /dev/null
+++ b/devel/simpletest/distinfo
@@ -0,0 +1,2 @@
+MD5 (php_simple_test_1.0RC1.tar.gz) = 00ec0a4c94e5480c15550039886248c1
+SIZE (php_simple_test_1.0RC1.tar.gz) = 155315
diff --git a/devel/simpletest/pkg-descr b/devel/simpletest/pkg-descr
new file mode 100644
index 000000000000..53c9fb5fb052
--- /dev/null
+++ b/devel/simpletest/pkg-descr
@@ -0,0 +1,6 @@
+Unit testing, mock objects and web testing framework for PHP built
+around test cases. If you know JUnit or some of the PHPUnit clones this
+will need no explanation. It also adds JWebUnit style testing including
+cookies, authentication and form handling
+
+WWW: http://sourceforge.net/projects/simpletest/
diff --git a/devel/simpletest/pkg-plist b/devel/simpletest/pkg-plist
new file mode 100644
index 000000000000..0421bff5c7d9
--- /dev/null
+++ b/devel/simpletest/pkg-plist
@@ -0,0 +1,75 @@
+%%PEARDIR%%/simpletest/authentication.php
+%%PEARDIR%%/simpletest/browser.php
+%%PEARDIR%%/simpletest/dumper.php
+%%PEARDIR%%/simpletest/errors.php
+%%PEARDIR%%/simpletest/expectation.php
+%%PEARDIR%%/simpletest/extensions/pear_test_case.php
+%%PEARDIR%%/simpletest/extensions/phpunit_test_case.php
+%%PEARDIR%%/simpletest/form.php
+%%PEARDIR%%/simpletest/frames.php
+%%PEARDIR%%/simpletest/http.php
+%%PEARDIR%%/simpletest/mock_objects.php
+%%PEARDIR%%/simpletest/options.php
+%%PEARDIR%%/simpletest/page.php
+%%PEARDIR%%/simpletest/parser.php
+%%PEARDIR%%/simpletest/remote.php
+%%PEARDIR%%/simpletest/reporter.php
+%%PEARDIR%%/simpletest/scorer.php
+%%PEARDIR%%/simpletest/shell_tester.php
+%%PEARDIR%%/simpletest/simple_test.php
+%%PEARDIR%%/simpletest/socket.php
+%%PEARDIR%%/simpletest/tag.php
+%%PEARDIR%%/simpletest/unit_tester.php
+%%PEARDIR%%/simpletest/url.php
+%%PEARDIR%%/simpletest/user_agent.php
+%%PEARDIR%%/simpletest/web_tester.php
+%%PEARDIR%%/simpletest/xml.php
+%%PORTDOCS%%%%DOCSDIR%%/HELP_MY_TESTS_DONT_WORK_ANYMORE
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/VERSION
+%%PORTDOCS%%%%DOCSDIR%%/expectation_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/form_testing_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/group_test_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/mock_objects_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/partial_mocks_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/reporter_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/server_stubs_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/unit_test_documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/web_tester_documentation.html
+%%DATADIR%%/test/acceptance_test.php
+%%DATADIR%%/test/adapter_test.php
+%%DATADIR%%/test/all_tests.php
+%%DATADIR%%/test/authentication_test.php
+%%DATADIR%%/test/browser_test.php
+%%DATADIR%%/test/dumper_test.php
+%%DATADIR%%/test/errors_test.php
+%%DATADIR%%/test/expectation_test.php
+%%DATADIR%%/test/form_test.php
+%%DATADIR%%/test/frames_test.php
+%%DATADIR%%/test/http_test.php
+%%DATADIR%%/test/live_test.php
+%%DATADIR%%/test/options_test.php
+%%DATADIR%%/test/page_test.php
+%%DATADIR%%/test/parser_test.php
+%%DATADIR%%/test/real_sites_test.php
+%%DATADIR%%/test/remote_test.php
+%%DATADIR%%/test/shell_test.php
+%%DATADIR%%/test/shell_tester_test.php
+%%DATADIR%%/test/simple_mock_test.php
+%%DATADIR%%/test/socket_test.php
+%%DATADIR%%/test/tag_test.php
+%%DATADIR%%/test/unit_tests.php
+%%DATADIR%%/test/url_test.php
+%%DATADIR%%/test/user_agent_test.php
+%%DATADIR%%/test/visual_test.php
+%%DATADIR%%/test/web_tester_test.php
+%%DATADIR%%/test/xml_test.php
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/test
+@dirrm %%DATADIR%%
+@dirrm %%PEARDIR%%/simpletest/extensions
+@dirrm %%PEARDIR%%/simpletest
+@unexec rmdir %D/%%PEARDIR%% 2>/dev/null || true