aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-11 17:39:38 +0800
committerpav <pav@FreeBSD.org>2006-06-11 17:39:38 +0800
commit366cec4de382acde1d52920945851a03c3491c74 (patch)
tree1b967aa8f0fc2f8b6ad9ace1e524d3dd6c725da1 /devel
parent8e69e0a7289a1e6b8e6f052f4268c83d6521f8e9 (diff)
downloadfreebsd-ports-gnome-366cec4de382acde1d52920945851a03c3491c74.tar.gz
freebsd-ports-gnome-366cec4de382acde1d52920945851a03c3491c74.tar.zst
freebsd-ports-gnome-366cec4de382acde1d52920945851a03c3491c74.zip
COBF (aka C-Obfuscator) is a program which manipulates C or C++ sourcefiles
in a way that they aren't readable by human beings; but they remain compilable. WWW: http://home.arcor.de/bernhard.baier/cobf/ Please note: the 'copyright.txt' disallows patching the sourcecode without explicit permission from the author. Binary packages are not permitted without shipping the source. I contacted the author of COBF (emails available per request) and we are allowed to patch 'src/cpp/makefile' (see 'files/patch-makefile'). He also permits us shipping binary-only packages (because users can obtain the source with 'make fetch' anyway). PR: ports/97264 Submitted by: Ed Schouten <ed@fxq.nl>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cobf/Makefile34
-rw-r--r--devel/cobf/distinfo3
-rw-r--r--devel/cobf/files/patch-makefile26
-rw-r--r--devel/cobf/pkg-descr5
5 files changed, 69 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 415bb36c612f..57af8bddaae0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -150,6 +150,7 @@
SUBDIR += clisp-hyperspec
SUBDIR += cmake
SUBDIR += cmunge
+ SUBDIR += cobf
SUBDIR += cocktail
SUBDIR += codeblocks
SUBDIR += codeville
diff --git a/devel/cobf/Makefile b/devel/cobf/Makefile
new file mode 100644
index 000000000000..d382aaebefd6
--- /dev/null
+++ b/devel/cobf/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cobf
+# Date created: 14 May 2006
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cobf
+PORTVERSION= 1.06
+CATEGORIES= devel
+MASTER_SITES= http://home.arcor.de/bernhard.baier/${PORTNAME}/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ed@fxq.nl
+COMMENT= C and C++ code obfuscator
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}
+PORTDOCS= COPYING README cobf.pdf
+PLIST_FILES= bin/cobf
+
+do-build:
+ @${MAKE} -C ${WRKSRC}/src/cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/cpp/cobf ${PREFIX}/bin/cobf
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/copyright.txt ${DOCSDIR}/COPYING
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/doc/cobf.pdf ${DOCSDIR}/cobf.pdf
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cobf/distinfo b/devel/cobf/distinfo
new file mode 100644
index 000000000000..b133a9df4e53
--- /dev/null
+++ b/devel/cobf/distinfo
@@ -0,0 +1,3 @@
+MD5 (cobf_1.06.zip) = 81443c440586952c7b2f5d49dbd7e56f
+SHA256 (cobf_1.06.zip) = df3902d52c7e0cea0e5ebd7b463d7f991df023ae2be49fc225f4d3ada2e17789
+SIZE (cobf_1.06.zip) = 199444
diff --git a/devel/cobf/files/patch-makefile b/devel/cobf/files/patch-makefile
new file mode 100644
index 000000000000..21803f77f768
--- /dev/null
+++ b/devel/cobf/files/patch-makefile
@@ -0,0 +1,26 @@
+--- src/cpp/makefile Fri Jan 6 18:55:56 2006
++++ src/cpp/makefile Sun May 14 14:23:10 2006
+@@ -3,9 +3,8 @@
+ # Makefile for gcc 3.4.4
+ #
+ #
+-CFLAGS = -Wall -O6 -fomit-frame-pointer -m486 -Dunix -I ../include
++CXXFLAGS += -Dunix -I../include
+ CCFLAGS = -Wall -O6 -fomit-frame-pointer -m486 -Dunix -I ../include
+-LDFLAGS = -lstdc++
+
+ AS =as
+ LD =gcc $(LDFLAGS)
+@@ -32,11 +31,8 @@
+ .cc.o:
+ $(CCC) -c -o $*.o $<
+
+-.cpp.o:
+- $(CCC) -c -o $*.o $<
+-
+ cobf: $(COBF_OBJECTS)
+- $(LD) -o $@ $(COBF_OBJECTS) $(LDFLAGS)
++ $(CXX) -o $@ $(COBF_OBJECTS) $(LDFLAGS)
+
+ clean:
+ -rm *.o
diff --git a/devel/cobf/pkg-descr b/devel/cobf/pkg-descr
new file mode 100644
index 000000000000..c396f03e41f8
--- /dev/null
+++ b/devel/cobf/pkg-descr
@@ -0,0 +1,5 @@
+COBF (aka C-Obfuscator) is a program which manipulates C or C++ sourcefiles
+in a way that they aren't readable by human beings; but they remain
+compilable.
+
+WWW: http://home.arcor.de/bernhard.baier/cobf/