aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-07-23 00:32:19 +0800
committercpm <cpm@FreeBSD.org>2017-07-23 00:32:19 +0800
commit412ef0d70c271ed7bf4023cdf4e7068a2dcd627c (patch)
tree69df34c563613f1d38169606c8b005643f52c57f /devel
parentf27320e617cd30d332ff6ea4b6d42c4af00af2af (diff)
downloadfreebsd-ports-gnome-412ef0d70c271ed7bf4023cdf4e7068a2dcd627c.tar.gz
freebsd-ports-gnome-412ef0d70c271ed7bf4023cdf4e7068a2dcd627c.tar.zst
freebsd-ports-gnome-412ef0d70c271ed7bf4023cdf4e7068a2dcd627c.zip
- Allow concurrent installation (USE_PYTHON=concurrent)
- Add USE_LOCALE - Use do-test - Bump PORTREVISION
Diffstat (limited to 'devel')
-rw-r--r--devel/py-gitless/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/py-gitless/Makefile b/devel/py-gitless/Makefile
index 8d754f0c5b8a..3f16259e3399 100644
--- a/devel/py-gitless/Makefile
+++ b/devel/py-gitless/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gitless
PORTVERSION= 0.8.5
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,11 +20,16 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}clint>=0.3.6:devel/py-clint \
git:devel/git
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
+USE_LOCALE= en_US.UTF-8
USE_GITHUB= yes
GH_ACCOUNT= sdg-mit
NO_ARCH= yes
+do-test:
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
.include <bsd.port.mk>