aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjmd <jmd@FreeBSD.org>2017-10-20 09:34:43 +0800
committerjmd <jmd@FreeBSD.org>2017-10-20 09:34:43 +0800
commit46f476dcb0bac8984c0bdfcc1426d9f0cf56cbe4 (patch)
tree9fdbbc400db91a0285babfc06f8dc568c2464ac9 /devel
parent9a8ab1e6440db136bc3ef26ed09fbe5a899c1146 (diff)
downloadfreebsd-ports-gnome-46f476dcb0bac8984c0bdfcc1426d9f0cf56cbe4.tar.gz
freebsd-ports-gnome-46f476dcb0bac8984c0bdfcc1426d9f0cf56cbe4.tar.zst
freebsd-ports-gnome-46f476dcb0bac8984c0bdfcc1426d9f0cf56cbe4.zip
devel/flang-clang and devel/flang: Upgrade to later snapshots. They bring a lot of fixed bugs inside of flang and support for ejecting AVX512 operations. Removes dependency on lang/openmp since devel/llvm40 brings its own (correct) libomp.so.
Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D12734
Diffstat (limited to 'devel')
-rw-r--r--devel/flang-clang/Makefile10
-rw-r--r--devel/flang-clang/distinfo6
-rw-r--r--devel/flang/Makefile9
-rw-r--r--devel/flang/distinfo6
-rw-r--r--devel/flang/files/patch-CMakeLists.txt18
-rw-r--r--devel/flang/files/patch-runtime_flang_async.c33
-rw-r--r--devel/flang/files/patch-runtime_flang_cdexp.c12
-rw-r--r--devel/flang/files/patch-runtime_flang_cexp.c12
-rw-r--r--devel/flang/files/patch-runtime_flang_stime3f.c2
-rw-r--r--devel/flang/files/patch-runtime_flangrti_dumpregs.h2
-rw-r--r--devel/flang/files/patch-runtime_flangrti_erfc__scaled.c11
-rw-r--r--devel/flang/files/patch-runtime_flangrti_erfc__scaledf.c11
-rw-r--r--devel/flang/files/patch-runtime_flangrti_iostdinit.c4
-rw-r--r--devel/flang/files/patch-runtime_flangrti_trace__lin.c4
-rw-r--r--devel/flang/files/patch-runtime_flangrti_x86__64-Linux_dumpregs.c2
15 files changed, 35 insertions, 107 deletions
diff --git a/devel/flang-clang/Makefile b/devel/flang-clang/Makefile
index 662a48fbba1a..b5de39c31ef1 100644
--- a/devel/flang-clang/Makefile
+++ b/devel/flang-clang/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= flang-clang
-DISTVERSION= 4.0-20170812
+DISTVERSION= 4.0-20171019
PORTREVISION= 1
CATEGORIES= devel lang
@@ -14,10 +14,8 @@ LICENSE_NAME= LLVM Release License
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= llvm40>=0:devel/llvm40 \
- openmp>=0:devel/openmp
-RUN_DEPENDS= llvm40>=0:devel/llvm40 \
- openmp>=0:devel/openmp
+BUILD_DEPENDS= llvm40>=0:devel/llvm40
+RUN_DEPENDS= llvm40>=0:devel/llvm40
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON_amd64= for now only builds and is supported on amd64
@@ -35,7 +33,7 @@ SHEBANG_FILES= tools/scan-view/bin/scan-view \
USE_GITHUB= yes
GH_ACCOUNT= flang-compiler
GH_PROJECT= clang
-GH_TAGNAME= 79d1970
+GH_TAGNAME= 70938ea
CMAKE_ARGS+= -DLLVM_CONFIG=${LOCALBASE}/bin/llvm-config40
diff --git a/devel/flang-clang/distinfo b/devel/flang-clang/distinfo
index 9ed5bdebf2d7..8c5f8adbd65a 100644
--- a/devel/flang-clang/distinfo
+++ b/devel/flang-clang/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1502586432
-SHA256 (flang-compiler-clang-4.0-20170812-79d1970_GH0.tar.gz) = e1b3442b6ccfc9574e0e4479e55b66baf57d957ac1b4652a38e29ae221e51d4f
-SIZE (flang-compiler-clang-4.0-20170812-79d1970_GH0.tar.gz) = 15210102
+TIMESTAMP = 1508451770
+SHA256 (flang-compiler-clang-4.0-20171019-70938ea_GH0.tar.gz) = 6b462819323e3dcd0a34a844582adbfd47936d108be66850bb2e75853c66e354
+SIZE (flang-compiler-clang-4.0-20171019-70938ea_GH0.tar.gz) = 15209610
diff --git a/devel/flang/Makefile b/devel/flang/Makefile
index 294e833fd908..cfee5a61e7fa 100644
--- a/devel/flang/Makefile
+++ b/devel/flang/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= flang
-DISTVERSION= 4.0-20170812
+DISTVERSION= 4.0-20171019
PORTREVISION= 1
CATEGORIES= devel
@@ -13,10 +13,8 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= llvm40>=0:devel/llvm40 \
- openmp>=0:devel/openmp \
flang-clang>=0:devel/flang-clang
RUN_DEPENDS= llvm40>=0:devel/llvm40 \
- openmp>=0:devel/openmp \
flang-clang>=0:devel/flang-clang
ONLY_FOR_ARCHS= amd64
@@ -33,12 +31,13 @@ USES+= ${_USES_PYTHON}
USE_GITHUB= yes
GH_ACCOUNT= flang-compiler
-GH_TAGNAME= f7af78c
+GH_TAGNAME= e68c31f
CMAKE_ARGS+= -DLLVM_CONFIG=${LOCALBASE}/bin/llvm-config40 \
-DCMAKE_CXX_COMPILER=${LOCALBASE}flang/bin/clang++ \
-DCMAKE_C_COMPILER=${LOCALBASE}/flang/bin/clang \
- -DCMAKE_Fortran_COMPILER=${LOCALBASE}/flang/bin/flang
+ -DCMAKE_Fortran_COMPILER=${LOCALBASE}/flang/bin/flang \
+ -DFLANG_LIBOMP=${LOCALBASE}/llvm40/lib/libomp.so
CMAKE_INSTALL_PREFIX= ${PREFIX}/flang
diff --git a/devel/flang/distinfo b/devel/flang/distinfo
index 67c0faa92001..4a28a57de11d 100644
--- a/devel/flang/distinfo
+++ b/devel/flang/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1502586565
-SHA256 (flang-compiler-flang-4.0-20170812-f7af78c_GH0.tar.gz) = 96c38c73f1ed5b3ba45e04232ec4b6ad4fb25a3cc0b1fa48a0036d51ecee1329
-SIZE (flang-compiler-flang-4.0-20170812-f7af78c_GH0.tar.gz) = 3587549
+TIMESTAMP = 1508451863
+SHA256 (flang-compiler-flang-4.0-20171019-e68c31f_GH0.tar.gz) = 5797b5ea4f97f80428c3e918ed4579044a42a94550af5d3ab6603020ed3b9499
+SIZE (flang-compiler-flang-4.0-20171019-e68c31f_GH0.tar.gz) = 3926694
diff --git a/devel/flang/files/patch-CMakeLists.txt b/devel/flang/files/patch-CMakeLists.txt
index 62c8688913b8..784445f72ab8 100644
--- a/devel/flang/files/patch-CMakeLists.txt
+++ b/devel/flang/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2017-07-17 19:12:06 UTC
+--- CMakeLists.txt.orig 2017-10-19 11:03:03 UTC
+++ CMakeLists.txt
-@@ -48,6 +48,19 @@ if( ${TARGET_OS} STREQUAL "Linux" )
+@@ -51,6 +51,19 @@ if( ${TARGET_OS} STREQUAL "Linux" )
message("Unsupported architecture: ${TARGET_ARCHITECTURE}" )
return()
endif()
@@ -20,7 +20,7 @@
else()
message("Unsupported OS: ${TARGET_OS}" )
return()
-@@ -56,7 +69,8 @@ endif()
+@@ -59,7 +72,8 @@ endif()
# The cmake documentation states that these are set. They are not so we
# set them here
set(CMAKE_HOST_SYSTEM_NAME ${TARGET_OS})
@@ -30,12 +30,12 @@
# If we are not building as a part of LLVM, build Flang as an
# standalone project, using LLVM as an external library:
-@@ -292,7 +306,7 @@ endif()
+@@ -296,7 +310,7 @@ endif()
# Add appropriate flags for GCC
if (LLVM_COMPILER_IS_GCC_COMPATIBLE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -fno-common -Woverloaded-virtual -Wcast-qual -fno-strict-aliasing -pedantic -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings")
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-macro-redefined -Wno-logical-not-parentheses -Wno-unknown-warning-option")
- endif ()
-
- if (APPLE)
+- option(WITH_WERROR "Compile with '-Werror' C compiler flag" ON)
++ option(WITH_WERROR "Compile with '-Werror' C compiler flag" OFF)
+ if (WITH_WERROR)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
+ endif ()
diff --git a/devel/flang/files/patch-runtime_flang_async.c b/devel/flang/files/patch-runtime_flang_async.c
index 0b5470515e01..2af5c25a7f9f 100644
--- a/devel/flang/files/patch-runtime_flang_async.c
+++ b/devel/flang/files/patch-runtime_flang_async.c
@@ -1,37 +1,14 @@
---- runtime/flang/async.c.orig 2017-05-17 00:40:01 UTC
+--- runtime/flang/async.c.orig 2017-10-19 11:03:03 UTC
+++ runtime/flang/async.c
-@@ -27,6 +27,8 @@
- * Fio_asy_close - called from close
- */
+@@ -39,9 +39,10 @@
+ #include <errno.h>
+ #endif
+#include <sys/signal.h>
+
- #if !defined(INTERIX86) && !defined(TARGET_INTERIX) && !defined(TARGET_OSX) && !defined(CRAY) && !defined(TARGET_WIN_X8632)
-
- #if !defined(TARGET_WIN_X8664)
-@@ -44,7 +46,6 @@
#include "stdioInterf.h"
#include "async.h"
-
-
+
#define FIO_MAX_ASYNC_TRANSACTIONS 16
- /* one struct per file */
-@@ -320,7 +321,7 @@ Fio_asy_read(struct asy *asy, void *adr,
- asy->aiocb[tn].aio_reqprio = 0;
- asy->aiocb[tn].aio_buf = adr;
- asy->aiocb[tn].aio_nbytes = len;
-- memset(&(asy->aiocb[tn].aio_sigevent), 0, sizeof(sigevent_t));
-+ memset(&(asy->aiocb[tn].aio_sigevent), 0, sizeof(struct sigevent));
- asy->aiocb[tn].aio_offset = asy->atd[tn].off;
- n = aio_read(&(asy->aiocb[tn]));
- #endif
-@@ -374,7 +375,7 @@ Fio_asy_write(struct asy *asy, void *adr
- asy->aiocb[tn].aio_reqprio = 0;
- asy->aiocb[tn].aio_buf = adr;
- asy->aiocb[tn].aio_nbytes = len;
-- memset(&(asy->aiocb[tn].aio_sigevent), 0, sizeof(sigevent_t));
-+ memset(&(asy->aiocb[tn].aio_sigevent), 0, sizeof(struct sigevent));
- asy->aiocb[tn].aio_offset = asy->atd[tn].off;
- n = aio_write(&(asy->aiocb[tn]));
- #endif
diff --git a/devel/flang/files/patch-runtime_flang_cdexp.c b/devel/flang/files/patch-runtime_flang_cdexp.c
deleted file mode 100644
index b56b2e1e769d..000000000000
--- a/devel/flang/files/patch-runtime_flang_cdexp.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- runtime/flang/cdexp.c.orig 2017-05-17 00:40:01 UTC
-+++ runtime/flang/cdexp.c
-@@ -22,7 +22,8 @@ __mth_i_cdexp(dcmplx_t *dcmplx, double r
- {
- double x, y, z;
- x = exp(real);
-- sincos(imag, &z, &y);
-+ z = sin(imag);
-+ y = cos(imag);
- y *= x;
- z *= x;
- d_dummy(y, z); /* should leave y & z in appropriate
diff --git a/devel/flang/files/patch-runtime_flang_cexp.c b/devel/flang/files/patch-runtime_flang_cexp.c
deleted file mode 100644
index b840933d41cd..000000000000
--- a/devel/flang/files/patch-runtime_flang_cexp.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- runtime/flang/cexp.c.orig 2017-05-17 00:40:01 UTC
-+++ runtime/flang/cexp.c
-@@ -22,7 +22,8 @@ __mth_i_cexp(cmplx_t *cmplx, float real,
- {
- float x, y, z;
- x = exp(real);
-- sincosf(imag, &z, &y);
-+ z = sinf(imag);
-+ y = cosf(imag);
- y *= x;
- z *= x;
- r_dummy(y, z); /* should leave y & z in appropriate
diff --git a/devel/flang/files/patch-runtime_flang_stime3f.c b/devel/flang/files/patch-runtime_flang_stime3f.c
index e0d08dd0ded7..4e8bc9a3e7f2 100644
--- a/devel/flang/files/patch-runtime_flang_stime3f.c
+++ b/devel/flang/files/patch-runtime_flang_stime3f.c
@@ -1,4 +1,4 @@
---- runtime/flang/stime3f.c.orig 2017-05-17 00:40:01 UTC
+--- runtime/flang/stime3f.c.orig 2017-10-19 11:03:03 UTC
+++ runtime/flang/stime3f.c
@@ -27,13 +27,7 @@
diff --git a/devel/flang/files/patch-runtime_flangrti_dumpregs.h b/devel/flang/files/patch-runtime_flangrti_dumpregs.h
index 4da25a6133f0..62e0c768540c 100644
--- a/devel/flang/files/patch-runtime_flangrti_dumpregs.h
+++ b/devel/flang/files/patch-runtime_flangrti_dumpregs.h
@@ -1,4 +1,4 @@
---- runtime/flangrti/dumpregs.h.orig 2017-05-17 00:40:01 UTC
+--- runtime/flangrti/dumpregs.h.orig 2017-10-19 11:03:03 UTC
+++ runtime/flangrti/dumpregs.h
@@ -21,6 +21,6 @@
* Declare routines that access the machine registers
diff --git a/devel/flang/files/patch-runtime_flangrti_erfc__scaled.c b/devel/flang/files/patch-runtime_flangrti_erfc__scaled.c
deleted file mode 100644
index adf5b26114e2..000000000000
--- a/devel/flang/files/patch-runtime_flangrti_erfc__scaled.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- runtime/flangrti/erfc_scaled.c.orig 2017-05-17 00:40:01 UTC
-+++ runtime/flangrti/erfc_scaled.c
-@@ -19,7 +19,7 @@
- #pragma global - Mx, 6, 0x100
-
- #include "mthdecls.h"
--#if defined(TARGET_WIN) || defined(win32) || defined(TARGET_OSX)
-+#if defined(TARGET_WIN) || defined(win32) || defined(TARGET_OSX) || defined(__FreeBSD__)
- #include <float.h>
- #else
- #include <values.h>
diff --git a/devel/flang/files/patch-runtime_flangrti_erfc__scaledf.c b/devel/flang/files/patch-runtime_flangrti_erfc__scaledf.c
deleted file mode 100644
index a850b7e8c059..000000000000
--- a/devel/flang/files/patch-runtime_flangrti_erfc__scaledf.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- runtime/flangrti/erfc_scaledf.c.orig 2017-05-17 00:40:01 UTC
-+++ runtime/flangrti/erfc_scaledf.c
-@@ -19,7 +19,7 @@
- #pragma global - Mx, 6, 0x100
-
- #include "mthdecls.h"
--#if defined(TARGET_WIN) || defined(win32) || defined(TARGET_OSX)
-+#if defined(TARGET_WIN) || defined(win32) || defined(TARGET_OSX) || defined(__FreeBSD__)
- #include <float.h>
- #else
- #include <values.h>
diff --git a/devel/flang/files/patch-runtime_flangrti_iostdinit.c b/devel/flang/files/patch-runtime_flangrti_iostdinit.c
index c75ed4e8909d..d1b8bebbc3ac 100644
--- a/devel/flang/files/patch-runtime_flangrti_iostdinit.c
+++ b/devel/flang/files/patch-runtime_flangrti_iostdinit.c
@@ -1,4 +1,4 @@
---- runtime/flangrti/iostdinit.c.orig 2017-05-17 00:40:01 UTC
+--- runtime/flangrti/iostdinit.c.orig 2017-10-19 11:03:03 UTC
+++ runtime/flangrti/iostdinit.c
@@ -160,7 +160,7 @@ __io_ferror(void *p)
int
@@ -9,7 +9,7 @@
}
/* is a tty? */
-@@ -270,14 +270,14 @@ extern long *_imp___timezone_dll; /* for
+@@ -270,14 +270,14 @@ extern long *_imp___timezone_dll; /* for crtdll.dll */
#define timezone _timezone /* cygnus, timezone is usually a function */
#endif
diff --git a/devel/flang/files/patch-runtime_flangrti_trace__lin.c b/devel/flang/files/patch-runtime_flangrti_trace__lin.c
index 353a9b46e037..90675b02beef 100644
--- a/devel/flang/files/patch-runtime_flangrti_trace__lin.c
+++ b/devel/flang/files/patch-runtime_flangrti_trace__lin.c
@@ -1,4 +1,4 @@
---- runtime/flangrti/trace_lin.c.orig 2017-05-17 00:40:01 UTC
+--- runtime/flangrti/trace_lin.c.orig 2017-10-19 11:03:03 UTC
+++ runtime/flangrti/trace_lin.c
@@ -85,7 +85,7 @@ static struct sigs sigs[] = {
{0, CODNULL, NULL} /* end of list */
@@ -11,7 +11,7 @@
@@ -99,7 +99,7 @@ __abort_trace(int skip)
char **strings;
- size_t i, n;
+ size_t i;
- if (regs != (gregset_t *)0) {
+ if (regs != (void *)0) {
diff --git a/devel/flang/files/patch-runtime_flangrti_x86__64-Linux_dumpregs.c b/devel/flang/files/patch-runtime_flangrti_x86__64-Linux_dumpregs.c
index 1b52fb8db1be..25663e437b48 100644
--- a/devel/flang/files/patch-runtime_flangrti_x86__64-Linux_dumpregs.c
+++ b/devel/flang/files/patch-runtime_flangrti_x86__64-Linux_dumpregs.c
@@ -1,4 +1,4 @@
---- runtime/flangrti/x86_64-Linux/dumpregs.c.orig 2017-05-17 00:40:01 UTC
+--- runtime/flangrti/x86_64-Linux/dumpregs.c.orig 2017-10-19 11:03:03 UTC
+++ runtime/flangrti/x86_64-Linux/dumpregs.c
@@ -40,7 +40,7 @@
#define RSP 15