aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-09 23:21:42 +0800
committerultima <ultima@FreeBSD.org>2017-08-09 23:21:42 +0800
commit4bab8544493f2db4993ad16411b50605f9656025 (patch)
treeeec88646b2562f94cc0571737fb57032228e2293 /devel
parentbe21a7f845661413ac8a66bb10c2a1c383bfee49 (diff)
downloadfreebsd-ports-gnome-4bab8544493f2db4993ad16411b50605f9656025.tar.gz
freebsd-ports-gnome-4bab8544493f2db4993ad16411b50605f9656025.tar.zst
freebsd-ports-gnome-4bab8544493f2db4993ad16411b50605f9656025.zip
universal-ctags has the objective of continuing the development from what
existed in the Sourceforge area. Github exuberant-ctags repository was started by Reza Jelveh and was later moved to the universal-ctags organization. The goal of the project is preparing and maintaining common/unified space where people interested in making ctags better can work together. WWW: https://ctags.io/ PR: 220952 Submitted by: <dereks@lifeofadishwasher.com> (maintainer) Reviewed by: matthew (mentor), koobs, mat Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D11893
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/universal-ctags/Makefile59
-rw-r--r--devel/universal-ctags/distinfo3
-rw-r--r--devel/universal-ctags/pkg-descr8
4 files changed, 71 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8bcb4bcd7a0d..6205b38aa21d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5981,6 +5981,7 @@
SUBDIR += umlgraph
SUBDIR += unibilium
SUBDIR += unittest-cpp
+ SUBDIR += universal-ctags
SUBDIR += universalindentgui
SUBDIR += upnp
SUBDIR += upp
diff --git a/devel/universal-ctags/Makefile b/devel/universal-ctags/Makefile
new file mode 100644
index 000000000000..43e3f825b577
--- /dev/null
+++ b/devel/universal-ctags/Makefile
@@ -0,0 +1,59 @@
+# Created by: Derek Schrock <dereks@lifeofadishwasher.com>
+# $FreeBSD$
+
+PORTNAME= universal-ctags
+PORTVERSION= g20170718
+CATEGORIES= devel
+
+MAINTAINER= dereks@lifeofadishwasher.com
+COMMENT= Fork of Exuberant Ctags to generate index/tag files
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf pkgconfig
+GNU_CONFIGURE= yes
+
+USE_GITHUB= YES
+GH_PROJECT= ctags
+GH_TAGNAME= 5567535e
+
+OPTIONS_DEFINE= ASPELL DEBUG ICONV JSON LIBXML2 MANPAGES YAML
+OPTIONS_DEFAULT= ICONV JSON LIBXML2 MANPAGES YAML
+
+JSON_DESC= JSON output support
+
+ASPELL_CONFIGURE_ENABLE= aspell
+# textproc/aspell does not install a aspell.pc file
+ASPELL_CONFIGURE_ENV= ASPELL_LIBS="-L${LOCALBASE}/lib -laspell" \
+ ASPELL_CFLAGS="-I${LOCALBASE}/include"
+ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
+
+DEBUG_CONFIGURE_ENABLE= debugging
+
+ICONV_CONFIGURE_ENABLE= iconv
+ICONV_USES= iconv
+
+# Extra support for YAML and XML based languages
+LIBXML2_CONFIGURE_ENABLE= xml
+LIBXML2_LIB_DEPENDS= libxml2.so:textproc/libxml2
+
+JSON_CONFIGURE_ENABLE= json
+JSON_LIB_DEPENDS= libjansson.so:devel/jansson
+
+MANPAGES_BUILD_DEPENDS= rst2man:textproc/py-docutils
+MANPAGES_PLIST_FILES= man/man1/ctags.1.gz \
+ man/man7/ctags-incompatibilities.7.gz \
+ man/man7/ctags-optlib.7.gz
+
+YAML_CONFIGURE_ENABLE= yaml
+YAML_LIB_DEPENDS= libyaml.so:textproc/libyaml
+
+PLIST_FILES= bin/ctags \
+ bin/readtags
+
+pre-configure:
+ # test-case.mak is generated by autogen.sh disable it for building
+ @${REINPLACE_CMD} -e '/^include.*\/test-cases\.mak$$/s/^/#/' ${WRKSRC}/Makefile.am
+
+.include <bsd.port.mk>
diff --git a/devel/universal-ctags/distinfo b/devel/universal-ctags/distinfo
new file mode 100644
index 000000000000..8c20a499bd99
--- /dev/null
+++ b/devel/universal-ctags/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502243666
+SHA256 (universal-ctags-ctags-g20170718-5567535e_GH0.tar.gz) = 9b0f71c05fd067d7f9c7c8b320c3383f2eaacb6f3cff131c5624363dc5fe104c
+SIZE (universal-ctags-ctags-g20170718-5567535e_GH0.tar.gz) = 1301783
diff --git a/devel/universal-ctags/pkg-descr b/devel/universal-ctags/pkg-descr
new file mode 100644
index 000000000000..71e9cbf2f7e2
--- /dev/null
+++ b/devel/universal-ctags/pkg-descr
@@ -0,0 +1,8 @@
+universal-ctags has the objective of continuing the development from what
+existed in the Sourceforge area. Github exuberant-ctags repository was
+started by Reza Jelveh and was later moved to the universal-ctags organization.
+
+The goal of the project is preparing and maintaining common/unified space
+where people interested in making ctags better can work together.
+
+WWW: https://ctags.io/