aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-03 21:25:07 +0800
committerpav <pav@FreeBSD.org>2006-05-03 21:25:07 +0800
commit57c04beb7033430b70edf713823ab1360da084a6 (patch)
tree0d1965cff36464917e8b13f19e9dc175205abec8 /devel
parent35ea1e3f5481f0aa4970badeab48cdde17a3ac0d (diff)
downloadfreebsd-ports-gnome-57c04beb7033430b70edf713823ab1360da084a6.tar.gz
freebsd-ports-gnome-57c04beb7033430b70edf713823ab1360da084a6.tar.zst
freebsd-ports-gnome-57c04beb7033430b70edf713823ab1360da084a6.zip
- Switch lua dependency to lang/lua50
Diffstat (limited to 'devel')
-rw-r--r--devel/lua-filename/Makefile2
-rw-r--r--devel/lua-posix/Makefile2
-rw-r--r--devel/lua-pty/Makefile4
-rw-r--r--devel/lua50-app/Makefile4
-rw-r--r--devel/lua50-compat51/Makefile2
-rw-r--r--devel/lua50-dfui/Makefile4
-rw-r--r--devel/lua50-filename/Makefile2
-rw-r--r--devel/lua50-posix/Makefile2
-rw-r--r--devel/lua50-pty/Makefile4
9 files changed, 13 insertions, 13 deletions
diff --git a/devel/lua-filename/Makefile b/devel/lua-filename/Makefile
index 3950ecb5e739..7b97eb46dc89 100644
--- a/devel/lua-filename/Makefile
+++ b/devel/lua-filename/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY=
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Filename-manipulating functions for Lua 5.0.x
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/devel/lua-posix/Makefile b/devel/lua-posix/Makefile
index 0e10e63b3bbc..26bfcb0a2000 100644
--- a/devel/lua-posix/Makefile
+++ b/devel/lua-posix/Makefile
@@ -14,7 +14,7 @@ DISTFILES= lposix.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= A POSIX layer for Lua
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/posix
diff --git a/devel/lua-pty/Makefile b/devel/lua-pty/Makefile
index fa29708e8764..4758f2e58cbf 100644
--- a/devel/lua-pty/Makefile
+++ b/devel/lua-pty/Makefile
@@ -14,9 +14,9 @@ DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
LIBDIR= ${PREFIX}/lib/lua/5.0
diff --git a/devel/lua50-app/Makefile b/devel/lua50-app/Makefile
index 1407900a2665..ea99ea2fe84d 100644
--- a/devel/lua50-app/Makefile
+++ b/devel/lua50-app/Makefile
@@ -16,8 +16,8 @@ EXTRACT_ONLY=
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= App framework for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/posix.lua:${PORTSDIR}/devel/lua50-posix \
${LOCALBASE}/share/lua/5.0/filename.lua:${PORTSDIR}/devel/lua50-filename \
${LOCALBASE}/share/lua/5.0/pty.lua:${PORTSDIR}/devel/lua50-pty
diff --git a/devel/lua50-compat51/Makefile b/devel/lua50-compat51/Makefile
index 81184fe7f65b..a4b7d5a7b8dc 100644
--- a/devel/lua50-compat51/Makefile
+++ b/devel/lua50-compat51/Makefile
@@ -14,7 +14,7 @@ DISTNAME= compat-${CVER}${CREV}.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Lua 5.1 package compatibility layer for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
CONFLICTS= luasocket-2.0
diff --git a/devel/lua50-dfui/Makefile b/devel/lua50-dfui/Makefile
index fbf19ecc6f43..6901938edb6f 100644
--- a/devel/lua50-dfui/Makefile
+++ b/devel/lua50-dfui/Makefile
@@ -16,10 +16,10 @@ DISTNAME= lua-dfui-0.1.20050901
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= DFUI binding for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
LIB_DEPENDS= dfui4.4:${PORTSDIR}/devel/libdfui
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51 \
${LOCALBASE}/share/lua/5.0/posix.lua:${PORTSDIR}/devel/lua50-posix
diff --git a/devel/lua50-filename/Makefile b/devel/lua50-filename/Makefile
index 3950ecb5e739..7b97eb46dc89 100644
--- a/devel/lua50-filename/Makefile
+++ b/devel/lua50-filename/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY=
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Filename-manipulating functions for Lua 5.0.x
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/devel/lua50-posix/Makefile b/devel/lua50-posix/Makefile
index 0e10e63b3bbc..26bfcb0a2000 100644
--- a/devel/lua50-posix/Makefile
+++ b/devel/lua50-posix/Makefile
@@ -14,7 +14,7 @@ DISTFILES= lposix.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= A POSIX layer for Lua
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/posix
diff --git a/devel/lua50-pty/Makefile b/devel/lua50-pty/Makefile
index fa29708e8764..4758f2e58cbf 100644
--- a/devel/lua50-pty/Makefile
+++ b/devel/lua50-pty/Makefile
@@ -14,9 +14,9 @@ DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
LIBDIR= ${PREFIX}/lib/lua/5.0