aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-09-16 18:28:14 +0800
committerjbeich <jbeich@FreeBSD.org>2015-09-16 18:28:14 +0800
commit62209de0cda8ab3cb9406750c61fd1c59700cc7d (patch)
treeb6b6772e5fb4047e6bb0db0f4f14a5dd60bf9ac7 /devel
parent6c4daf404a425d10523c778d29d3545ab6d6d504 (diff)
downloadfreebsd-ports-gnome-62209de0cda8ab3cb9406750c61fd1c59700cc7d.tar.gz
freebsd-ports-gnome-62209de0cda8ab3cb9406750c61fd1c59700cc7d.tar.zst
freebsd-ports-gnome-62209de0cda8ab3cb9406750c61fd1c59700cc7d.zip
devel/libmtdev: add new port
PR: 196978 Approved by: hselasky mtdev is a stand-alone library which transforms all variants of kernel MT events to the slotted type B protocol. The events put into mtdev may be from any MT device, specifically type A without contact tracking, type A with contact tracking, or type B with contact tracking. See Linux kernel documentation for further details. http://bitmath.org/code/mtdev/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libmtdev/Makefile24
-rw-r--r--devel/libmtdev/distinfo2
-rw-r--r--devel/libmtdev/files/patch-src_common.h11
-rw-r--r--devel/libmtdev/pkg-descr7
-rw-r--r--devel/libmtdev/pkg-plist9
6 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cbe4e645e0b2..d418277bd8eb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1214,6 +1214,7 @@
SUBDIR += libmpsse
SUBDIR += libmsiecf
SUBDIR += libmsocket
+ SUBDIR += libmtdev
SUBDIR += libmtrie
SUBDIR += libnaji
SUBDIR += libnfc
diff --git a/devel/libmtdev/Makefile b/devel/libmtdev/Makefile
new file mode 100644
index 000000000000..ec8d52b8401f
--- /dev/null
+++ b/devel/libmtdev/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= mtdev
+PORTVERSION= 1.1.5
+CATEGORIES= devel
+MASTER_SITES= http://bitmath.org/code/${PORTNAME}/
+PKGNAMEPREFIX= lib
+
+MAINTAINER= hselasky@FreeBSD.org
+COMMENT= Multitouch Protocol Translation Library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
+RUN_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
+
+USES= libtool pathfix tar:bz2
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include # v4l_compat
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libmtdev/distinfo b/devel/libmtdev/distinfo
new file mode 100644
index 000000000000..f5144f7e14e4
--- /dev/null
+++ b/devel/libmtdev/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mtdev-1.1.5.tar.bz2) = 6677d5708a7948840de734d8b4675d5980d4561171c5a8e89e54adf7a13eba7f
+SIZE (mtdev-1.1.5.tar.bz2) = 274162
diff --git a/devel/libmtdev/files/patch-src_common.h b/devel/libmtdev/files/patch-src_common.h
new file mode 100644
index 000000000000..3c9b4cdd5c32
--- /dev/null
+++ b/devel/libmtdev/files/patch-src_common.h
@@ -0,0 +1,11 @@
+--- src/common.h.orig 2013-07-31 17:25:50 UTC
++++ src/common.h
+@@ -33,7 +33,7 @@
+
+ #include <mtdev-mapping.h>
+ #include <mtdev-plumbing.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
+
diff --git a/devel/libmtdev/pkg-descr b/devel/libmtdev/pkg-descr
new file mode 100644
index 000000000000..681f1dbfe030
--- /dev/null
+++ b/devel/libmtdev/pkg-descr
@@ -0,0 +1,7 @@
+mtdev is a stand-alone library which transforms all variants of kernel
+MT events to the slotted type B protocol. The events put into mtdev
+may be from any MT device, specifically type A without contact
+tracking, type A with contact tracking, or type B with contact
+tracking. See Linux kernel documentation for further details.
+
+WWW: http://bitmath.org/code/mtdev/
diff --git a/devel/libmtdev/pkg-plist b/devel/libmtdev/pkg-plist
new file mode 100644
index 000000000000..4622ac1ae121
--- /dev/null
+++ b/devel/libmtdev/pkg-plist
@@ -0,0 +1,9 @@
+bin/mtdev-test
+include/mtdev-mapping.h
+include/mtdev-plumbing.h
+include/mtdev.h
+lib/libmtdev.a
+lib/libmtdev.so
+lib/libmtdev.so.1
+lib/libmtdev.so.1.0.0
+libdata/pkgconfig/mtdev.pc