aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2017-09-30 00:06:29 +0800
committermartymac <martymac@FreeBSD.org>2017-09-30 00:06:29 +0800
commit6542aaa5c772aee26a95c52eccead99616b93814 (patch)
tree662202327b69a97dc79fd99e005243c5db2034e6 /devel
parent639de6722492033cc0ef74d8cc31caf0bf8a9dee (diff)
downloadfreebsd-ports-gnome-6542aaa5c772aee26a95c52eccead99616b93814.tar.gz
freebsd-ports-gnome-6542aaa5c772aee26a95c52eccead99616b93814.tar.zst
freebsd-ports-gnome-6542aaa5c772aee26a95c52eccead99616b93814.zip
Update Simgear and Flightgear ports to 2017.3.1
Diffstat (limited to 'devel')
-rw-r--r--devel/simgear/Makefile3
-rw-r--r--devel/simgear/distinfo6
-rw-r--r--devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.cxx27
-rw-r--r--devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.hxx20
-rw-r--r--devel/simgear/pkg-plist7
5 files changed, 11 insertions, 52 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index ec25d0cb0461..bc164bc25aae 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= simgear
-PORTVERSION= 2017.1.3
-PORTREVISION= 8
+PORTVERSION= 2017.3.1
CATEGORIES= devel games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index 3aa1adc263c2..cf42a245112b 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491386012
-SHA256 (simgear-2017.1.3.tar.bz2) = 85304d985b4fc0dc00d9f7603b02d096e3c24ca4c98adc18dc9af1e2d0e3c310
-SIZE (simgear-2017.1.3.tar.bz2) = 1235062
+TIMESTAMP = 1506362997
+SHA256 (simgear-2017.3.1.tar.bz2) = 0ee08550b737b249dcc91590ec0cb9c5dc9080998f6ba66a7d7209cdfce6e1f4
+SIZE (simgear-2017.3.1.tar.bz2) = 1302704
diff --git a/devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.cxx b/devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.cxx
deleted file mode 100644
index 5f7636158c6e..000000000000
--- a/devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.cxx
+++ /dev/null
@@ -1,27 +0,0 @@
---- simgear/scene/material/Effect.cxx.orig 2017-04-04 09:24:44.000000000 +0200
-+++ simgear/scene/material/Effect.cxx 2017-07-16 21:55:10.888904000 +0200
-@@ -32,7 +32,7 @@
- #include <map>
- #include <queue>
- #include <utility>
--#include <boost/tr1/unordered_map.hpp>
-+#include <unordered_map>
-
- #include <boost/bind.hpp>
- #include <boost/foreach.hpp>
-@@ -832,13 +832,13 @@
-
- // XXX Should these be protected by a mutex? Probably
-
--typedef tr1::unordered_map<ProgramKey, ref_ptr<Program>,
-+typedef std::unordered_map<ProgramKey, ref_ptr<Program>,
- boost::hash<ProgramKey>, ProgramKey::EqualTo>
- ProgramMap;
- ProgramMap programMap;
- ProgramMap resolvedProgramMap; // map with resolved shader file names
-
--typedef tr1::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
-+typedef std::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
- ShaderMap;
- ShaderMap shaderMap;
-
diff --git a/devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.hxx b/devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.hxx
deleted file mode 100644
index 3d6b87137864..000000000000
--- a/devel/simgear/files/patch-BOOST-simgear-scene-material-Effect.hxx
+++ /dev/null
@@ -1,20 +0,0 @@
---- simgear/scene/material/Effect.hxx.orig 2017-04-04 09:24:44.000000000 +0200
-+++ simgear/scene/material/Effect.hxx 2017-07-16 21:55:33.247324000 +0200
-@@ -19,7 +19,7 @@
-
- #include <vector>
- #include <string>
--#include <boost/tr1/unordered_map.hpp>
-+#include <unordered_map>
-
- #include <boost/functional/hash.hpp>
-
-@@ -127,7 +127,7 @@
- bool operator()(const Key& lhs, const Key& rhs) const;
- };
- };
-- typedef std::tr1::unordered_map<Key, osg::observer_ptr<Effect>,
-+ typedef std::unordered_map<Key, osg::observer_ptr<Effect>,
- boost::hash<Key>, Key::EqualTo> Cache;
- Cache* getCache()
- {
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index a028dfeb46c8..1056ce64df41 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -61,6 +61,8 @@ include/simgear/constants.h
include/simgear/debug/BufferedLogCallback.hxx
include/simgear/debug/debug_types.h
include/simgear/debug/logstream.hxx
+include/simgear/embedded_resources/EmbeddedResource.hxx
+include/simgear/embedded_resources/EmbeddedResourceManager.hxx
include/simgear/environment/metar.hxx
include/simgear/environment/precipitation.hxx
include/simgear/ephemeris/celestialBody.hxx
@@ -86,6 +88,8 @@ include/simgear/io/HTTPMemoryRequest.hxx
include/simgear/io/HTTPRepository.hxx
include/simgear/io/HTTPRequest.hxx
include/simgear/io/iochannel.hxx
+include/simgear/io/iostreams/CharArrayStream.hxx
+include/simgear/io/iostreams/zlibstream.hxx
include/simgear/io/lowlevel.hxx
include/simgear/io/raw_socket.hxx
include/simgear/io/sg_binobj.hxx
@@ -136,6 +140,7 @@ include/simgear/misc/ListDiff.hxx
include/simgear/misc/ResourceManager.hxx
include/simgear/misc/SVGpreserveAspectRatio.hxx
include/simgear/misc/SimpleMarkdown.hxx
+include/simgear/misc/argparse.hxx
include/simgear/misc/interpolator.hxx
include/simgear/misc/make_new.hxx
include/simgear/misc/sg_dir.hxx
@@ -145,6 +150,7 @@ include/simgear/misc/stdint.hxx
include/simgear/misc/stopwatch.hxx
include/simgear/misc/strutils.hxx
include/simgear/misc/tabbed_values.hxx
+include/simgear/misc/test_macros.hxx
include/simgear/misc/texcoord.hxx
include/simgear/nasal/cppbind/Ghost.hxx
include/simgear/nasal/cppbind/NasalCallContext.hxx
@@ -273,6 +279,7 @@ include/simgear/scene/util/SGSceneFeatures.hxx
include/simgear/scene/util/SGSceneUserData.hxx
include/simgear/scene/util/SGStateAttributeVisitor.hxx
include/simgear/scene/util/SGTextureStateAttributeVisitor.hxx
+include/simgear/scene/util/SGTransientModelData.hxx
include/simgear/scene/util/SGUpdateVisitor.hxx
include/simgear/scene/util/SplicingVisitor.hxx
include/simgear/scene/util/StateAttributeFactory.hxx