aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-11-20 00:16:46 +0800
committerdanfe <danfe@FreeBSD.org>2015-11-20 00:16:46 +0800
commit69ec36ee8794805f5d5f82c20ff6189f46e294cf (patch)
treefb000666405736d4d4425c9082b373a8ce0fa5ab /devel
parent78fb08d2d8251a79015d384dd156db6b495398c4 (diff)
downloadfreebsd-ports-gnome-69ec36ee8794805f5d5f82c20ff6189f46e294cf.tar.gz
freebsd-ports-gnome-69ec36ee8794805f5d5f82c20ff6189f46e294cf.tar.zst
freebsd-ports-gnome-69ec36ee8794805f5d5f82c20ff6189f46e294cf.zip
Flush a short queue of minor non-functional changes sitting it my tree:
- Escape literal dot properly in sed(1) code (for REINPLACE_CMD) - Spell "C-string" correctly in COMMENT and add a missing newline - Use NULL for pointer in C code (original snippet was for C++ and Bjarne prefers to avoid macros, per his C++ Style and Technique FAQ)
Diffstat (limited to 'devel')
-rw-r--r--devel/bbfreeze/Makefile2
-rw-r--r--devel/stringencoders/Makefile3
2 files changed, 3 insertions, 2 deletions
diff --git a/devel/bbfreeze/Makefile b/devel/bbfreeze/Makefile
index 29ec6f73bba0..60066ae76c0f 100644
--- a/devel/bbfreeze/Makefile
+++ b/devel/bbfreeze/Makefile
@@ -23,7 +23,7 @@ PORTDOCS= *
post-patch:
@${REINPLACE_CMD} -e '/altgraph/s,==,>=,' ${WRKSRC}/${PYSETUP}
- @${REINPLACE_CMD} -e '/from altgraph.compat import/d' \
+ @${REINPLACE_CMD} -e '/from altgraph\.compat import/d' \
${WRKSRC}/bbfreeze/modulegraph/modulegraph.py
post-install:
diff --git a/devel/stringencoders/Makefile b/devel/stringencoders/Makefile
index e19544c06309..6a7fd9f714f8 100644
--- a/devel/stringencoders/Makefile
+++ b/devel/stringencoders/Makefile
@@ -9,11 +9,12 @@ CATEGORIES= devel
MASTER_SITES= GOOGLE_CODE
MAINTAINER= skreuzer@FreeBSD.org
-COMMENT= Collection of high performance c-string transformations
+COMMENT= Collection of high performance C-string transformations
USES= libtool perl5
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+
CFLAGS+= -fsigned-char # chars are unsigned on PowerPC and ARM
.include <bsd.port.mk>