aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrpaulo <rpaulo@FreeBSD.org>2014-07-06 03:17:41 +0800
committerrpaulo <rpaulo@FreeBSD.org>2014-07-06 03:17:41 +0800
commit6b23eb8ddd706cba7f2e0c8cce1aed03613318bb (patch)
treec1fd31ac76088aca9dc290031cdc8c56cd518693 /devel
parentf2934f81eededb8e3485eca925041c0c353442a8 (diff)
downloadfreebsd-ports-gnome-6b23eb8ddd706cba7f2e0c8cce1aed03613318bb.tar.gz
freebsd-ports-gnome-6b23eb8ddd706cba7f2e0c8cce1aed03613318bb.tar.zst
freebsd-ports-gnome-6b23eb8ddd706cba7f2e0c8cce1aed03613318bb.zip
hgreviewboard: fix the json import
Newer Python versions include a json module, but hgreviewboard tries to use the simplejson module included in its tarball. We don't install the included simplejson module, so fix the import line. Reviewed by: bapt
Diffstat (limited to 'devel')
-rw-r--r--devel/hgreviewboard/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/hgreviewboard/Makefile b/devel/hgreviewboard/Makefile
index d7623ce08f3b..f3fa4b0c7c9d 100644
--- a/devel/hgreviewboard/Makefile
+++ b/devel/hgreviewboard/Makefile
@@ -2,6 +2,7 @@
PORTNAME= hgreviewboard
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= https://bitbucket.org/ccaughie/hgreviewboard/get/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,6 +22,10 @@ USE_PYTHON= yes
NO_BUILD= yes
+post-patch:
+ ${SED} -i '' -e 's/import simplejson/import json as simplejson/' \
+ ${WRKSRC}/reviewboard.py
+
do-install:
${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/reviewboard
${INSTALL_DATA} ${WRKSRC}/__init__.py \