aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2017-12-22 21:45:31 +0800
committerolgeni <olgeni@FreeBSD.org>2017-12-22 21:45:31 +0800
commit6d69b1170eed578cfeb351718c8e0ac4c19a67fc (patch)
tree2b1c623d26b27af5edf45f0685bfbf75929d9102 /devel
parente1b5062db79cdbd6f4c66545c4eea21d39c55666 (diff)
downloadfreebsd-ports-gnome-6d69b1170eed578cfeb351718c8e0ac4c19a67fc.tar.gz
freebsd-ports-gnome-6d69b1170eed578cfeb351718c8e0ac4c19a67fc.tar.zst
freebsd-ports-gnome-6d69b1170eed578cfeb351718c8e0ac4c19a67fc.zip
Add devel/py-pyfcm, a Python client for Firebase Cloud Messaging.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyfcm/Makefile21
-rw-r--r--devel/py-pyfcm/distinfo3
-rw-r--r--devel/py-pyfcm/files/patch-README.rst13
-rw-r--r--devel/py-pyfcm/pkg-descr3
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 332ba9e90246..a3a8ebbef067 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4720,6 +4720,7 @@
SUBDIR += py-pyelftools
SUBDIR += py-pyev
SUBDIR += py-pyface
+ SUBDIR += py-pyfcm
SUBDIR += py-pyflakes
SUBDIR += py-pygdbmi
SUBDIR += py-pygit2
diff --git a/devel/py-pyfcm/Makefile b/devel/py-pyfcm/Makefile
new file mode 100644
index 000000000000..496d9a42f957
--- /dev/null
+++ b/devel/py-pyfcm/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pyfcm
+PORTVERSION= 1.4.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= olgeni@FreeBSD.org
+
+COMMENT= Python client for Firebase Cloud Messaging
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyfcm/distinfo b/devel/py-pyfcm/distinfo
new file mode 100644
index 000000000000..b9b4f093864c
--- /dev/null
+++ b/devel/py-pyfcm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513940242
+SHA256 (pyfcm-1.4.3.tar.gz) = dd66f890ea20178eaaa274d781809b672187d76b10f56cf7cbe4d54c8b6a01b0
+SIZE (pyfcm-1.4.3.tar.gz) = 15209
diff --git a/devel/py-pyfcm/files/patch-README.rst b/devel/py-pyfcm/files/patch-README.rst
new file mode 100644
index 000000000000..63d4a55751da
--- /dev/null
+++ b/devel/py-pyfcm/files/patch-README.rst
@@ -0,0 +1,13 @@
+--- README.rst.orig 2017-10-18 23:26:43 UTC
++++ README.rst
+@@ -119,8 +119,8 @@ Send a data message.
+ # To send extra kwargs (keyword arguments not provided in any of the methods),
+ # pass it as a key value in a dictionary to the method being used
+ extra_kwargs = {
+-        'priority': 'high'
+-   }
++ 'priority': 'high'
++ }
+ result = push_service.notify_single_device(registration_id=registration_id, data_message=data_message, extra_kwargs=extra_kwargs)
+
+ # To process background notifications in iOS 10, set content_available
diff --git a/devel/py-pyfcm/pkg-descr b/devel/py-pyfcm/pkg-descr
new file mode 100644
index 000000000000..bf5300449e09
--- /dev/null
+++ b/devel/py-pyfcm/pkg-descr
@@ -0,0 +1,3 @@
+Python client for FCM - Firebase Cloud Messaging (Android & iOS)
+
+WWW: http://olucurious.github.io/PyFCM/