aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-12-12 21:43:05 +0800
committernetchild <netchild@FreeBSD.org>2003-12-12 21:43:05 +0800
commit7e4108d2e8dcc99218792ea72bc5f3686d7b79d1 (patch)
tree93fb7fd37e3d0028f80a950ce0dc03af626eacf4 /devel
parent0f604e9895401d15bc27421aa834b564241d2025 (diff)
downloadfreebsd-ports-gnome-7e4108d2e8dcc99218792ea72bc5f3686d7b79d1.tar.gz
freebsd-ports-gnome-7e4108d2e8dcc99218792ea72bc5f3686d7b79d1.tar.zst
freebsd-ports-gnome-7e4108d2e8dcc99218792ea72bc5f3686d7b79d1.zip
s/rpm2cpio/rpm2cpio.pl/ after the recent update of archivers/rpm2cpio (the
script was renamed to solve a conflict with archivers/rpm) to fix possible build problems. I've tested this with lang/icc. Any new errors because of this commit in one of the modified ports may be because the ports previously may have used rpm2cpio from archivers/rpm instead of the used {EXTRACT,BUILD}_DEPENDS archivers/rpm2cpio.
Diffstat (limited to 'devel')
-rw-r--r--devel/linux-atk/Makefile4
-rw-r--r--devel/linux-glib2/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/devel/linux-atk/Makefile b/devel/linux-atk/Makefile
index 3246e733cb09..8a3790774b9b 100644
--- a/devel/linux-atk/Makefile
+++ b/devel/linux-atk/Makefile
@@ -13,7 +13,7 @@ CATEGORIES= devel accessibility
MAINTAINER= trevor@FreeBSD.org
COMMENT= Accessibility Toolkit, Linux/i386 binary
-BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+BUILD_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
BASEVERSION= 9
ONLY_FOR_ARCHS= i386
@@ -25,7 +25,7 @@ pre-install:
${RM} -rf ${WRKSRC}/tmp
${MKDIR} ${WRKSRC}/tmp
cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
+ rpm2cpio.pl < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
${FIND} * -type f -o -type l > ${PLIST}
${ECHO_CMD} @dirrm usr/share/doc/atk-1.2.0 >> ${PLIST}
diff --git a/devel/linux-glib2/Makefile b/devel/linux-glib2/Makefile
index b746a08cb67c..f41fa5b6a1cc 100644
--- a/devel/linux-glib2/Makefile
+++ b/devel/linux-glib2/Makefile
@@ -13,7 +13,7 @@ CATEGORIES= devel linux
MAINTAINER= trevor@FreeBSD.org
COMMENT= Version 2.X Linux/i386 binary port of GLib
-BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+BUILD_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
BASEVERSION= 9
ONLY_FOR_ARCHS= i386
@@ -25,7 +25,7 @@ pre-install:
${RM} -rf ${WRKSRC}/tmp
${MKDIR} ${WRKSRC}/tmp
cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
+ rpm2cpio.pl < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
${FIND} * -type f -o -type l > ${PLIST}; \
${FIND} -d * -type d | ${GREP} glib | ${SED} -e 's:^:@dirrm :' \
>> ${PLIST}