aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-17 04:52:58 +0800
committeradamw <adamw@FreeBSD.org>2003-06-17 04:52:58 +0800
commit8052fd3fb7fe6d92a2417b006fdc2957f45cc132 (patch)
tree729163e48ba648e9fb5ba1252bf62584d782bfe5 /devel
parent99718a31ef357e9ddb0e9aa383d2c7c847330738 (diff)
downloadfreebsd-ports-gnome-8052fd3fb7fe6d92a2417b006fdc2957f45cc132.tar.gz
freebsd-ports-gnome-8052fd3fb7fe6d92a2417b006fdc2957f45cc132.tar.zst
freebsd-ports-gnome-8052fd3fb7fe6d92a2417b006fdc2957f45cc132.zip
Utilize USE_GNOME= pkgconfig.
Diffstat (limited to 'devel')
-rw-r--r--devel/ORBit/Makefile2
-rw-r--r--devel/glib12/Makefile4
-rw-r--r--devel/glib20/Makefile4
-rw-r--r--devel/gnome-common/Makefile4
-rw-r--r--devel/gnomecommon/Makefile4
-rw-r--r--devel/libsigc++12/Makefile6
-rw-r--r--devel/libsigc++20/Makefile6
7 files changed, 8 insertions, 22 deletions
diff --git a/devel/ORBit/Makefile b/devel/ORBit/Makefile
index c9ef9f128147..784eca4a20c1 100644
--- a/devel/ORBit/Makefile
+++ b/devel/ORBit/Makefile
@@ -15,9 +15,7 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= High-performance CORBA ORB with support for the C language
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/devel/glib12/Makefile b/devel/glib12/Makefile
index 333c91a62e89..743cc3efed57 100644
--- a/devel/glib12/Makefile
+++ b/devel/glib12/Makefile
@@ -12,12 +12,10 @@ CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/glib/1.2
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-
MAINTAINER= gnome@FreeBSD.org
COMMENT= Some useful routines of C programming (previous stable version)
+USE_GNOME= pkgconfig
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-suffix
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 19a6a23a51bf..da5e8960e0f1 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -20,9 +20,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Some useful routines of C programming (current stable version)
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
NO_LATEST_LINK= yes
@@ -30,7 +28,7 @@ USE_BZIP2= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_GMAKE= yes
USE_PERL5= yes
CONFIGURE_ARGS= --enable-static --with-libiconv=gnu
diff --git a/devel/gnome-common/Makefile b/devel/gnome-common/Makefile
index 8a26d2d47eb5..895158be2f4e 100644
--- a/devel/gnome-common/Makefile
+++ b/devel/gnome-common/Makefile
@@ -16,12 +16,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Common automake macros for GNOME and GOME 2.0
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/devel/gnomecommon/Makefile b/devel/gnomecommon/Makefile
index 8a26d2d47eb5..895158be2f4e 100644
--- a/devel/gnomecommon/Makefile
+++ b/devel/gnomecommon/Makefile
@@ -16,12 +16,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Common automake macros for GNOME and GOME 2.0
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/devel/libsigc++12/Makefile b/devel/libsigc++12/Makefile
index c46790636a2a..6ff2ab9aa682 100644
--- a/devel/libsigc++12/Makefile
+++ b/devel/libsigc++12/Makefile
@@ -17,14 +17,12 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Callback Framework for C++
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- pkg-config:${PORTSDIR}/devel/pkgconfig
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_GMAKE= yes
LATEST_LINK= libsigc++12
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_LIBTOOL= yes
.include <bsd.port.mk>
diff --git a/devel/libsigc++20/Makefile b/devel/libsigc++20/Makefile
index c46790636a2a..6ff2ab9aa682 100644
--- a/devel/libsigc++20/Makefile
+++ b/devel/libsigc++20/Makefile
@@ -17,14 +17,12 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Callback Framework for C++
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- pkg-config:${PORTSDIR}/devel/pkgconfig
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_GMAKE= yes
LATEST_LINK= libsigc++12
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_LIBTOOL= yes
.include <bsd.port.mk>