aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-08-10 23:19:06 +0800
committermat <mat@FreeBSD.org>2017-08-10 23:19:06 +0800
commit82837d5ac859b34448408d8d240a5fc0bf228dfa (patch)
treed7b3d4acfff758fab2c2e9efafcdf85a2fe90303 /devel
parent9dbf830da3fb1d992f223339b01a03721ddb3f58 (diff)
downloadfreebsd-ports-gnome-82837d5ac859b34448408d8d240a5fc0bf228dfa.tar.gz
freebsd-ports-gnome-82837d5ac859b34448408d8d240a5fc0bf228dfa.tar.zst
freebsd-ports-gnome-82837d5ac859b34448408d8d240a5fc0bf228dfa.zip
Mark some ports BROKEN with modern Perl.
With hat: perl@ Sponsored by: Absolight
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Data-Alias/Makefile8
-rw-r--r--devel/p5-Devel-BeginLift/Makefile8
-rw-r--r--devel/p5-Regexp-Compare/Makefile8
-rw-r--r--devel/p5-UNIVERSAL-ref/Makefile8
-rw-r--r--devel/p5-rpm-build-perl/Makefile8
5 files changed, 35 insertions, 5 deletions
diff --git a/devel/p5-Data-Alias/Makefile b/devel/p5-Data-Alias/Makefile
index ab43f657844a..9e05520f4bce 100644
--- a/devel/p5-Data-Alias/Makefile
+++ b/devel/p5-Data-Alias/Makefile
@@ -19,4 +19,10 @@ USE_PERL5= configure
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Data/Alias/Alias.so
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502501
+BROKEN= Does not build, op_sibling usage. https://rt.cpan.org/Public/Bug/Display.html?id=114544
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Devel-BeginLift/Makefile b/devel/p5-Devel-BeginLift/Makefile
index f0f6fb2834e5..a949883dce08 100644
--- a/devel/p5-Devel-BeginLift/Makefile
+++ b/devel/p5-Devel-BeginLift/Makefile
@@ -18,4 +18,10 @@ BUILD_DEPENDS:= ${RUN_DEPENDS} \
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502501
+BROKEN= Does not build, op_sibling usage. https://rt.cpan.org/Public/Bug/Display.html?id=115272
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Regexp-Compare/Makefile b/devel/p5-Regexp-Compare/Makefile
index c48b1ff0781a..ced4094cad4d 100644
--- a/devel/p5-Regexp-Compare/Makefile
+++ b/devel/p5-Regexp-Compare/Makefile
@@ -19,4 +19,10 @@ USES= perl5
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Regexp/Compare/Compare.so
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502700
+BROKEN= Does not support 5.27+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-UNIVERSAL-ref/Makefile b/devel/p5-UNIVERSAL-ref/Makefile
index 07d0b17866dc..5f8e1553817a 100644
--- a/devel/p5-UNIVERSAL-ref/Makefile
+++ b/devel/p5-UNIVERSAL-ref/Makefile
@@ -17,4 +17,10 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502501
+BROKEN= Does not build, op_sibling usage. https://rt.cpan.org/Public/Bug/Display.html?id=118008
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-rpm-build-perl/Makefile b/devel/p5-rpm-build-perl/Makefile
index 1867728ccb13..f3c29bae7439 100644
--- a/devel/p5-rpm-build-perl/Makefile
+++ b/devel/p5-rpm-build-perl/Makefile
@@ -19,4 +19,10 @@ USE_PERL5= configure
post-patch:
@${REINPLACE_CMD} -e 's| perl.clean||' ${WRKSRC}/Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502501
+BROKEN= Does not build, op_sibling usage. https://rt.cpan.org/Public/Bug/Display.html?id=117350
+.endif
+
+.include <bsd.port.post.mk>