aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-01-10 03:01:02 +0800
committerantoine <antoine@FreeBSD.org>2017-01-10 03:01:02 +0800
commit852555686b3cfc76e6545b4b1919c12bbd6005d2 (patch)
tree36dbbb1b8636370cd1fc09a128a007f88b6fc829 /devel
parentce71cd45643f619e05ea6d31edbbfb9d23195b23 (diff)
downloadfreebsd-ports-gnome-852555686b3cfc76e6545b4b1919c12bbd6005d2.tar.gz
freebsd-ports-gnome-852555686b3cfc76e6545b4b1919c12bbd6005d2.tar.zst
freebsd-ports-gnome-852555686b3cfc76e6545b4b1919c12bbd6005d2.zip
New port: devel/py-jupyter_client
Jupyter protocol implementation and client libraries. WWW: http://jupyter.org/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jupyter_client/Makefile23
-rw-r--r--devel/py-jupyter_client/distinfo3
-rw-r--r--devel/py-jupyter_client/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 14ce695abda1..8177fab00a7d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4319,6 +4319,7 @@
SUBDIR += py-jsonpointer
SUBDIR += py-jsonrpclib
SUBDIR += py-jsonschema
+ SUBDIR += py-jupyter_client
SUBDIR += py-jupyter_core
SUBDIR += py-kaptan
SUBDIR += py-kayako
diff --git a/devel/py-jupyter_client/Makefile b/devel/py-jupyter_client/Makefile
new file mode 100644
index 000000000000..7e11cf8b4429
--- /dev/null
+++ b/devel/py-jupyter_client/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= jupyter_client
+PORTVERSION= 4.4.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Jupyter protocol implementation and client libraries
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter_core>=0:devel/py-jupyter_core \
+ ${PYTHON_PKGNAMEPREFIX}pyzmq>=13:net/py-pyzmq \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=0:devel/py-traitlets
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jupyter_client/distinfo b/devel/py-jupyter_client/distinfo
new file mode 100644
index 000000000000..3b3f4d86d452
--- /dev/null
+++ b/devel/py-jupyter_client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483860890
+SHA256 (jupyter_client-4.4.0.tar.gz) = c99a52fac2e5b7a3b714e9252ebf72cbf97536d556ae2b5082baccc3e5cd52ee
+SIZE (jupyter_client-4.4.0.tar.gz) = 256379
diff --git a/devel/py-jupyter_client/pkg-descr b/devel/py-jupyter_client/pkg-descr
new file mode 100644
index 000000000000..b8df574e23dc
--- /dev/null
+++ b/devel/py-jupyter_client/pkg-descr
@@ -0,0 +1,3 @@
+Jupyter protocol implementation and client libraries.
+
+WWW: http://jupyter.org/