aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2016-08-10 03:36:46 +0800
committerarved <arved@FreeBSD.org>2016-08-10 03:36:46 +0800
commit8845088284997ee9de56fab36f402b842f18781a (patch)
treee756da7da6272b8192c1fe346586fd4d028e3acf /devel
parent5ae5ccc0dad612c40133ef97f1f54775fe5af8b3 (diff)
downloadfreebsd-ports-gnome-8845088284997ee9de56fab36f402b842f18781a.tar.gz
freebsd-ports-gnome-8845088284997ee9de56fab36f402b842f18781a.tar.zst
freebsd-ports-gnome-8845088284997ee9de56fab36f402b842f18781a.zip
Add py-mailcap-fix, a module to fix a bug in the python mailcap module
This port is a dependency of the upcoming update to www/rtv
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-mailcap-fix/Makefile26
-rw-r--r--devel/py-mailcap-fix/distinfo3
-rw-r--r--devel/py-mailcap-fix/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 84e017ed80df..8e785d49d0ec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4224,6 +4224,7 @@
SUBDIR += py-louie
SUBDIR += py-lxml
SUBDIR += py-magic
+ SUBDIR += py-mailcap-fix
SUBDIR += py-manuel
SUBDIR += py-matrix-angular-sdk
SUBDIR += py-mccabe
diff --git a/devel/py-mailcap-fix/Makefile b/devel/py-mailcap-fix/Makefile
new file mode 100644
index 000000000000..8b476722f0e9
--- /dev/null
+++ b/devel/py-mailcap-fix/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= mailcap_fix
+PORTVERSION= 0.1.3
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Mailcap module that correctly handles windcard entries
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/UNLICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= michael-lazar
+GH_TAGNAME= ${PORTVERSION}
+USES= python:3.3+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-mailcap-fix/distinfo b/devel/py-mailcap-fix/distinfo
new file mode 100644
index 000000000000..a9cc78c839cc
--- /dev/null
+++ b/devel/py-mailcap-fix/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470771315
+SHA256 (michael-lazar-mailcap_fix-0.1.3_GH0.tar.gz) = fba24851100573acb38ffb86639846096961f458c10e923510faed7994e73664
+SIZE (michael-lazar-mailcap_fix-0.1.3_GH0.tar.gz) = 17514
diff --git a/devel/py-mailcap-fix/pkg-descr b/devel/py-mailcap-fix/pkg-descr
new file mode 100644
index 000000000000..b973b32415fc
--- /dev/null
+++ b/devel/py-mailcap-fix/pkg-descr
@@ -0,0 +1,6 @@
+This package patches the python standard library's mailcap module in order to
+correctly handle windcard entries.
+
+The bug is documented on the bug tracker here: issue 14977
+
+WWW: https://github.com/michael-lazar/mailcap_fix