aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-04-29 14:09:56 +0800
committerleeym <leeym@FreeBSD.org>2005-04-29 14:09:56 +0800
commit8d535c6a063101fd528de6e272b68f8c07d8b243 (patch)
tree6292d4a00e1332a233f6d5515c003371dd7fc01f /devel
parentc5e0cb66a7fd2e94f367910f781753028bd60e7e (diff)
downloadfreebsd-ports-gnome-8d535c6a063101fd528de6e272b68f8c07d8b243.tar.gz
freebsd-ports-gnome-8d535c6a063101fd528de6e272b68f8c07d8b243.tar.zst
freebsd-ports-gnome-8d535c6a063101fd528de6e272b68f8c07d8b243.zip
- upgrade from Flyspray 0.9.5 to 0.9.7
PR: 79216 Submitted by: Nick Hilliard <nick@foobar.org> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/flyspray/Makefile32
-rw-r--r--devel/flyspray/distinfo4
-rw-r--r--devel/flyspray/files/README.FreeBSD76
-rw-r--r--devel/flyspray/files/patch-header.php18
-rw-r--r--devel/flyspray/pkg-deinstall2
-rw-r--r--devel/flyspray/pkg-message48
-rw-r--r--devel/flyspray/pkg-plist499
7 files changed, 447 insertions, 232 deletions
diff --git a/devel/flyspray/Makefile b/devel/flyspray/Makefile
index e17d612b70ac..5fbb14bb272c 100644
--- a/devel/flyspray/Makefile
+++ b/devel/flyspray/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= flyspray
-PORTVERSION= 0.9.5
+PORTVERSION= 0.9.7
CATEGORIES= devel
MASTER_SITES= http://flyspray.rocks.cc/files/
@@ -15,6 +15,7 @@ COMMENT= A simple, easy-to-use web based bug tracking system
RUN_DEPENDS= ${LOCALBASE}/share/adodb/adodb.inc.php:${PORTSDIR}/databases/adodb
+USE_REINPLACE= yes
USE_PHP= mysql pcre session
WANT_PHP_WEB= yes
@@ -22,29 +23,46 @@ NO_BUILD= yes
DBDIR= /var/db
-DOC_FILES= AUTHORS BUGS CHANGELOG COPYING INSTALL README TODO UPGRADING sql/flyspray-${PORTVERSION}.mysql
-FLYSPRAY_FILES= favicon.ico functions.inc.php functions.js index.php lang scripts themes regexp.php sql/upgrade_0.9.4_to_0.9.5-mysql.php
+DOC_FILES= AUTHORS.txt BUGS.txt CHANGELOG.txt INSTALL.txt README.txt \
+ TODO.txt UPGRADING.txt README.FreeBSD \
+ licences/ADOdb.licence.txt \
+ licences/Flyspray.licence.txt \
+ licences/NuvolaIcons.licence.txt \
+ licences/jsCalendar.licence.txt \
+ licences/phpMarkdown.licence.txt
+
+FLYSPRAY_FILES= favicon.ico header.php includes index.php lang scripts sql themes
+
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
+post-patch:
+ @${CP} ${PKGDIR}/files/README.FreeBSD ${WRKSRC}/docs/
+ @${REINPLACE_CMD} -e "s|realpath('../')|'${PREFIX}/share'|g" \
+ ${WRKSRC}/sql/install-${PORTVERSION}.php
+ @${RM} ${WRKSRC}/sql/install-${PORTVERSION}.php.bak
do-install:
- ${MKDIR} ${PREFIX}/share/${PORTNAME}
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
${CHMOD} 755 ${PREFIX}/share/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/header.php ${PREFIX}/share/${PORTNAME}/header.php-dist
cd ${WRKSRC} && \
tar cf - ${FLYSPRAY_FILES} | \
(cd ${PREFIX}/share/${PORTNAME} && tar -xf -)
${LN} -s ${DBDIR}/${PORTNAME}/attachments ${PREFIX}/share/${PORTNAME}/attachments
- ${MKDIR} ${DBDIR}/${PORTNAME}/attachments
+ @${MKDIR} ${DBDIR}/${PORTNAME}/attachments
${CHMOD} 750 ${DBDIR}/${PORTNAME}/attachments
- ${CHOWN} www:www ${DBDIR}/${PORTNAME}/attachments
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${DBDIR}/${PORTNAME}/attachments
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/share/${PORTNAME}
post-install: install-doc
+ @${SED} -e 's|%%DOCSDIR%%|${DOCSDIR}|g' pkg-message > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
install-doc:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/devel/flyspray/distinfo b/devel/flyspray/distinfo
index d2e90b55fbf9..b36561b75b83 100644
--- a/devel/flyspray/distinfo
+++ b/devel/flyspray/distinfo
@@ -1,2 +1,2 @@
-MD5 (flyspray-0.9.5.tar.gz) = efb1c68721f43aca3b47076b5da27442
-SIZE (flyspray-0.9.5.tar.gz) = 134612
+MD5 (flyspray-0.9.7.tar.gz) = ab686864412a0fb4590560ee360bb1f5
+SIZE (flyspray-0.9.7.tar.gz) = 347443
diff --git a/devel/flyspray/files/README.FreeBSD b/devel/flyspray/files/README.FreeBSD
new file mode 100644
index 000000000000..bf744769c807
--- /dev/null
+++ b/devel/flyspray/files/README.FreeBSD
@@ -0,0 +1,76 @@
+Configuration Instructions for Flyspray
+=======================================
+
+0) If you are upgrading from a previous version of flyspray, please skip to
+ the Upgrading section below.
+
+1) Create a mysql database for Flyspray to use. Here is one way to do that,
+ from the unix/linux command line, entering your mysql root password when
+ prompted:
+
+# mysqladmin -u root -p create flyspray
+
+2) Import the Flyspray database tables into your new empty database. Here is
+ the unix/linux command line method; be sure to enter your mysql root
+ password when prompted:
+
+# mysql -u root -p flyspray < flyspray-version.sql
+
+3) Insert the following configuration command into your httpd.conf:
+
+ Alias "/flyspray/" "/usr/local/share/flyspray/"
+
+4) Point your browser to http://yourserver.com/flyspray/ and you should
+ see the Flyspray setup script!
+
+5) If you are upgrading from an old version of Flyspray, skip to note 10
+ below. Otherwise, create youself a new user, and put this user into the
+ Admin group.
+
+6) CHANGE THE PASSWORD FOR THE super/super ACCOUNT by clicking the 'Change
+ Password' link near the top of the page. You might like to disable the
+ account entirely, or it will appear in the list of members to be assigned
+ tasks.
+
+7) Click on the admin links to set up your Options and lists.
+
+8) Close the sample task, and begin adding your own.
+
+9) Report any bugs you find back to http://flyspray.rocks.cc/?p=Support or the
+ mailing list linked from the Flyspray homepage.
+
+
+Upgrading from Previous Versions of Flyspray
+============================================
+
+You can upgrade from a previous version of Flyspray by doing the following:
+
+0) read /usr/local/share/doc/flyspray/UPGRADING.txt.
+
+1) back up your old flyspray task database using "mysqldump". No, really,
+ you seriously run the risk of losing ALL your data if you don't do this.
+
+2) load http://yourserver.com/flyspray/ in your browser, set up the
+ database access parameters and click the "continue to next page" button.
+ DO NOT click "Continue to next page" a second time (i.e. on the page
+ which reads "Next, we are going to try setting up your database...")
+
+3) If you are upgrading from 0.9.5, you will need to upgrade your database
+ settings to 0.9.6 before going to 0.9.7. You can do this by loading the
+ upgrade script on:
+
+ http://yourserver.com/flyspray/sql/upgrade_0.9.5_to_0.9.6-mysql.php
+
+ You will need to click "Perform upgrade now!".
+
+4) To upgrade your database structure from 0.9.6 format to 0.9.7 load the
+ following URL into your browser:
+
+ http://yourserver.com/flyspray/sql/upgrade_0.9.6_to_0.9.7.php
+
+ You will need to click "Take me to Flyspray 0.9.7 now!"
+
+5) That's it! flyspray has been upgraded to 0.9.7. If you messed up the
+ sequence of commands, you will probably have lost data in the process,
+ and may need to re-install your database from your backup. You did
+ take a backup, right?
diff --git a/devel/flyspray/files/patch-header.php b/devel/flyspray/files/patch-header.php
deleted file mode 100644
index 465790fe1731..000000000000
--- a/devel/flyspray/files/patch-header.php
+++ /dev/null
@@ -1,18 +0,0 @@
---- header.php.orig Fri Feb 20 02:49:20 2004
-+++ header.php Fri Aug 20 12:34:04 2004
-@@ -2,13 +2,13 @@
-
- // Directory with Flyspray scripts. It's the directory where this file is
- // located.
--$basedir = '/var/www/flyspray';
-+$basedir = '/usr/local/share/flyspray';
-
- // Flyspray uses ADODB for database access. You will need to install
- // it somewhere on your server for Flyspray to function. It can be installed
- // inside the Flyspray directory if you wish. The next line needs to be the
- // correct path to your adodb.inc.php file.
--include_once ( "/usr/share/adodb/adodb.inc.php" );
-+include_once ( "/usr/local/share/adodb/adodb.inc.php" );
-
- // Modify this next line to reflect the correct path to your Flyspray
- // functions.inc.php file.
diff --git a/devel/flyspray/pkg-deinstall b/devel/flyspray/pkg-deinstall
index aa09c6759022..efc9df869660 100644
--- a/devel/flyspray/pkg-deinstall
+++ b/devel/flyspray/pkg-deinstall
@@ -2,6 +2,8 @@
case $2 in
DEINSTALL)
+# /bin/rm -f ${PKG_PREFIX}/share/flyspray/flyspray.conf.php
+# /bin/rmdir ${PKG_PREFIX}/share/flyspray/
echo "--"
echo "The Flyspray program has been deleted but the bug tracking database has"
echo "not been touched. To delete all the bug tracking information, execute the"
diff --git a/devel/flyspray/pkg-message b/devel/flyspray/pkg-message
index b6127e72507d..16fa40397b21 100644
--- a/devel/flyspray/pkg-message
+++ b/devel/flyspray/pkg-message
@@ -1,51 +1,7 @@
##
-Configuration Instructions for Flyspray
-=======================================
+Please read the installation instructions in:
-1) Create a mysql database for Flyspray to use. Here is one way to do that,
-from the unix/linux command line, entering your mysql root password when
-prompted:
-
-# mysqladmin -u root -p create flyspray
-
-2) Import the Flyspray database tables into your new empty database. Here is
-the unix/linux command line method; be sure to enter your mysql root
-password when prompted:
-
-# mysql -u root -p flyspray < flyspray-version.sql
-
-3) Edit the header.php file to suit your database setup. Examples are
-provided in the file. You will need to set your database type to an ADODB
-supported database, your database username and password, and the host the
-database server runs on. You will also need to enter the location of the
-adodb.inc.php file and functions.inc.php file. Consider changing the cookie
-salt value as well.
-
-4) Insert the following configuration command into your httpd.conf:
-
- Alias "/flyspray/" "/usr/local/share/flyspray/"
-
-5) Point your browser to http://yourserver.com/flyspray/ and you should
-see Flyspray! Login as 'super', with the password 'super'.
-
-6) Create youself a new user, and put this user into the Admin group.
-
-7) CHANGE THE PASSWORD FOR THE super/super ACCOUNT by clicking the
-'Change Password' link near the top of the page. You might like to disable
-the account entirely, or it will appear in the list of members to be assigned
-tasks.
-
-8) Click on the admin links to set up your Options and lists.
-
-9) Close the sample task, and begin adding your own.
-
-10) Report any bugs you find back to http://flyspray.rocks.cc/bts/ or the
-mailing list linked from the Flyspray homepage.
-
-11) If you are upgrading from flyspray 0.9.4, please use your browser to
-open the URL:
-
-http://yourserver.com/flyspray/sql/upgrade_0.9.4_to_0.9.5-mysql.php
+ %%DOCSDIR%%/README.FreeBSD
##
diff --git a/devel/flyspray/pkg-plist b/devel/flyspray/pkg-plist
index be8e77d5ce04..daa8f8069e18 100644
--- a/devel/flyspray/pkg-plist
+++ b/devel/flyspray/pkg-plist
@@ -1,160 +1,341 @@
-share/flyspray/attachments
-share/flyspray/favicon.ico
-share/flyspray/functions.inc.php
-share/flyspray/functions.js
-share/flyspray/header.php-dist
-share/flyspray/index.php
-share/flyspray/regexp.php
-share/flyspray/lang/de/admin.php
-share/flyspray/lang/de/authenticate.php
-share/flyspray/lang/de/chpass.php
-share/flyspray/lang/de/details.php
-share/flyspray/lang/de/functions.inc.php
-share/flyspray/lang/de/index.php
-share/flyspray/lang/de/loginbox.php
-share/flyspray/lang/de/main.php
-share/flyspray/lang/de/modify.php
-share/flyspray/lang/de/newgroup.php
-share/flyspray/lang/de/newproject.php
-share/flyspray/lang/de/newtask.php
-share/flyspray/lang/de/newuser.php
-share/flyspray/lang/de/register.php
-share/flyspray/lang/de/severity.php
-share/flyspray/lang/de/status.php
-share/flyspray/lang/en/admin.php
-share/flyspray/lang/en/authenticate.php
-share/flyspray/lang/en/chpass.php
-share/flyspray/lang/en/details.php
-share/flyspray/lang/en/functions.inc.php
-share/flyspray/lang/en/index.php
-share/flyspray/lang/en/loginbox.php
-share/flyspray/lang/en/main.php
-share/flyspray/lang/en/modify.php
-share/flyspray/lang/en/newgroup.php
-share/flyspray/lang/en/newproject.php
-share/flyspray/lang/en/newtask.php
-share/flyspray/lang/en/newuser.php
-share/flyspray/lang/en/register.php
-share/flyspray/lang/en/severity.php
-share/flyspray/lang/en/status.php
-share/flyspray/lang/it/newgroup.php
-share/flyspray/lang/it/index.php
-share/flyspray/lang/it/severity.php
-share/flyspray/lang/it/newtask.php
-share/flyspray/lang/it/authenticate.php
-share/flyspray/lang/it/newproject.php
-share/flyspray/lang/it/functions.inc.php
-share/flyspray/lang/it/loginbox.php
-share/flyspray/lang/it/chpass.php
-share/flyspray/lang/it/status.php
-share/flyspray/lang/it/main.php
-share/flyspray/lang/it/register.php
-share/flyspray/lang/it/details.php
-share/flyspray/lang/it/modify.php
-share/flyspray/lang/it/newuser.php
-share/flyspray/lang/it/admin.php
-share/flyspray/lang/pl/newgroup.php
-share/flyspray/lang/pl/index.php
-share/flyspray/lang/pl/severity.php
-share/flyspray/lang/pl/newtask.php
-share/flyspray/lang/pl/authenticate.php
-share/flyspray/lang/pl/functions.inc.php
-share/flyspray/lang/pl/newproject.php
-share/flyspray/lang/pl/loginbox.php
-share/flyspray/lang/pl/chpass.php
-share/flyspray/lang/pl/status.php
-share/flyspray/lang/pl/register.php
-share/flyspray/lang/pl/main.php
-share/flyspray/lang/pl/details.php
-share/flyspray/lang/pl/modify.php
-share/flyspray/lang/pl/newuser.php
-share/flyspray/lang/pl/admin.php
-share/flyspray/lang/ptbr/newgroup.php
-share/flyspray/lang/ptbr/index.php
-share/flyspray/lang/ptbr/severity.php
-share/flyspray/lang/ptbr/newtask.php
-share/flyspray/lang/ptbr/authenticate.php
-share/flyspray/lang/ptbr/newproject.php
-share/flyspray/lang/ptbr/functions.inc.php
-share/flyspray/lang/ptbr/loginbox.php
-share/flyspray/lang/ptbr/chpass.php
-share/flyspray/lang/ptbr/status.php
-share/flyspray/lang/ptbr/register.php
-share/flyspray/lang/ptbr/main.php
-share/flyspray/lang/ptbr/readme.txt
-share/flyspray/lang/ptbr/details.php
-share/flyspray/lang/ptbr/modify.php
-share/flyspray/lang/ptbr/newuser.php
-share/flyspray/lang/ptbr/admin.php
-share/flyspray/scripts/admin.php
-share/flyspray/scripts/authenticate.php
-share/flyspray/scripts/chpass.php
-share/flyspray/scripts/chproject.php
-share/flyspray/scripts/details.php
-share/flyspray/scripts/index.php
-share/flyspray/scripts/loginbox.php
-share/flyspray/scripts/modify.php
-share/flyspray/scripts/newgroup.php
-share/flyspray/scripts/newproject.php
-share/flyspray/scripts/newtask.php
-share/flyspray/scripts/newuser.php
-share/flyspray/scripts/register.php
-share/flyspray/sql/upgrade_0.9.4_to_0.9.5-mysql.php
-share/flyspray/themes/Bluey/button.png
-share/flyspray/themes/Bluey/index.html
-share/flyspray/themes/Bluey/percent-0.png
-share/flyspray/themes/Bluey/percent-10.png
-share/flyspray/themes/Bluey/percent-100.png
-share/flyspray/themes/Bluey/percent-20.png
-share/flyspray/themes/Bluey/percent-30.png
-share/flyspray/themes/Bluey/percent-40.png
-share/flyspray/themes/Bluey/percent-50.png
-share/flyspray/themes/Bluey/percent-60.png
-share/flyspray/themes/Bluey/percent-70.png
-share/flyspray/themes/Bluey/percent-80.png
-share/flyspray/themes/Bluey/percent-90.png
-share/flyspray/themes/Bluey/tab-active.png
-share/flyspray/themes/Bluey/tab-notactive.png
-share/flyspray/themes/Bluey/theme.css
-share/flyspray/themes/Bluey/title.png
-share/flyspray/themes/Woodgrain/button.png
-share/flyspray/themes/Woodgrain/index.html
-share/flyspray/themes/Woodgrain/page-bg.png
-share/flyspray/themes/Woodgrain/page-fg.png
-share/flyspray/themes/Woodgrain/percent-0.png
-share/flyspray/themes/Woodgrain/percent-10.png
-share/flyspray/themes/Woodgrain/percent-100.png
-share/flyspray/themes/Woodgrain/percent-20.png
-share/flyspray/themes/Woodgrain/percent-30.png
-share/flyspray/themes/Woodgrain/percent-40.png
-share/flyspray/themes/Woodgrain/percent-50.png
-share/flyspray/themes/Woodgrain/percent-60.png
-share/flyspray/themes/Woodgrain/percent-70.png
-share/flyspray/themes/Woodgrain/percent-80.png
-share/flyspray/themes/Woodgrain/percent-90.png
-share/flyspray/themes/Woodgrain/theme.css
-share/flyspray/themes/Woodgrain/title.png
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
-%%PORTDOCS%%%%DOCSDIR%%/flyspray-0.9.5.mysql
+%%DATADIR%%/attachments
+%%DATADIR%%/header.php-dist
+%%DATADIR%%/favicon.ico
+%%DATADIR%%/header.php
+%%DATADIR%%/includes/styleswitcher.js
+%%DATADIR%%/includes/regexp.php
+%%DATADIR%%/includes/functions.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-ko-utf8.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-fi.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-es.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-du.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-ko.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-si.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-no.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-hu.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-sk.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-ro.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-ru.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-af.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-hr-utf8.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-pl-utf8.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-cs-win.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-el.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-en.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-br.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-lt-utf8.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-fr.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-nl.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-hr.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-jp.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-pl.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-it.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-lt.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-zh.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-sp.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-ca.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-pt.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-da.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-tr.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-sv.js
+%%DATADIR%%/includes/jscalendar/lang/calendar-de.js
+%%DATADIR%%/includes/jscalendar/img.gif
+%%DATADIR%%/includes/jscalendar/calendar-system.css
+%%DATADIR%%/includes/jscalendar/calendar-setup.js
+%%DATADIR%%/includes/jscalendar/menuarrow.gif
+%%DATADIR%%/includes/jscalendar/test-position.html
+%%DATADIR%%/includes/jscalendar/calendar.js
+%%DATADIR%%/includes/jscalendar/calendar-brown.css
+%%DATADIR%%/includes/jscalendar/calendar-blue.css
+%%DATADIR%%/includes/jscalendar/calendar-tas.css
+%%DATADIR%%/includes/jscalendar/calendar-win2k-1.css
+%%DATADIR%%/includes/jscalendar/calendar-win2k-2.css
+%%DATADIR%%/includes/jscalendar/ChangeLog
+%%DATADIR%%/includes/jscalendar/simple-1.html
+%%DATADIR%%/includes/jscalendar/simple-2.html
+%%DATADIR%%/includes/jscalendar/simple-3.html
+%%DATADIR%%/includes/jscalendar/README
+%%DATADIR%%/includes/jscalendar/calendar.php
+%%DATADIR%%/includes/jscalendar/calendar-setup_stripped.js
+%%DATADIR%%/includes/jscalendar/calendar-green.css
+%%DATADIR%%/includes/jscalendar/calendar_stripped.js
+%%DATADIR%%/includes/jscalendar/menuarrow2.gif
+%%DATADIR%%/includes/jscalendar/test.php
+%%DATADIR%%/includes/jscalendar/calendar-blue2.css
+%%DATADIR%%/includes/jscalendar/calendar-win2k-cold-1.css
+%%DATADIR%%/includes/jscalendar/calendar-win2k-cold-2.css
+%%DATADIR%%/includes/jscalendar/release-notes.html
+%%DATADIR%%/includes/jscalendar/index.html
+%%DATADIR%%/includes/jscalendar/bugtest-hidden-selects.html
+%%DATADIR%%/includes/functions.inc.php
+%%DATADIR%%/includes/markdown.php
+%%DATADIR%%/includes/gzip_compress.php
+%%DATADIR%%/index.php
+%%DATADIR%%/lang/en/authenticate.php
+%%DATADIR%%/lang/en/reports.php
+%%DATADIR%%/lang/en/newgroup.php
+%%DATADIR%%/lang/en/index.php
+%%DATADIR%%/lang/en/severity.php
+%%DATADIR%%/lang/en/newtask.php
+%%DATADIR%%/lang/en/functions.inc.php
+%%DATADIR%%/lang/en/newproject.php
+%%DATADIR%%/lang/en/chpass.php
+%%DATADIR%%/lang/en/loginbox.php
+%%DATADIR%%/lang/en/priority.php
+%%DATADIR%%/lang/en/status.php
+%%DATADIR%%/lang/en/main.php
+%%DATADIR%%/lang/en/register.php
+%%DATADIR%%/lang/en/details.php
+%%DATADIR%%/lang/en/modify.php
+%%DATADIR%%/lang/en/newuser.php
+%%DATADIR%%/lang/en/admin.php
+%%DATADIR%%/lang/ptbr/authenticate.php
+%%DATADIR%%/lang/ptbr/newgroup.php
+%%DATADIR%%/lang/ptbr/index.php
+%%DATADIR%%/lang/ptbr/severity.php
+%%DATADIR%%/lang/ptbr/newtask.php
+%%DATADIR%%/lang/ptbr/functions.inc.php
+%%DATADIR%%/lang/ptbr/newproject.php
+%%DATADIR%%/lang/ptbr/loginbox.php
+%%DATADIR%%/lang/ptbr/chpass.php
+%%DATADIR%%/lang/ptbr/status.php
+%%DATADIR%%/lang/ptbr/main.php
+%%DATADIR%%/lang/ptbr/register.php
+%%DATADIR%%/lang/ptbr/details.php
+%%DATADIR%%/lang/ptbr/readme.txt
+%%DATADIR%%/lang/ptbr/modify.php
+%%DATADIR%%/lang/ptbr/newuser.php
+%%DATADIR%%/lang/ptbr/admin.php
+%%DATADIR%%/lang/langdiff.php
+%%DATADIR%%/lang/fr/authenticate.php
+%%DATADIR%%/lang/fr/reports.php
+%%DATADIR%%/lang/fr/newgroup.php
+%%DATADIR%%/lang/fr/index.php
+%%DATADIR%%/lang/fr/severity.php
+%%DATADIR%%/lang/fr/newtask.php
+%%DATADIR%%/lang/fr/functions.inc.php
+%%DATADIR%%/lang/fr/newproject.php
+%%DATADIR%%/lang/fr/loginbox.php
+%%DATADIR%%/lang/fr/chpass.php
+%%DATADIR%%/lang/fr/priority.php
+%%DATADIR%%/lang/fr/status.php
+%%DATADIR%%/lang/fr/register.php
+%%DATADIR%%/lang/fr/main.php
+%%DATADIR%%/lang/fr/details.php
+%%DATADIR%%/lang/fr/modify.php
+%%DATADIR%%/lang/fr/admin.php
+%%DATADIR%%/lang/fr/newuser.php
+%%DATADIR%%/lang/es/authenticate.php
+%%DATADIR%%/lang/es/newgroup.php
+%%DATADIR%%/lang/es/index.php
+%%DATADIR%%/lang/es/severity.php
+%%DATADIR%%/lang/es/newtask.php
+%%DATADIR%%/lang/es/functions.inc.php
+%%DATADIR%%/lang/es/newproject.php
+%%DATADIR%%/lang/es/loginbox.php
+%%DATADIR%%/lang/es/chpass.php
+%%DATADIR%%/lang/es/status.php
+%%DATADIR%%/lang/es/main.php
+%%DATADIR%%/lang/es/register.php
+%%DATADIR%%/lang/es/details.php
+%%DATADIR%%/lang/es/modify.php
+%%DATADIR%%/lang/es/newuser.php
+%%DATADIR%%/lang/es/admin.php
+%%DATADIR%%/lang/de/authenticate.php
+%%DATADIR%%/lang/de/reports.php
+%%DATADIR%%/lang/de/newgroup.php
+%%DATADIR%%/lang/de/index.php
+%%DATADIR%%/lang/de/severity.php
+%%DATADIR%%/lang/de/newtask.php
+%%DATADIR%%/lang/de/functions.inc.php
+%%DATADIR%%/lang/de/newproject.php
+%%DATADIR%%/lang/de/loginbox.php
+%%DATADIR%%/lang/de/priority.php
+%%DATADIR%%/lang/de/chpass.php
+%%DATADIR%%/lang/de/status.php
+%%DATADIR%%/lang/de/register.php
+%%DATADIR%%/lang/de/main.php
+%%DATADIR%%/lang/de/details.php
+%%DATADIR%%/lang/de/modify.php
+%%DATADIR%%/lang/de/newuser.php
+%%DATADIR%%/lang/de/admin.php
+%%DATADIR%%/lang/nl/authenticate.php
+%%DATADIR%%/lang/nl/reports.php
+%%DATADIR%%/lang/nl/newgroup.php
+%%DATADIR%%/lang/nl/index.php
+%%DATADIR%%/lang/nl/severity.php
+%%DATADIR%%/lang/nl/newtask.php
+%%DATADIR%%/lang/nl/functions.inc.php
+%%DATADIR%%/lang/nl/newproject.php
+%%DATADIR%%/lang/nl/loginbox.php
+%%DATADIR%%/lang/nl/chpass.php
+%%DATADIR%%/lang/nl/priority.php
+%%DATADIR%%/lang/nl/status.php
+%%DATADIR%%/lang/nl/register.php
+%%DATADIR%%/lang/nl/main.php
+%%DATADIR%%/lang/nl/details.php
+%%DATADIR%%/lang/nl/modify.php
+%%DATADIR%%/lang/nl/admin.php
+%%DATADIR%%/lang/nl/newuser.php
+%%DATADIR%%/lang/pl/authenticate.php
+%%DATADIR%%/lang/pl/reports.php
+%%DATADIR%%/lang/pl/newgroup.php
+%%DATADIR%%/lang/pl/index.php
+%%DATADIR%%/lang/pl/severity.php
+%%DATADIR%%/lang/pl/newtask.php
+%%DATADIR%%/lang/pl/functions.inc.php
+%%DATADIR%%/lang/pl/newproject.php
+%%DATADIR%%/lang/pl/loginbox.php
+%%DATADIR%%/lang/pl/chpass.php
+%%DATADIR%%/lang/pl/priority.php
+%%DATADIR%%/lang/pl/status.php
+%%DATADIR%%/lang/pl/register.php
+%%DATADIR%%/lang/pl/main.php
+%%DATADIR%%/lang/pl/details.php
+%%DATADIR%%/lang/pl/modify.php
+%%DATADIR%%/lang/pl/admin.php
+%%DATADIR%%/lang/pl/newuser.php
+%%DATADIR%%/lang/it/authenticate.php
+%%DATADIR%%/lang/it/reports.php
+%%DATADIR%%/lang/it/newgroup.php
+%%DATADIR%%/lang/it/index.php
+%%DATADIR%%/lang/it/severity.php
+%%DATADIR%%/lang/it/newtask.php
+%%DATADIR%%/lang/it/functions.inc.php
+%%DATADIR%%/lang/it/newproject.php
+%%DATADIR%%/lang/it/chpass.php
+%%DATADIR%%/lang/it/loginbox.php
+%%DATADIR%%/lang/it/priority.php
+%%DATADIR%%/lang/it/status.php
+%%DATADIR%%/lang/it/register.php
+%%DATADIR%%/lang/it/main.php
+%%DATADIR%%/lang/it/details.php
+%%DATADIR%%/lang/it/modify.php
+%%DATADIR%%/lang/it/admin.php
+%%DATADIR%%/lang/it/newuser.php
+%%DATADIR%%/lang/dk/authenticate.php
+%%DATADIR%%/lang/dk/newgroup.php
+%%DATADIR%%/lang/dk/index.php
+%%DATADIR%%/lang/dk/severity.php
+%%DATADIR%%/lang/dk/newtask.php
+%%DATADIR%%/lang/dk/functions.inc.php
+%%DATADIR%%/lang/dk/newproject.php
+%%DATADIR%%/lang/dk/chpass.php
+%%DATADIR%%/lang/dk/loginbox.php
+%%DATADIR%%/lang/dk/status.php
+%%DATADIR%%/lang/dk/register.php
+%%DATADIR%%/lang/dk/main.php
+%%DATADIR%%/lang/dk/details.php
+%%DATADIR%%/lang/dk/modify.php
+%%DATADIR%%/lang/dk/newuser.php
+%%DATADIR%%/lang/dk/admin.php
+%%DATADIR%%/scripts/authenticate.php
+%%DATADIR%%/scripts/reports.php
+%%DATADIR%%/scripts/newgroup.php
+%%DATADIR%%/scripts/rss.php
+%%DATADIR%%/scripts/index.php
+%%DATADIR%%/scripts/newtask.php
+%%DATADIR%%/scripts/newproject.php
+%%DATADIR%%/scripts/chproject.php
+%%DATADIR%%/scripts/loginbox.php
+%%DATADIR%%/scripts/schrem.php
+%%DATADIR%%/scripts/register.php
+%%DATADIR%%/scripts/details.php
+%%DATADIR%%/scripts/modify.php
+%%DATADIR%%/scripts/admin.php
+%%DATADIR%%/scripts/newuser.php
+%%DATADIR%%/sql/upgrade_0.9.5_to_0.9.6-pgsql.php
+%%DATADIR%%/sql/upgrade_0.9.6_to_0.9.7.mysql
+%%DATADIR%%/sql/flyspray-0.9.7.mysql
+%%DATADIR%%/sql/mysql2pgsql.pl
+%%DATADIR%%/sql/flyspray.conf.skel
+%%DATADIR%%/sql/install-0.9.7.php
+%%DATADIR%%/sql/upgrade_0.9.3.1_to_0.9.4-mysql.php
+%%DATADIR%%/sql/upgrade_0.9.6_to_0.9.7.pgsql
+%%DATADIR%%/sql/upgrade_0.9.4_to_0.9.5-mysql.php
+%%DATADIR%%/sql/upgrade_0.9.6_to_0.9.7.php
+%%DATADIR%%/sql/upgrade_0.9.5_to_0.9.6-mysql.php
+%%DATADIR%%/sql/flyspray-0.9.7.pgsql
+%%DATADIR%%/themes/Bluey/tab-notactive.png
+%%DATADIR%%/themes/Bluey/percent-0.png
+%%DATADIR%%/themes/Bluey/percent-100.png
+%%DATADIR%%/themes/Bluey/mime/application/octet-stream.png
+%%DATADIR%%/themes/Bluey/mime/application/x-gzip.png
+%%DATADIR%%/themes/Bluey/mime/application/pdf.png
+%%DATADIR%%/themes/Bluey/mime/text/html.png
+%%DATADIR%%/themes/Bluey/mime/audio.png
+%%DATADIR%%/themes/Bluey/mime/image.png
+%%DATADIR%%/themes/Bluey/mime/application.png
+%%DATADIR%%/themes/Bluey/mime/text.png
+%%DATADIR%%/themes/Bluey/mime/video.png
+%%DATADIR%%/themes/Bluey/menu/projectprefs.png
+%%DATADIR%%/themes/Bluey/menu/newtask.png
+%%DATADIR%%/themes/Bluey/menu/reports.png
+%%DATADIR%%/themes/Bluey/menu/lists.png
+%%DATADIR%%/themes/Bluey/menu/comment.png
+%%DATADIR%%/themes/Bluey/menu/editmydetails.png
+%%DATADIR%%/themes/Bluey/menu/search.png
+%%DATADIR%%/themes/Bluey/menu/usersandgroups.png
+%%DATADIR%%/themes/Bluey/menu/logout.png
+%%DATADIR%%/themes/Bluey/menu/options.png
+%%DATADIR%%/themes/Bluey/comment.png
+%%DATADIR%%/themes/Bluey/percent-10.png
+%%DATADIR%%/themes/Bluey/theme.css
+%%DATADIR%%/themes/Bluey/asc.png
+%%DATADIR%%/themes/Bluey/calendar.png
+%%DATADIR%%/themes/Bluey/smile.png
+%%DATADIR%%/themes/Bluey/button.png
+%%DATADIR%%/themes/Bluey/desc.png
+%%DATADIR%%/themes/Bluey/percent-20.png
+%%DATADIR%%/themes/Bluey/tab-active.png
+%%DATADIR%%/themes/Bluey/percent-30.png
+%%DATADIR%%/themes/Bluey/title.png
+%%DATADIR%%/themes/Bluey/percent-40.png
+%%DATADIR%%/themes/Bluey/percent-50.png
+%%DATADIR%%/themes/Bluey/percent-60.png
+%%DATADIR%%/themes/Bluey/percent-70.png
+%%DATADIR%%/themes/Bluey/button-over.png
+%%DATADIR%%/themes/Bluey/percent-80.png
+%%DATADIR%%/themes/Bluey/percent-90.png
+%%DATADIR%%/themes/Bluey/index.html
+%%DATADIR%%/themes/Bluey/attachment.png
+%%DATADIR%%/themes/Bluey/frown.png
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
+%%PORTDOCS%%%%DOCSDIR%%/BUGS.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADING.txt
+%%PORTDOCS%%%%DOCSDIR%%/ADOdb.licence.txt
+%%PORTDOCS%%%%DOCSDIR%%/Flyspray.licence.txt
+%%PORTDOCS%%%%DOCSDIR%%/NuvolaIcons.licence.txt
+%%PORTDOCS%%%%DOCSDIR%%/jsCalendar.licence.txt
+%%PORTDOCS%%%%DOCSDIR%%/phpMarkdown.licence.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm share/flyspray/lang/en
-@dirrm share/flyspray/lang/de
-@dirrm share/flyspray/lang/it
-@dirrm share/flyspray/lang/pl
-@dirrm share/flyspray/lang/ptbr
-@dirrm share/flyspray/lang
-@dirrm share/flyspray/themes/Bluey
-@dirrm share/flyspray/themes/Woodgrain
-@dirrm share/flyspray/themes
-@dirrm share/flyspray/scripts
-@dirrm share/flyspray/sql
-@dirrm share/flyspray
-@unexec rmdir /var/db/flyspray/attachments 2>/dev/null || true
-@unexec rmdir /var/db/flyspray 2>/dev/null || true
+@dirrm %%DATADIR%%/includes/jscalendar/lang
+@dirrm %%DATADIR%%/includes/jscalendar
+@dirrm %%DATADIR%%/includes
+@dirrm %%DATADIR%%/lang/en
+@dirrm %%DATADIR%%/lang/ptbr
+@dirrm %%DATADIR%%/lang/fr
+@dirrm %%DATADIR%%/lang/es
+@dirrm %%DATADIR%%/lang/de
+@dirrm %%DATADIR%%/lang/nl
+@dirrm %%DATADIR%%/lang/pl
+@dirrm %%DATADIR%%/lang/it
+@dirrm %%DATADIR%%/lang/dk
+@dirrm %%DATADIR%%/lang
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/sql
+@dirrm %%DATADIR%%/themes/Bluey/mime/audio
+@dirrm %%DATADIR%%/themes/Bluey/mime/image
+@dirrm %%DATADIR%%/themes/Bluey/mime/application
+@dirrm %%DATADIR%%/themes/Bluey/mime/text
+@dirrm %%DATADIR%%/themes/Bluey/mime/video
+@dirrm %%DATADIR%%/themes/Bluey/mime
+@dirrm %%DATADIR%%/themes/Bluey/menu
+@dirrm %%DATADIR%%/themes/Bluey
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%