aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-11 02:57:07 +0800
committeryuri <yuri@FreeBSD.org>2017-11-11 02:57:07 +0800
commit8e4288f60a0055dcc6d5582a92e2f9770e219643 (patch)
tree27c4b6f620e0eee4a7c223c545ca4d39e3b83f2c /devel
parentb08e54ad0d9df902d5221706128d184639b97a48 (diff)
downloadfreebsd-ports-gnome-8e4288f60a0055dcc6d5582a92e2f9770e219643.tar.gz
freebsd-ports-gnome-8e4288f60a0055dcc6d5582a92e2f9770e219643.tar.zst
freebsd-ports-gnome-8e4288f60a0055dcc6d5582a92e2f9770e219643.zip
New port: devel/pybind11: Seamless operability between C++11 and Python (cmake part)
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13025
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pybind11/Makefile20
-rw-r--r--devel/pybind11/distinfo3
-rw-r--r--devel/pybind11/pkg-descr9
-rw-r--r--devel/pybind11/pkg-plist29
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8d4f515cd7af..97bc8f7c1725 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5142,6 +5142,7 @@
SUBDIR += py35-setuptools
SUBDIR += py36-setuptools
SUBDIR += py_static_check
+ SUBDIR += pybind11
SUBDIR += pybugz
SUBDIR += pycharm-ce
SUBDIR += pychecker
diff --git a/devel/pybind11/Makefile b/devel/pybind11/Makefile
new file mode 100644
index 000000000000..7a7c0437834a
--- /dev/null
+++ b/devel/pybind11/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= pybind11
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.2.1
+CATEGORIES= devel python
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Seamless interoperability between C++11 and Python (cmake part)
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource
+USE_GITHUB= yes
+GH_ACCOUNT= pybind
+NO_ARCH= yes
+CMAKE_ARGS= -DPYBIND11_TEST:BOOL="OFF"
+
+.include <bsd.port.mk>
diff --git a/devel/pybind11/distinfo b/devel/pybind11/distinfo
new file mode 100644
index 000000000000..c89d2725003c
--- /dev/null
+++ b/devel/pybind11/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510299608
+SHA256 (pybind-pybind11-v2.2.1_GH0.tar.gz) = f8bd1509578b2a1e7407d52e6ee8afe64268909a1bbda620ca407318598927e7
+SIZE (pybind-pybind11-v2.2.1_GH0.tar.gz) = 540643
diff --git a/devel/pybind11/pkg-descr b/devel/pybind11/pkg-descr
new file mode 100644
index 000000000000..a6560c85f235
--- /dev/null
+++ b/devel/pybind11/pkg-descr
@@ -0,0 +1,9 @@
+A lightweight header-only library to create Python bindings of existing
+C++ code. Its goals and syntax are similar to the excellent Boost.Python
+library by David Abrahams: to minimize boilerplate code in traditional
+extension modules by inferring type information using compile-time
+introspection.
+
+This is the cmake part of pybind11.
+
+WWW: https://github.com/wjakob/pybind11
diff --git a/devel/pybind11/pkg-plist b/devel/pybind11/pkg-plist
new file mode 100644
index 000000000000..e774fe5f3632
--- /dev/null
+++ b/devel/pybind11/pkg-plist
@@ -0,0 +1,29 @@
+include/pybind11/attr.h
+include/pybind11/buffer_info.h
+include/pybind11/cast.h
+include/pybind11/chrono.h
+include/pybind11/common.h
+include/pybind11/complex.h
+include/pybind11/detail/class.h
+include/pybind11/detail/common.h
+include/pybind11/detail/descr.h
+include/pybind11/detail/init.h
+include/pybind11/detail/internals.h
+include/pybind11/detail/typeid.h
+include/pybind11/eigen.h
+include/pybind11/embed.h
+include/pybind11/eval.h
+include/pybind11/functional.h
+include/pybind11/iostream.h
+include/pybind11/numpy.h
+include/pybind11/operators.h
+include/pybind11/options.h
+include/pybind11/pybind11.h
+include/pybind11/pytypes.h
+include/pybind11/stl.h
+include/pybind11/stl_bind.h
+share/cmake/pybind11/FindPythonLibsNew.cmake
+share/cmake/pybind11/pybind11Config.cmake
+share/cmake/pybind11/pybind11ConfigVersion.cmake
+share/cmake/pybind11/pybind11Targets.cmake
+share/cmake/pybind11/pybind11Tools.cmake