aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-13 08:49:12 +0800
committermarino <marino@FreeBSD.org>2016-09-13 08:49:12 +0800
commit9c95a665815280c267a0d12910a38cda478c04c8 (patch)
treec754272b9887ba258ae6055a5211a565d1fe1a35 /devel
parent100dfdcc5571dea9d85adcf1b597ec896b3b899e (diff)
downloadfreebsd-ports-gnome-9c95a665815280c267a0d12910a38cda478c04c8.tar.gz
freebsd-ports-gnome-9c95a665815280c267a0d12910a38cda478c04c8.tar.zst
freebsd-ports-gnome-9c95a665815280c267a0d12910a38cda478c04c8.zip
devel/hadoop: Unbreak build (nominal case)
The ssl.mk helper can augment the MAKE_ARGS variable with a OPENSSL_CFLAGS definition which just happens to break this port. Add a filter to remove any such definitions if they occur. The issue was introduced when USES+=ssl was added to the makefile to document the SSL requirement.
Diffstat (limited to 'devel')
-rw-r--r--devel/hadoop/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/hadoop/Makefile b/devel/hadoop/Makefile
index 8948cfb7580d..a7723c70e86c 100644
--- a/devel/hadoop/Makefile
+++ b/devel/hadoop/Makefile
@@ -78,7 +78,11 @@ MAKE_ARGS= -Dbuild.classes=${WRKSRC}/hadoop-core-${PORTVERSION}.jar -Dversion=${
-Dcompile.c++=true -Dmake.cmd=gmake -Dlibhdfs=1 -Dlibrecordio=true -Dskip.record-parser=true
ALL_TARGET= compile-core-native compile-c++ compile-c++-libhdfs compile-c++-pipes compile-c++-utils
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+# The ssl.mk helper can augment MAKE_ARGS and break the build. Filter out
+# the OPENSSL_CFLAGS if it exists to prevent that from happening.
+MAKE_ARGS:= ${MAKE_ARGS:NOPENSSL_CFLAGS=*}
.if ${ARCH} == "amd64"
_HADOOP_ARCH= FreeBSD-amd64-64
@@ -142,4 +146,4 @@ do-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>