aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-11-10 04:09:18 +0800
committerantoine <antoine@FreeBSD.org>2017-11-10 04:09:18 +0800
commitaa63443e9db8d3dd314059cb8e4790336d9c2733 (patch)
treee3482b8dd3af307d868ccdb92adcce3803de14db /devel
parentfb5aa1489583cfcc2b433f7db18b17dc2fd966af (diff)
downloadfreebsd-ports-gnome-aa63443e9db8d3dd314059cb8e4790336d9c2733.tar.gz
freebsd-ports-gnome-aa63443e9db8d3dd314059cb8e4790336d9c2733.tar.zst
freebsd-ports-gnome-aa63443e9db8d3dd314059cb8e4790336d9c2733.zip
Fix the context of some patches so that they apply with stricter patch(1)
PR: 223545 With hat: portmgr
Diffstat (limited to 'devel')
-rw-r--r--devel/cppcheck/files/patch-CMakeLists.txt4
-rw-r--r--devel/cppcheck/files/patch-gui_CMakeLists.txt6
-rw-r--r--devel/p5-Config-Auto/files/patch-Makefile.PL16
3 files changed, 14 insertions, 12 deletions
diff --git a/devel/cppcheck/files/patch-CMakeLists.txt b/devel/cppcheck/files/patch-CMakeLists.txt
index a51c9ac7b367..61e1bc259341 100644
--- a/devel/cppcheck/files/patch-CMakeLists.txt
+++ b/devel/cppcheck/files/patch-CMakeLists.txt
@@ -1,8 +1,8 @@
---- CMakeLists.txt.orig 2017-05-13 09:27:11 UTC
+--- CMakeLists.txt.orig 2017-10-07 21:11:39 UTC
+++ CMakeLists.txt
@@ -1,4 +1,4 @@
-project(CppCheck)
+project(cppcheck)
- cmake_minimum_required(VERSION 2.8)
+ cmake_minimum_required(VERSION 2.8.4)
include(GNUInstallDirs)
diff --git a/devel/cppcheck/files/patch-gui_CMakeLists.txt b/devel/cppcheck/files/patch-gui_CMakeLists.txt
index aff4c31501b0..045a0c7646ad 100644
--- a/devel/cppcheck/files/patch-gui_CMakeLists.txt
+++ b/devel/cppcheck/files/patch-gui_CMakeLists.txt
@@ -1,7 +1,7 @@
---- gui/CMakeLists.txt.orig 2017-05-13 09:27:11 UTC
+--- gui/CMakeLists.txt.orig 2017-10-07 21:11:39 UTC
+++ gui/CMakeLists.txt
-@@ -29,7 +29,7 @@ if (BUILD_GUI)
-
+@@ -27,7 +27,7 @@ if (BUILD_GUI)
+ qt5_use_modules(cppcheck-gui ${GUI_QT_COMPONENTS})
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
diff --git a/devel/p5-Config-Auto/files/patch-Makefile.PL b/devel/p5-Config-Auto/files/patch-Makefile.PL
index 1f2bac930ac3..62f90e9bc736 100644
--- a/devel/p5-Config-Auto/files/patch-Makefile.PL
+++ b/devel/p5-Config-Auto/files/patch-Makefile.PL
@@ -1,12 +1,14 @@
---- Makefile.PL.orig Sun Sep 28 13:41:23 2003
-+++ Makefile.PL Sun Sep 28 13:42:32 2003
-@@ -29,4 +29,9 @@
- AUTHOR => 'Jos I. Boumans <kane@cpan.org>')
- : ()
- ),
+--- Makefile.PL.orig 2013-05-12 15:18:54 UTC
++++ Makefile.PL
+@@ -29,6 +29,11 @@ WriteMakefile1(
+ LICENSE => 'perl',
+ META_MERGE => {
+ resources => {
+
+ 'MAN3PODS' => {
+ 'lib/Config/Auto.pm' => '$(INST_MAN3DIR)/Config::Auto.$(MAN3EXT)',
+ },
+
- );
+ repository => 'https://github.com/jib/config-auto',
+ },
+ },