aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-24 05:07:36 +0800
committermarcus <marcus@FreeBSD.org>2004-02-24 05:07:36 +0800
commitb1b593f20489c18a984ed8d928246c3d071ac386 (patch)
treee662c1433ac5a7531ea7f34ab4581b960f61d6c6 /devel
parent8d557dd67487e6e12f37022ee3ffb37e8bfa8f63 (diff)
downloadfreebsd-ports-gnome-b1b593f20489c18a984ed8d928246c3d071ac386.tar.gz
freebsd-ports-gnome-b1b593f20489c18a984ed8d928246c3d071ac386.tar.zst
freebsd-ports-gnome-b1b593f20489c18a984ed8d928246c3d071ac386.zip
Fix build with new gnuregex.h scheme as well as on 4.X i386.
Reported by: bento via kris
Diffstat (limited to 'devel')
-rw-r--r--devel/gnome-build/Makefile3
-rw-r--r--devel/gnomebuild/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/devel/gnome-build/Makefile b/devel/gnome-build/Makefile
index 64121dfa33ff..478587cd2120 100644
--- a/devel/gnome-build/Makefile
+++ b/devel/gnome-build/Makefile
@@ -24,6 +24,7 @@ USE_GNOME= gnomeprefix gnomehack gnometarget libgnomeui gnomevfs2
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-compile-warnings=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgnuregex"
@@ -31,7 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.if ${OSVERSION} >= 500000
EXTRA_PATCHES+= ${FILESDIR}/current-src_backends_libgbf_am_gbf-am-project.c
-.else
+.elif ${ARCH} != "i386"
EXTRA_PATCHES+= ${FILESDIR}/stable-src_backends_libgbf_am_gbf-am-project.c
.endif
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
index 64121dfa33ff..478587cd2120 100644
--- a/devel/gnomebuild/Makefile
+++ b/devel/gnomebuild/Makefile
@@ -24,6 +24,7 @@ USE_GNOME= gnomeprefix gnomehack gnometarget libgnomeui gnomevfs2
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-compile-warnings=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgnuregex"
@@ -31,7 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.if ${OSVERSION} >= 500000
EXTRA_PATCHES+= ${FILESDIR}/current-src_backends_libgbf_am_gbf-am-project.c
-.else
+.elif ${ARCH} != "i386"
EXTRA_PATCHES+= ${FILESDIR}/stable-src_backends_libgbf_am_gbf-am-project.c
.endif