aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-24 06:18:48 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-24 06:18:48 +0800
commitbe83a27855aaa2a677dec30f507ed18e277bafc8 (patch)
treee68634a7d7f25c5be89b242bf2af0a6cbf4f355b /devel
parente0f5d2f4a561a2ba754ce516646db93d9e5959b9 (diff)
downloadfreebsd-ports-gnome-be83a27855aaa2a677dec30f507ed18e277bafc8.tar.gz
freebsd-ports-gnome-be83a27855aaa2a677dec30f507ed18e277bafc8.tar.zst
freebsd-ports-gnome-be83a27855aaa2a677dec30f507ed18e277bafc8.zip
- PHP 5.2 slave port
PR: 145772 Submitted by: Alex Keda
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php52-readline/files/patch-config.m438
-rw-r--r--devel/php52-shmop/Makefile14
3 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a702f36ca357..8bf288761803 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2475,6 +2475,7 @@
SUBDIR += php52-pcntl
SUBDIR += php52-pcre
SUBDIR += php52-readline
+ SUBDIR += php52-shmop
SUBDIR += phpbt
SUBDIR += phptags
SUBDIR += physfs
diff --git a/devel/php52-readline/files/patch-config.m4 b/devel/php52-readline/files/patch-config.m4
new file mode 100644
index 000000000000..b0b2bb521bc7
--- /dev/null
+++ b/devel/php52-readline/files/patch-config.m4
@@ -0,0 +1,38 @@
+--- config.m4.orig 2009-08-04 13:20:49.000000000 +0200
++++ config.m4 2009-09-22 11:13:12.000000000 +0200
+@@ -5,13 +5,8 @@
+ PHP_ARG_WITH(libedit,for libedit readline replacement,
+ [ --with-libedit[=DIR] Include libedit readline replacement (CLI/CGI only)])
+
+-if test "$PHP_LIBEDIT" = "no"; then
+ PHP_ARG_WITH(readline,for readline support,
+ [ --with-readline[=DIR] Include readline support (CLI/CGI only)])
+-else
+- dnl "register" the --with-readline option to preven invalid "unknown configure option" warning
+- php_with_readline=no
+-fi
+
+ if test "$PHP_READLINE" && test "$PHP_READLINE" != "no"; then
+ for i in $PHP_READLINE /usr/local /usr; do
+@@ -60,6 +55,13 @@
+ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
+ ])
+
++ PHP_CHECK_LIBRARY(readline, rl_completion_matches,
++ [
++ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1, [ ])
++ ],[],[
++ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
++ ])
++
+ AC_DEFINE(HAVE_LIBREADLINE, 1, [ ])
+
+ elif test "$PHP_LIBEDIT" != "no"; then
+@@ -97,7 +99,6 @@
+ fi
+
+ if test "$PHP_READLINE" != "no" || test "$PHP_LIBEDIT" != "no"; then
+- AC_CHECK_FUNCS([rl_completion_matches])
+ PHP_NEW_EXTENSION(readline, readline.c, $ext_shared, cli)
+ PHP_SUBST(READLINE_SHARED_LIBADD)
+ fi
diff --git a/devel/php52-shmop/Makefile b/devel/php52-shmop/Makefile
new file mode 100644
index 000000000000..5beac0bfee0e
--- /dev/null
+++ b/devel/php52-shmop/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-shmop
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -shmop
+
+.include "${MASTERDIR}/Makefile"