aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-01-16 06:45:02 +0800
committeryuri <yuri@FreeBSD.org>2018-01-16 06:45:02 +0800
commitc0a5cb071ca75f2bd9949f301b7c77ab0ed5b298 (patch)
tree3cfb53c1f0095a9acd270e4c9639755e870a8f8e /devel
parent53015d201e7d5d2bada17ad69d9d75e9858a7615 (diff)
downloadfreebsd-ports-gnome-c0a5cb071ca75f2bd9949f301b7c77ab0ed5b298.tar.gz
freebsd-ports-gnome-c0a5cb071ca75f2bd9949f301b7c77ab0ed5b298.tar.zst
freebsd-ports-gnome-c0a5cb071ca75f2bd9949f301b7c77ab0ed5b298.zip
devel/oniguruma: Update to 6.7.0
Additional changes: * Took ownership. Maintainer's timeout expired, and my repeated requests to the maintainer went unanswered. * Rewrote the package description. Also submitted it to the upstream with the suggestion to replace the current description. * Used tarballs accoding to the policy. * Added the STATISTICS port option to reflect the option in configure. PR: 224810 Submitted by: myself Approved by: tcberner (mentor), mat Differential Revision: https://reviews.freebsd.org/D13903
Diffstat (limited to 'devel')
-rw-r--r--devel/oniguruma/Makefile51
-rw-r--r--devel/oniguruma/distinfo6
-rw-r--r--devel/oniguruma/pkg-descr19
-rw-r--r--devel/oniguruma/pkg-plist21
4 files changed, 45 insertions, 52 deletions
diff --git a/devel/oniguruma/Makefile b/devel/oniguruma/Makefile
index 5d5551b306ed..b2597145cdc3 100644
--- a/devel/oniguruma/Makefile
+++ b/devel/oniguruma/Makefile
@@ -2,40 +2,41 @@
# $FreeBSD$
PORTNAME= oniguruma
-PORTVERSION= 6.6.1
-DISTVERSIONPREFIX= v
-PORTREVISION= 1
+DISTVERSION= 6.7.0
CATEGORIES= devel textproc
+MASTER_SITES= https://github.com/kkos/${PORTNAME}/releases/download/v${DISTVERSION}/
+DISTNAME= onig-${DISTVERSION}
-MAINTAINER= rob@theseusnetworking.com
-COMMENT= BSDL Regular Expressions library compatible with POSIX/GNU/Perl
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Regular expressions library compatible with POSIX/GNU/Perl
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pathfix autoreconf libtool
-USE_GITHUB= yes
-GH_ACCOUNT= kkos
+USES= autoreconf pathfix libtool # configure provided in the tarball breaks: https://github.com/kkos/oniguruma/issues/73
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+PATHFIX_MAKEFILEIN= Makefile.am
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+TEST_WRKSRC= ${WRKSRC}/test
+TEST_TARGET= test
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= STATISTICS DOCS EXAMPLES
+STATISTICS_DESC= Take matching time statistical data (debug feature)
-PATHFIX_MAKEFILEIN= Makefile.am
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
-TEST_TARGET= test
-TEST_WRKSRC= ${WRKSRC}/test
-
-post-patch:
- @${REINPLACE_CMD} -e \
- '/^INCLUDES/s|$$(includedir)|| ; \
- s|$$(<)|$$(@).in|' ${WRKSRC}/Makefile.am
-
-post-install:
+STATISTICS_CONFIGURE_WITH= statistics
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} HISTORY README ${STAGEDIR}${DOCSDIR})
- (cd ${WRKSRC}/doc && ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR})
+ cd ${WRKSRC} && ${INSTALL_DATA} HISTORY README ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKSRC}/sample && ${INSTALL_DATA} *.c ${STAGEDIR}${EXAMPLESDIR})
+ cd ${WRKSRC}/sample && ${INSTALL_DATA} *.c ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/devel/oniguruma/distinfo b/devel/oniguruma/distinfo
index 205583e08829..189f7a7db9c6 100644
--- a/devel/oniguruma/distinfo
+++ b/devel/oniguruma/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1507483426
-SHA256 (kkos-oniguruma-v6.6.1_GH0.tar.gz) = 08d5221ced206470536045a948cced32a7e07259a9b28c044daa364399c36fe8
-SIZE (kkos-oniguruma-v6.6.1_GH0.tar.gz) = 610072
+TIMESTAMP = 1515879790
+SHA256 (onig-6.7.0.tar.gz) = 32d73c37d3c350b16287d86288f4bc98b95467fc37091cbcade60d83b01da073
+SIZE (onig-6.7.0.tar.gz) = 952950
diff --git a/devel/oniguruma/pkg-descr b/devel/oniguruma/pkg-descr
index ea8eea7a47db..260276132760 100644
--- a/devel/oniguruma/pkg-descr
+++ b/devel/oniguruma/pkg-descr
@@ -1,5 +1,18 @@
-Oniguruma is a regular expressions library. The characteristics of this
-library is that different character encoding for every regular
-expression object can be specified.
+Oniguruma is a modern and flexible regular expressions library. It
+encompasses features from different regular expression implementations
+that traditionally exist in different languages. It comes close to
+being a complete superset of all regular expression features found
+in other regular expression implementations.
+
+Its features include:
+* Character encoding can be specified per regular expression object.
+* Several regular expression types are supported:
+ * POSIX
+ * Grep
+ * GNU Regex
+ * Perl
+ * Java
+ * Ruby
+ * Emacs
WWW: https://github.com/kkos/oniguruma
diff --git a/devel/oniguruma/pkg-plist b/devel/oniguruma/pkg-plist
index bc339a26e6e1..dde1453bb0c5 100644
--- a/devel/oniguruma/pkg-plist
+++ b/devel/oniguruma/pkg-plist
@@ -2,28 +2,7 @@ bin/onig-config
include/oniggnu.h
include/onigposix.h
include/oniguruma.h
-lib/libonig.a
lib/libonig.so
lib/libonig.so.4
lib/libonig.so.4.0.0
libdata/pkgconfig/oniguruma.pc
-%%PORTDOCS%%%%DOCSDIR%%/API
-%%PORTDOCS%%%%DOCSDIR%%/API.ja
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/FAQ.ja
-%%PORTDOCS%%%%DOCSDIR%%/HISTORY
-%%PORTDOCS%%%%DOCSDIR%%/RE
-%%PORTDOCS%%%%DOCSDIR%%/RE.ja
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/UNICODE_PROPERTIES
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bug_fix.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/crnl.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/encode.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/listcap.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/names.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/posix.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scan.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sql.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/syntax.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/user_property.c