aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-11-16 20:50:57 +0800
committerantoine <antoine@FreeBSD.org>2013-11-16 20:50:57 +0800
commitc24e0e15cd0691d01fad12124a0b0f4dc99226f8 (patch)
treec15a0c1dcc8e16ab9240d5111879d6b23f620503 /devel
parent833ba2e57406f5ff7b2e712cdae9ccb30aad8242 (diff)
downloadfreebsd-ports-gnome-c24e0e15cd0691d01fad12124a0b0f4dc99226f8.tar.gz
freebsd-ports-gnome-c24e0e15cd0691d01fad12124a0b0f4dc99226f8.tar.zst
freebsd-ports-gnome-c24e0e15cd0691d01fad12124a0b0f4dc99226f8.zip
New port: devel/pecl-jsonc
PECL extension for JSON serialization PR: ports/181538 Submitted by: Gasol Wu
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-jsonc/Makefile24
-rw-r--r--devel/pecl-jsonc/distinfo2
-rw-r--r--devel/pecl-jsonc/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2dc1f329f05b..51b29b771cee 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3273,6 +3273,7 @@
SUBDIR += pecl-inotify
SUBDIR += pecl-intl
SUBDIR += pecl-jsmin
+ SUBDIR += pecl-jsonc
SUBDIR += pecl-judy
SUBDIR += pecl-libevent
SUBDIR += pecl-mcve
diff --git a/devel/pecl-jsonc/Makefile b/devel/pecl-jsonc/Makefile
new file mode 100644
index 000000000000..74a1825b2287
--- /dev/null
+++ b/devel/pecl-jsonc/Makefile
@@ -0,0 +1,24 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= jsonc
+PORTVERSION= 1.3.1
+CATEGORIES= devel
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= PECL extension for JSON manipulation
+
+LICENSE= PHP301
+
+CONFLICTS_INSTALL= php54-json-5* php55-json-5* php5-json-5*
+
+CONFIGURE_ARGS= --with-jsonc
+USE_PHP= yes
+USE_PHPEXT= yes
+IGNORE_WITH_PHP=52 53
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-jsonc/distinfo b/devel/pecl-jsonc/distinfo
new file mode 100644
index 000000000000..f5dff8fb0be3
--- /dev/null
+++ b/devel/pecl-jsonc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/jsonc-1.3.1.tgz) = 9913559265422f3ab5ea8f7d99500fbec77d5b4c944261870237978447a3beda
+SIZE (PECL/jsonc-1.3.1.tgz) = 59552
diff --git a/devel/pecl-jsonc/pkg-descr b/devel/pecl-jsonc/pkg-descr
new file mode 100644
index 000000000000..c05e27a70759
--- /dev/null
+++ b/devel/pecl-jsonc/pkg-descr
@@ -0,0 +1,4 @@
+Support for JSON (JavaScript Object Notation) serialization. This is a drop-in
+alternative to PHP standard json extension.
+
+WWW: http://pecl.php.net/package/jsonc