aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2006-03-18 05:30:00 +0800
committernetchild <netchild@FreeBSD.org>2006-03-18 05:30:00 +0800
commitc6e2910cef73e6608a9b5887427a79643608a31b (patch)
tree415c7b7ad56dfca132aa2a044d9e5e849bc7a79e /devel
parent532daa6b4d6da950b5fb9575706b28a957559885 (diff)
downloadfreebsd-ports-gnome-c6e2910cef73e6608a9b5887427a79643608a31b.tar.gz
freebsd-ports-gnome-c6e2910cef73e6608a9b5887427a79643608a31b.tar.zst
freebsd-ports-gnome-c6e2910cef73e6608a9b5887427a79643608a31b.zip
The previous revision resulted in a lib with unresolvable symbols. This
seems to be a bug in gcc 3.4. As a workaround only use level one optimization (-O1). Approved by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/pwlib/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 43c770b663ad..087f48d08965 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwlib
PORTVERSION= 1.9.2
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.voxgratia.org/releases/
@@ -31,12 +31,14 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ CFLAGS="${CFLAGS} -O1"
+MAKE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- STDCCFLAGS+="-I${LOCALBASE}"
+ STDCCFLAGS+="-I${LOCALBASE}" \
+ CFLAGS="${CFLAGS} -O1"
# if explicitely asked for, depend upon it
.if defined(WITH_SDL)