aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
commitda74e1e2753beef93258c048d602476b4b4dfd7c (patch)
tree38d55d2134664c2fa5ec17aa6dadae38a1ec9e4f /devel
parent355f300440d2bd9dae6636ba5c8bf4eacacc9567 (diff)
downloadfreebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.gz
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.zst
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Diffstat (limited to 'devel')
-rw-r--r--devel/bonobo/Makefile15
-rw-r--r--devel/bonobo/files/patch-ac12
-rw-r--r--devel/bonobo/pkg-plist4
-rw-r--r--devel/gconf/Makefile15
-rw-r--r--devel/gconf/files/patch-ab19
-rw-r--r--devel/gconf/pkg-plist15
-rw-r--r--devel/gnome-vfs1/Makefile24
-rw-r--r--devel/gnome-vfs1/pkg-plist4
-rw-r--r--devel/gnomevfs/Makefile24
-rw-r--r--devel/gnomevfs/pkg-plist4
-rw-r--r--devel/libglade/Makefile5
-rw-r--r--devel/libglade/files/patch-ab24
-rw-r--r--devel/oaf/Makefile13
-rw-r--r--devel/oaf/files/patch-aa17
14 files changed, 45 insertions, 150 deletions
diff --git a/devel/bonobo/Makefile b/devel/bonobo/Makefile
index 24bba8ba24af..26d4cac04bb5 100644
--- a/devel/bonobo/Makefile
+++ b/devel/bonobo/Makefile
@@ -15,27 +15,22 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnomeprint.16:${PORTSDIR}/print/gnomeprint
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix oaf gnomehier gnomeprint
+GNOME_HTML_DIR= ${PREFIX}/share/doc/bonobo
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure libefs/configure
-CONFIGURE_ARGS= --disable-gtk-doc \
- --with-html-dir=${PREFIX}/share/doc/bonobo
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/devel/bonobo/files/patch-ac b/devel/bonobo/files/patch-ac
deleted file mode 100644
index 727e795ebd2f..000000000000
--- a/devel/bonobo/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- libefs/Makefile.in.orig Mon May 14 17:01:15 2001
-+++ libefs/Makefile.in Tue May 22 11:04:58 2001
-@@ -37,3 +37,3 @@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/pkgconfig
- pkgincludedir = $(includedir)/@PACKAGE@
-@@ -85,3 +85,3 @@
-
--pcdir = $(libdir)/pkgconfig
-+pcdir = $(pkglibdir)
- pc_SCRIPTS = libefs.pc
diff --git a/devel/bonobo/pkg-plist b/devel/bonobo/pkg-plist
index 42e8abccacef..140e6e747380 100644
--- a/devel/bonobo/pkg-plist
+++ b/devel/bonobo/pkg-plist
@@ -244,14 +244,10 @@ share/locale/uk/LC_MESSAGES/bonobo.mo
share/locale/wa/LC_MESSAGES/bonobo.mo
share/locale/zh_CN/LC_MESSAGES/bonobo.mo
share/locale/zh_TW/LC_MESSAGES/bonobo.mo
-@dirrm share/gnome/ui
@dirrm share/gnome/help/audio_ulaw/C/images
@dirrm share/gnome/help/audio_ulaw/C
@dirrm share/gnome/help/audio_ulaw
@dirrm share/doc/bonobo/libefs
@dirrm share/doc/bonobo/bonobo
@dirrm share/doc/bonobo
-@dirrm lib/bonobo/plugin
@dirrm include/gnome-1.0/bonobo
-@unexec /bin/rmdir %D/lib/bonobo/monikers 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/lib/bonobo 2>/dev/null || /usr/bin/true
diff --git a/devel/gconf/Makefile b/devel/gconf/Makefile
index b1966b2f565a..0942f6960dd9 100644
--- a/devel/gconf/Makefile
+++ b/devel/gconf/Makefile
@@ -16,28 +16,21 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile \
- oaf.0:${PORTSDIR}/devel/oaf \
db3.2:${PORTSDIR}/databases/db3
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack glib12 gtk12 oaf libxml orbit
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-
-post-install:
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/apps
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/schemas/apps
.include <bsd.port.mk>
diff --git a/devel/gconf/files/patch-ab b/devel/gconf/files/patch-ab
deleted file mode 100644
index 032c7e5eab94..000000000000
--- a/devel/gconf/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile.in.orig Mon May 14 13:07:48 2001
-+++ Makefile.in Mon May 21 23:29:41 2001
-@@ -37,3 +37,3 @@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/pkgconfig
- pkgincludedir = $(includedir)/@PACKAGE@
-@@ -144,3 +144,3 @@
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(pkglibdir)
- pkgconfig_DATA = gconf.pc gconfgtk.pc
-@@ -476,4 +476,4 @@
- install-data-local:
-- -mkdir -p $(DESTDIR)$(datadir)/aclocal
-- $(INSTALL_DATA) gconf.m4 $(DESTDIR)$(datadir)/aclocal/gconf-$(MAJOR_VERSION).m4
-+ -mkdir -p $(DESTDIR)$(prefix)/share/aclocal
-+ $(INSTALL_DATA) gconf.m4 $(DESTDIR)$(prefix)/share/aclocal/gconf-$(MAJOR_VERSION).m4
- @echo "**** NOTE ****"
diff --git a/devel/gconf/pkg-plist b/devel/gconf/pkg-plist
index 1194779e1795..a34b17e3c391 100644
--- a/devel/gconf/pkg-plist
+++ b/devel/gconf/pkg-plist
@@ -61,18 +61,3 @@ share/locale/zh_CN/LC_MESSAGES/GConf.mo
@dirrm include/gconf/1/gconf
@dirrm include/gconf/1
@dirrm etc/gconf/1
-@exec /bin/mkdir -p %D/etc/gconf/gconf.xml.defaults/apps
-@exec /bin/mkdir -p %D/etc/gconf/gconf.xml.defaults/schemas/apps
-@unexec /bin/rmdir %D/lib/GConf 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/include/gconf 2>/dev/null || /usr/bin/true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/apps/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/schemas/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/schemas/apps/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rmdir %D/etc/gconf/schemas 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.mandatory 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/schemas/apps 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/schemas 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/apps 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf 2>/dev/null || /usr/bin/true
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 0e6e1a2e64dd..1775fc998cf0 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -16,37 +16,29 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- iconv.3:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
-RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix glib12 libxml gtk12 orbit gconf \
+ gnomemimedata gnomelibs
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
- @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
-
-post-patch:
- @${PERL} -pi -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/libcharset/Makefile.in
.include <bsd.port.mk>
diff --git a/devel/gnome-vfs1/pkg-plist b/devel/gnome-vfs1/pkg-plist
index beba41f47813..ec29ffe212d7 100644
--- a/devel/gnome-vfs1/pkg-plist
+++ b/devel/gnome-vfs1/pkg-plist
@@ -111,10 +111,6 @@ share/locale/tr/LC_MESSAGES/gnome-vfs.mo
share/locale/uk/LC_MESSAGES/gnome-vfs.mo
share/locale/wa/LC_MESSAGES/gnome-vfs.mo
share/locale/zh_TW/LC_MESSAGES/gnome-vfs.mo
-@dirrm lib/vfs/modules
@dirrm lib/vfs/extfs
@dirrm include/gnome-vfs-1.0/libgnomevfs
@dirrm include/gnome-vfs-1.0
-@dirrm etc/vfs/modules
-@dirrm etc/vfs
-@unexec /bin/rmdir %D/lib/vfs 2>/dev/null || /usr/bin/true
diff --git a/devel/gnomevfs/Makefile b/devel/gnomevfs/Makefile
index 0e6e1a2e64dd..1775fc998cf0 100644
--- a/devel/gnomevfs/Makefile
+++ b/devel/gnomevfs/Makefile
@@ -16,37 +16,29 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- iconv.3:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
-RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix glib12 libxml gtk12 orbit gconf \
+ gnomemimedata gnomelibs
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
- @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
-
-post-patch:
- @${PERL} -pi -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/libcharset/Makefile.in
.include <bsd.port.mk>
diff --git a/devel/gnomevfs/pkg-plist b/devel/gnomevfs/pkg-plist
index beba41f47813..ec29ffe212d7 100644
--- a/devel/gnomevfs/pkg-plist
+++ b/devel/gnomevfs/pkg-plist
@@ -111,10 +111,6 @@ share/locale/tr/LC_MESSAGES/gnome-vfs.mo
share/locale/uk/LC_MESSAGES/gnome-vfs.mo
share/locale/wa/LC_MESSAGES/gnome-vfs.mo
share/locale/zh_TW/LC_MESSAGES/gnome-vfs.mo
-@dirrm lib/vfs/modules
@dirrm lib/vfs/extfs
@dirrm include/gnome-vfs-1.0/libgnomevfs
@dirrm include/gnome-vfs-1.0
-@dirrm etc/vfs/modules
-@dirrm etc/vfs
-@unexec /bin/rmdir %D/lib/vfs 2>/dev/null || /usr/bin/true
diff --git a/devel/libglade/Makefile b/devel/libglade/Makefile
index 21990853de6c..8ce5faacf802 100644
--- a/devel/libglade/Makefile
+++ b/devel/libglade/Makefile
@@ -14,12 +14,11 @@ MASTER_SITE_SUBDIR= stable/sources/libglade
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnomedb.0:${PORTSDIR}/databases/gnomedb
-
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier gnomedb
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-bonobo --enable-gnomedb
diff --git a/devel/libglade/files/patch-ab b/devel/libglade/files/patch-ab
index b176d42e4de6..244d49bd8e05 100644
--- a/devel/libglade/files/patch-ab
+++ b/devel/libglade/files/patch-ab
@@ -1,34 +1,20 @@
$FreeBSD$
---- Makefile.in.orig Fri Sep 7 06:00:35 2001
-+++ Makefile.in Tue Sep 11 15:11:04 2001
-@@ -34,7 +34,7 @@
- includedir = @includedir@
- oldincludedir = /usr/include
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/pkgconfig
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = .
-
-@@ -167,15 +167,15 @@
+--- Makefile.in.orig Sat Jul 6 23:09:19 2002
++++ Makefile.in Sat Jul 6 23:12:35 2002
+@@ -167,12 +167,12 @@
bin_SCRIPTS = libglade-config libglade-xgettext
noinst_PROGRAMS = test-libglade
test_libglade_LDADD = $(THE_LIBS) $(XML_LIBS)
-SUBDIRS = intl macros glade doc
+SUBDIRS = intl macros glade
--m4datadir = $(datadir)/aclocal
-+m4datadir = $(prefix)/share/aclocal
+ m4datadir = $(prefix)/share/aclocal
m4data_DATA = libglade.m4
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = libgladeConf.sh
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = libglade.pc $(libglade_gnome_pc) $(libglade_bonobo_pc) \
- $(libglade_gnomedb_pc)
-
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index 3905b08914b8..7f6472c36f6b 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -19,23 +19,20 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gtk12 orbit libxml
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_GNOMELIBS= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
- --disable-more-warnings --disable-gtk-doc
+ --disable-more-warnings
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= oafd.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/devel/oaf/files/patch-aa b/devel/oaf/files/patch-aa
index 1d0c2fab43c1..e0caa8a8ec2c 100644
--- a/devel/oaf/files/patch-aa
+++ b/devel/oaf/files/patch-aa
@@ -1,15 +1,14 @@
---- Makefile.in.orig Wed May 10 02:42:25 2000
-+++ Makefile.in Thu Jun 1 14:21:12 2000
-@@ -95,10 +95,10 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig Fri Jul 5 11:27:26 2002
++++ Makefile.in Fri Jul 5 11:28:17 2002
+@@ -145,7 +145,7 @@
+ oafconfig_DATA = oaf-config.xml oaf-config.xml.sample $(NULL)
- EXTRA_DIST = oaf-config.in oaf.m4 oafConf.sh.in oafConf.sh
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = oafConf.sh
--m4datadir = $(datadir)/aclocal
-+m4datadir = $(prefix)/share/aclocal
- m4data_DATA = oaf.m4
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ m4datadir = $(prefix)/share/aclocal