aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-01-27 13:44:52 +0800
committerdanfe <danfe@FreeBSD.org>2005-01-27 13:44:52 +0800
commitdbfe9c96cfd9e21115ee41ad70127d7f7fe617b8 (patch)
tree849230368571d28098f4c3819129338354eb6bf6 /devel
parentd45561351a9f7687542379471c8273b101973ba0 (diff)
downloadfreebsd-ports-gnome-dbfe9c96cfd9e21115ee41ad70127d7f7fe617b8.tar.gz
freebsd-ports-gnome-dbfe9c96cfd9e21115ee41ad70127d7f7fe617b8.tar.zst
freebsd-ports-gnome-dbfe9c96cfd9e21115ee41ad70127d7f7fe617b8.zip
- Unbreak the build
- Minor indentation nits in Makefile - Fix a typo in pkg-descr
Diffstat (limited to 'devel')
-rw-r--r--devel/libcoro/Makefile15
-rw-r--r--devel/libcoro/pkg-descr2
2 files changed, 7 insertions, 10 deletions
diff --git a/devel/libcoro/Makefile b/devel/libcoro/Makefile
index 9b65a890a158..daa5a9b466c9 100644
--- a/devel/libcoro/Makefile
+++ b/devel/libcoro/Makefile
@@ -1,6 +1,6 @@
# Ports collection Makefile for: libcoro
# Date created: 22 June 2000
-# Whom: Kelly Yancey <kbyanc@posi.net>
+# Whom: Kelly Yancey <kbyanc@posi.net>
#
# $FreeBSD$
#
@@ -13,22 +13,19 @@ MASTER_SITE_SUBDIR= kbyanc
DISTNAME= coro-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= C library that implements coroutines
+COMMENT= C library that implements coroutines
ONLY_FOR_ARCHS= i386
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --arch arch/x86-freebsd
+NOPRECIOUSMAKEVARS= yes
MAN2= coro.2
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Broken by changes to make(1) on FreeBSD >= 5.x"
-.endif
-
post-extract:
${CP} -r ${WRKSRC}/arch/x86-linux ${WRKSRC}/arch/x86-freebsd
+ ${SED} -e '43,43s/$$/ __attribute__((noreturn,regparm(1)))/' \
+ ${WRKSRC}/arch/x86-linux/coro.c > ${WRKSRC}/arch/x86-freebsd/coro.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libcoro/pkg-descr b/devel/libcoro/pkg-descr
index 073d4f6cb441..d0fa050e1ee7 100644
--- a/devel/libcoro/pkg-descr
+++ b/devel/libcoro/pkg-descr
@@ -9,7 +9,7 @@ Excerpt from The Art of Computer Programming by D. E. Knuth:
coro is a C library that implements the low level handling of coroutines.
Despite it's simplicity, there is no portable way to implement them. The goal
of this library is to build a standard API for coroutines and implement it for
-as many architectures as possible. Currently on the i386 architecture is
+as many architectures as possible. Currently only the i386 architecture is
supported.
-Kelly