aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-07-01 04:02:43 +0800
committeradamw <adamw@FreeBSD.org>2016-07-01 04:02:43 +0800
commite2c38d6eca246ad91055de2bdaebfe5cff447454 (patch)
tree8b3e22b054d084e34040e8656cb76f2f6fb806d0 /devel
parentd90aa13c71b179143abbc37e521b47c33b9077c9 (diff)
downloadfreebsd-ports-gnome-e2c38d6eca246ad91055de2bdaebfe5cff447454.tar.gz
freebsd-ports-gnome-e2c38d6eca246ad91055de2bdaebfe5cff447454.tar.zst
freebsd-ports-gnome-e2c38d6eca246ad91055de2bdaebfe5cff447454.zip
Convert a couple ports that use both _CMAKE_ON and _CMAKE_OFF to _CMAKE_BOOL.
Use options helpers all the way in math/carve, because I couldn't help myself.
Diffstat (limited to 'devel')
-rw-r--r--devel/libftdi/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/devel/libftdi/Makefile b/devel/libftdi/Makefile
index d42906f93c88..1ecf623f3438 100644
--- a/devel/libftdi/Makefile
+++ b/devel/libftdi/Makefile
@@ -24,14 +24,12 @@ OPTIONS_SUB= yes
BOOST_DESC= C++ bindings (requires Boost)
BOOST_LIB_DEPENDS= libboost_system.so:devel/boost-libs
-BOOST_CMAKE_ON= -DFTDIPP:BOOL=ON
-BOOST_CMAKE_OFF= -DFTDIPP:BOOL=OFF
+BOOST_CMAKE_BOOL= FTDIPP
BOOST_CXXFLAGS= -I${LOCALBASE}/include
PYTHON_DESC= Python bindings
PYTHON_BUILD_DEPENDS= swig2.0:devel/swig20
-PYTHON_CMAKE_ON= -DPYTHON_BINDINGS:BOOL=ON
-PYTHON_CMAKE_OFF= -DPYTHON_BINDINGS:BOOL=OFF
+PYTHON_CMAKE_BOOL= PYTHON_BINDINGS
PYTHON_USES= python
.include <bsd.port.options.mk>