aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2017-07-22 11:34:26 +0800
committeracm <acm@FreeBSD.org>2017-07-22 11:34:26 +0800
commite3af924bfc9bec8b09f5fd0ef2dd44d0ade4987c (patch)
treefc812014bdad744627bca80e7b3c33319b760ead /devel
parent63d19905db93bb958007e576407b5d819fb6d796 (diff)
downloadfreebsd-ports-gnome-e3af924bfc9bec8b09f5fd0ef2dd44d0ade4987c.tar.gz
freebsd-ports-gnome-e3af924bfc9bec8b09f5fd0ef2dd44d0ade4987c.tar.zst
freebsd-ports-gnome-e3af924bfc9bec8b09f5fd0ef2dd44d0ade4987c.zip
- New port: devel/dcd-client
DCD is not an IDE. DCD is designed to provide autocompletion for your favorite text editor. If you are looking for an IDE, try one of these. DCD consists of a client and a server. The client (dcd-client) is almost always used through a text editor script or plugin, though it can be used from the command line. The server (dcd-server) is responsible for caching imported files, calculating autocomplete information, and sending it back to the client. WWW: https://github.com/dlang-community/DCD
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/dcd-client/Makefile13
2 files changed, 14 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 749a642a627b..f7f0556fc83b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -409,6 +409,7 @@
SUBDIR += dbus-sharp
SUBDIR += dbus-sharp-glib
SUBDIR += dbus-tcl
+ SUBDIR += dcd-client
SUBDIR += dcd-server
SUBDIR += dcmtk
SUBDIR += dconf
diff --git a/devel/dcd-client/Makefile b/devel/dcd-client/Makefile
new file mode 100644
index 000000000000..33416c84d67c
--- /dev/null
+++ b/devel/dcd-client/Makefile
@@ -0,0 +1,13 @@
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+PKGNAMESUFFIX= -client
+
+COMMENT= Auto-complete program for the D programming language (client)
+
+MASTERDIR= ${.CURDIR}/../../devel/dcd-server
+
+DUB_CONFIG= client
+
+.include "${MASTERDIR}/Makefile"