aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-10-23 00:01:23 +0800
committertijl <tijl@FreeBSD.org>2013-10-23 00:01:23 +0800
commite54dc7358921541134fb2c6f2b0b63f4c564e0df (patch)
treeb7398940156b74250b32740b8c87260e926d8f9c /devel
parentaa767895ba13526d49c192969807cefb239a29fd (diff)
downloadfreebsd-ports-gnome-e54dc7358921541134fb2c6f2b0b63f4c564e0df.tar.gz
freebsd-ports-gnome-e54dc7358921541134fb2c6f2b0b63f4c564e0df.tar.zst
freebsd-ports-gnome-e54dc7358921541134fb2c6f2b0b63f4c564e0df.zip
- Support staging.
- New LIB_DEPENDS syntax. - USES=gmake. - Options helpers. - Make the Requires field private in pkgconfig file.
Diffstat (limited to 'devel')
-rw-r--r--devel/libtifiles2/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/devel/libtifiles2/Makefile b/devel/libtifiles2/Makefile
index a90c5dbef68b..cf2014d21707 100644
--- a/devel/libtifiles2/Makefile
+++ b/devel/libtifiles2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libtifiles2
PORTVERSION= 1.1.6
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.17
@@ -10,33 +11,26 @@ COMMENT= TI calculator file types library
LICENSE= GPLv2
-LIB_DEPENDS= ticonv:${PORTSDIR}/converters/libticonv
+LIB_DEPENDS= libticonv.so:${PORTSDIR}/converters/libticonv
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
GNU_CONFIGURE= yes
CONFIGURE_ENV= ARCHIVE_CFLAGS=" " ARCHIVE_LIBS="-larchive"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
post-patch:
- @${REINPLACE_CMD} 's,libarchive,,' ${WRKSRC}/tifiles2.pc.in
+ @${REINPLACE_CMD} -e 's/libarchive/glib-2.0,ticonv/' \
+ -e '/Requires:/d' ${WRKSRC}/tifiles2.pc.in
.include <bsd.port.mk>