aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-05-29 01:07:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-05-29 01:07:17 +0800
commite7b5f991d872b2133fc30a0b252d946acb17f392 (patch)
treeef76b6d8c946c6ba51d0fa4eac36f69e183ca561 /devel
parent7dab02ca819a2008cd1d52cb5ac54e2b20602157 (diff)
downloadfreebsd-ports-gnome-e7b5f991d872b2133fc30a0b252d946acb17f392.tar.gz
freebsd-ports-gnome-e7b5f991d872b2133fc30a0b252d946acb17f392.tar.zst
freebsd-ports-gnome-e7b5f991d872b2133fc30a0b252d946acb17f392.zip
- Add rubygem-lazy_priority_queue 0.1.1
Lazy priority queue is a pure Ruby priority queue which implements a lazy binomial heap. It supports the change priority operation, being suitable for algorithms like Dijkstra's shortest path and Prim's minimum spanning tree. It can be instantiated as a min-priority queue as well as a max-priority queue. WWW: https://github.com/matiasbattocchia/lazy_priority_queue
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-lazy_priority_queue/Makefile18
-rw-r--r--devel/rubygem-lazy_priority_queue/distinfo3
-rw-r--r--devel/rubygem-lazy_priority_queue/pkg-descr6
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 69a19a9387c1..f3170ec3c360 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4996,6 +4996,7 @@
SUBDIR += rubygem-kgio
SUBDIR += rubygem-launchy
SUBDIR += rubygem-launchy22
+ SUBDIR += rubygem-lazy_priority_queue
SUBDIR += rubygem-librarian
SUBDIR += rubygem-librarianp
SUBDIR += rubygem-libyajl2
diff --git a/devel/rubygem-lazy_priority_queue/Makefile b/devel/rubygem-lazy_priority_queue/Makefile
new file mode 100644
index 000000000000..0c7930baa25e
--- /dev/null
+++ b/devel/rubygem-lazy_priority_queue/Makefile
@@ -0,0 +1,18 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lazy_priority_queue
+PORTVERSION= 0.1.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Priority queue implemented using a lazy binomial heap
+
+LICENSE= BSD2CLAUSE
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-lazy_priority_queue/distinfo b/devel/rubygem-lazy_priority_queue/distinfo
new file mode 100644
index 000000000000..52adb2819003
--- /dev/null
+++ b/devel/rubygem-lazy_priority_queue/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1464389841
+SHA256 (rubygem/lazy_priority_queue-0.1.1.gem) = e5d4ea8d037e8743afc91019fc23f5f6858372fea73e05e8244f8964f0634337
+SIZE (rubygem/lazy_priority_queue-0.1.1.gem) = 5632
diff --git a/devel/rubygem-lazy_priority_queue/pkg-descr b/devel/rubygem-lazy_priority_queue/pkg-descr
new file mode 100644
index 000000000000..a305c371956d
--- /dev/null
+++ b/devel/rubygem-lazy_priority_queue/pkg-descr
@@ -0,0 +1,6 @@
+Lazy priority queue is a pure Ruby priority queue which implements a lazy
+binomial heap. It supports the change priority operation, being suitable for
+algorithms like Dijkstra's shortest path and Prim's minimum spanning tree. It
+can be instantiated as a min-priority queue as well as a max-priority queue.
+
+WWW: https://github.com/matiasbattocchia/lazy_priority_queue