aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2005-01-25 15:31:15 +0800
committerclsung <clsung@FreeBSD.org>2005-01-25 15:31:15 +0800
commite85b454bd3d54c4f91df2644dbffa0613dd65466 (patch)
tree01de4561c5ab15ec17f36fb3e986b84a7a2df2f3 /devel
parentd3167f553d224b5934200194bf9afa4608d79bad (diff)
downloadfreebsd-ports-gnome-e85b454bd3d54c4f91df2644dbffa0613dd65466.tar.gz
freebsd-ports-gnome-e85b454bd3d54c4f91df2644dbffa0613dd65466.tar.zst
freebsd-ports-gnome-e85b454bd3d54c4f91df2644dbffa0613dd65466.zip
- Perl module for accounting SVK repository
PR: ports/73489 Submitted by: Yuan-Chung Hsiao <ychsiao AT ychsiao dot org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Accounting-SVK/Makefile26
-rw-r--r--devel/p5-Log-Accounting-SVK/distinfo2
-rw-r--r--devel/p5-Log-Accounting-SVK/pkg-descr11
-rw-r--r--devel/p5-Log-Accounting-SVK/pkg-plist8
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c8146e4cc963..02f2991346ba 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -900,6 +900,7 @@
SUBDIR += p5-Locale-gettext
SUBDIR += p5-Locale-libintl
SUBDIR += p5-LockFile-Simple
+ SUBDIR += p5-Log-Accounting-SVK
SUBDIR += p5-Log-Agent
SUBDIR += p5-Log-Agent-Logger
SUBDIR += p5-Log-Dispatch
diff --git a/devel/p5-Log-Accounting-SVK/Makefile b/devel/p5-Log-Accounting-SVK/Makefile
new file mode 100644
index 000000000000..e68bc67f27e1
--- /dev/null
+++ b/devel/p5-Log-Accounting-SVK/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Log-Accounting-SVK
+# Date created: 21 Oct 2004
+# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Accounting-SVK
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GU/GOD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ychsiao@ychsiao.org
+COMMENT= Perl module for accounting SVK repository
+
+BUILD_DEPENDS= ${SITE_PERL}/SVK.pm:${PORTSDIR}/devel/svk \
+ ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy \
+ ${SITE_PERL}/Algorithm/Accounting.pm:${PORTSDIR}/devel/p5-Algorithm-Accounting
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Accounting::SVK.3
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Accounting-SVK/distinfo b/devel/p5-Log-Accounting-SVK/distinfo
new file mode 100644
index 000000000000..533aab2586e7
--- /dev/null
+++ b/devel/p5-Log-Accounting-SVK/distinfo
@@ -0,0 +1,2 @@
+MD5 (Log-Accounting-SVK-0.03.tar.gz) = 094e61abe18987d6a95cdbd394808f08
+SIZE (Log-Accounting-SVK-0.03.tar.gz) = 8770
diff --git a/devel/p5-Log-Accounting-SVK/pkg-descr b/devel/p5-Log-Accounting-SVK/pkg-descr
new file mode 100644
index 000000000000..12be35821a5e
--- /dev/null
+++ b/devel/p5-Log-Accounting-SVK/pkg-descr
@@ -0,0 +1,11 @@
+This module make use of Algorithm::Accounting and SVK to do
+simple accounting of any SVK repository. The installed
+svn-accounting.pl script demostrate a simple use to this module,
+you may try:
+
+ svk-accounting.pl //
+
+This will display all the contributions of developers under
+repository '//'. You may also specify depotpath like '//trunk/svk'.
+
+WWW: http://search.cpan.org/dist/Log-Accounting-SVK/
diff --git a/devel/p5-Log-Accounting-SVK/pkg-plist b/devel/p5-Log-Accounting-SVK/pkg-plist
new file mode 100644
index 000000000000..d67bcfde919b
--- /dev/null
+++ b/devel/p5-Log-Accounting-SVK/pkg-plist
@@ -0,0 +1,8 @@
+bin/svk-accounting.pl
+%%SITE_PERL%%/Log/Accounting/SVK.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Accounting/SVK/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Accounting/SVK
+@unexec rmdir %D/%%SITE_PERL%%/Log/Accounting 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Log 2>/dev/null || true
+@unexec rmdir %D/%%SITe_PERL%%/%%PERL_ARCH%%/auto/Log/Accounting 2>/dev/null ||true
+@unexec rmdir %D/%%SITe_PERL%%/%%PERL_ARCH%%/auto/Log 2>/dev/null ||true