aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2011-08-26 19:32:46 +0800
committerlth <lth@FreeBSD.org>2011-08-26 19:32:46 +0800
commite8c7c97c5e74830b06e5822efa95cd16ef692ae8 (patch)
tree54046404ddc14cb9aff48b23a11008d8e1da3733 /devel
parent014e74a94d70119aa3db5709df91b8da736bc5d9 (diff)
downloadfreebsd-ports-gnome-e8c7c97c5e74830b06e5822efa95cd16ef692ae8.tar.gz
freebsd-ports-gnome-e8c7c97c5e74830b06e5822efa95cd16ef692ae8.tar.zst
freebsd-ports-gnome-e8c7c97c5e74830b06e5822efa95cd16ef692ae8.zip
Add p5-CPAN-Recent-Uploads 0.06, find the distributions recently
uploaded to CPAN.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-CPAN-Recent-Uploads/Makefile28
-rw-r--r--devel/p5-CPAN-Recent-Uploads/distinfo2
-rw-r--r--devel/p5-CPAN-Recent-Uploads/pkg-descr6
-rw-r--r--devel/p5-CPAN-Recent-Uploads/pkg-plist9
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 84d156abec4f..de005d2e1d59 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1243,6 +1243,7 @@
SUBDIR += p5-CPAN-Meta
SUBDIR += p5-CPAN-Meta-YAML
SUBDIR += p5-CPAN-Mini
+ SUBDIR += p5-CPAN-Recent-Uploads
SUBDIR += p5-CPAN-Reporter
SUBDIR += p5-CPAN-Reporter-Smoker
SUBDIR += p5-CPAN-SQLite
diff --git a/devel/p5-CPAN-Recent-Uploads/Makefile b/devel/p5-CPAN-Recent-Uploads/Makefile
new file mode 100644
index 000000000000..b659a3fa9ede
--- /dev/null
+++ b/devel/p5-CPAN-Recent-Uploads/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-CPAN-Recent-Uploads
+# Date created: 2011-08-26
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CPAN-Recent-Uploads
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:BINGOS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Find the distributions recently uploaded to CPAN
+
+RUN_DEPENDS= p5-libwww>=5.835:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=1.56:${PORTSDIR}/net/p5-URI \
+ p5-YAML-Syck>=1.15:${PORTSDIR}/textproc/p5-YAML-Syck
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CPAN::Recent::Uploads.3 \
+ CPAN::Recent::Uploads::Retriever.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Recent-Uploads/distinfo b/devel/p5-CPAN-Recent-Uploads/distinfo
new file mode 100644
index 000000000000..c577a945f5a7
--- /dev/null
+++ b/devel/p5-CPAN-Recent-Uploads/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CPAN-Recent-Uploads-0.06.tar.gz) = d658e22a8a61d9dd33b0458ba90f78f88586b1e06ab79931557f632fbad22f6b
+SIZE (CPAN-Recent-Uploads-0.06.tar.gz) = 12169
diff --git a/devel/p5-CPAN-Recent-Uploads/pkg-descr b/devel/p5-CPAN-Recent-Uploads/pkg-descr
new file mode 100644
index 000000000000..c1c4f64d193a
--- /dev/null
+++ b/devel/p5-CPAN-Recent-Uploads/pkg-descr
@@ -0,0 +1,6 @@
+CPAN::Recent::Uploads provides a mechanism for obtaining a list of
+the RECENT uploads to CPAN as determined from the files produced
+by File::Rsync::Mirror::Recentfile that exist in the authors/
+directory on CPAN.
+
+WWW: http://search.cpan.org/dist/CPAN-Recent-Uploads/
diff --git a/devel/p5-CPAN-Recent-Uploads/pkg-plist b/devel/p5-CPAN-Recent-Uploads/pkg-plist
new file mode 100644
index 000000000000..d0c9d38de75a
--- /dev/null
+++ b/devel/p5-CPAN-Recent-Uploads/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/CPAN/Recent/Uploads/Retriever.pm
+%%SITE_PERL%%/CPAN/Recent/Uploads.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Recent/Uploads/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Recent/Uploads
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Recent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN
+@dirrmtry %%SITE_PERL%%/CPAN/Recent/Uploads
+@dirrmtry %%SITE_PERL%%/CPAN/Recent
+@dirrmtry %%SITE_PERL%%/CPAN