aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-03-03 18:27:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-03-03 18:27:18 +0800
commitea4e4f76153d90f8371f1a2e4e9a96410974b82b (patch)
treef48ce9a6d1eab421cd6e32181381146c15bb461c /devel
parent96e3ffadf1f3e75352ed400a195f2133d0053bef (diff)
downloadfreebsd-ports-gnome-ea4e4f76153d90f8371f1a2e4e9a96410974b82b.tar.gz
freebsd-ports-gnome-ea4e4f76153d90f8371f1a2e4e9a96410974b82b.tar.zst
freebsd-ports-gnome-ea4e4f76153d90f8371f1a2e4e9a96410974b82b.zip
Add py3-prompt_toolkit 1.0.13 (slave port of py-prompt_toolkit)
- While I'm here, add SLAVEDIRS PR: 217478 Submitted by: Danilo G. Baio (dbaio) <dbaio@bsd.com.br>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-prompt_toolkit/Makefile6
-rw-r--r--devel/py3-prompt_toolkit/Makefile10
3 files changed, 15 insertions, 2 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ee19866c8f4a..26a5c059657b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4915,6 +4915,7 @@
SUBDIR += py3-lxml
SUBDIR += py3-mccabe
SUBDIR += py3-nose
+ SUBDIR += py3-prompt_toolkit
SUBDIR += py3-py
SUBDIR += py3-pycodestyle
SUBDIR += py3-pydocstyle
diff --git a/devel/py-prompt_toolkit/Makefile b/devel/py-prompt_toolkit/Makefile
index 5735b68254c3..6ccb627ed53d 100644
--- a/devel/py-prompt_toolkit/Makefile
+++ b/devel/py-prompt_toolkit/Makefile
@@ -13,11 +13,13 @@ COMMENT= Library for building powerful interactive command lines in Python
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
${PYTHON_PKGNAMEPREFIX}wcwidth>=0:devel/py-wcwidth
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils
-USES= python
+USES?= python
+
+SLAVEDIRS= devel/py3-prompt_toolkit
.include <bsd.port.mk>
diff --git a/devel/py3-prompt_toolkit/Makefile b/devel/py3-prompt_toolkit/Makefile
new file mode 100644
index 000000000000..1e079002db0e
--- /dev/null
+++ b/devel/py3-prompt_toolkit/Makefile
@@ -0,0 +1,10 @@
+# $FreeBSD$
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py3-six \
+ ${PYTHON_PKGNAMEPREFIX}wcwidth>=0:devel/py3-wcwidth
+
+USES= python:3.3+
+
+MASTERDIR= ${.CURDIR}/../py-prompt_toolkit
+
+.include "${MASTERDIR}/Makefile"