aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2017-08-16 23:56:26 +0800
committered <ed@FreeBSD.org>2017-08-16 23:56:26 +0800
commiteff5d8a293009dd1f24e7aca7178520f1f110383 (patch)
tree5c4677988cf061e973470e957fb103a879ae049b /devel
parent7e090960c5f42ae3c86437880a80e407aec9b6a4 (diff)
downloadfreebsd-ports-gnome-eff5d8a293009dd1f24e7aca7178520f1f110383.tar.gz
freebsd-ports-gnome-eff5d8a293009dd1f24e7aca7178520f1f110383.tar.zst
freebsd-ports-gnome-eff5d8a293009dd1f24e7aca7178520f1f110383.zip
Add py-toposort.
I am currently in the process of creating ports for various components related to CloudABI, including ARPC (an RPC framework that supports file descriptor passing) and Flower (a capability-based network backplane). The former comes with a script called 'aprotoc' for creating C++ bindings for messages and RPC services. This script depends on Python's toposort package to order declarations in the resulting C++ header file, taking dependencies into account. Reviewed by: mat, wg Differential Revision: https://reviews.freebsd.org/D12046
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-toposort/Makefile20
-rw-r--r--devel/py-toposort/distinfo3
-rw-r--r--devel/py-toposort/pkg-descr3
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9dd59268e656..409a21f52704 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4858,6 +4858,7 @@
SUBDIR += py-tinyrpc
SUBDIR += py-tipper
SUBDIR += py-tooz
+ SUBDIR += py-toposort
SUBDIR += py-total-ordering
SUBDIR += py-tox
SUBDIR += py-trace2html
diff --git a/devel/py-toposort/Makefile b/devel/py-toposort/Makefile
new file mode 100644
index 000000000000..a6a99ab41fa9
--- /dev/null
+++ b/devel/py-toposort/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ed Schouten <ed@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= toposort
+PORTVERSION= 1.5
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ed@FreeBSD.org
+COMMENT= Topological sorting algorithm for Python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES?= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-toposort/distinfo b/devel/py-toposort/distinfo
new file mode 100644
index 000000000000..73566ecbee82
--- /dev/null
+++ b/devel/py-toposort/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502893729
+SHA256 (toposort-1.5.tar.gz) = dba5ae845296e3bf37b042c640870ffebcdeb8cd4df45adaa01d8c5476c557dd
+SIZE (toposort-1.5.tar.gz) = 10294
diff --git a/devel/py-toposort/pkg-descr b/devel/py-toposort/pkg-descr
new file mode 100644
index 000000000000..7f1f780271eb
--- /dev/null
+++ b/devel/py-toposort/pkg-descr
@@ -0,0 +1,3 @@
+Implementation of a topological sorting algorithm for Python.
+
+WWW: https://bitbucket.org/ericvsmith/toposort