aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-12-18 12:08:56 +0800
committerstas <stas@FreeBSD.org>2009-12-18 12:08:56 +0800
commitf15470eb4c83e2132625ec5b5a83d81f769cd682 (patch)
treec7fafaa3c5c01d8e3befee530c095320c9864a77 /devel
parent08549c228f136cb9f8685d5d2e99e85f7e1bf618 (diff)
downloadfreebsd-ports-gnome-f15470eb4c83e2132625ec5b5a83d81f769cd682.tar.gz
freebsd-ports-gnome-f15470eb4c83e2132625ec5b5a83d81f769cd682.tar.zst
freebsd-ports-gnome-f15470eb4c83e2132625ec5b5a83d81f769cd682.zip
- Drop REDIRECT/THREADED options as this libgc variants were moved into the
separate ports.
Diffstat (limited to 'devel')
-rw-r--r--devel/boehm-gc/Makefile23
1 files changed, 2 insertions, 21 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 9277713a5a8c..f4273b4de602 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -18,31 +18,12 @@ COMMENT= Garbage collection and memory leak detection for C and C++
GNU_CONFIGURE= yes
USE_GNOME= gnometarget gnomehack
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-cplusplus --disable-static
+CONFIGURE_ARGS= --enable-cplusplus --disable-static --disable-threads
MAKE_JOBS_UNSAFE= yes
-OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
- FULLDEBUG "Debugging support (see documentation)" off \
- THREADING "POSIX thread support" off \
- PARALLEL_MARK "Parallel-thread marking (faster for SMP)" off
+OPTIONS= FULLDEBUG "Debugging support (see documentation)" off
.include <bsd.port.pre.mk>
-.if defined(WITH_THREADING)
-CONFIGURE_ARGS+= --enable-threads=posix --enable-thread-local-alloc
-CONFIGURE_ENV= CFLAGSS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/}"
-.if defined(WITH_PARALLEL_MARK)
-CONFIGURE_ARGS+= --enable-parallel-mark
-.endif
-PKGNAMESUFFIX= +threaded
-.else
-CONFIGURE_ARGS+= --disable-threads
-PKGNAMESUFFIX= # empty
-.endif
-.if defined(WITH_REDIRECT)
-CONFIGURE_ARGS+= --enable-redirect-malloc
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+redirect
-.endif
.if defined(WITH_FULLDEBUG)
CONFIGURE_ARGS+= --enable-gc-debug
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug