aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2005-04-23 20:00:14 +0800
committerkrion <krion@FreeBSD.org>2005-04-23 20:00:14 +0800
commitf4231d0dbbf6fed8eee1d698564ed1906e9dfecd (patch)
treed06d3e7bab9a1dbbc1d764e8374986c3a29b1294 /devel
parent8c5492865b39b2306fcb55e1a162bc566a2042d6 (diff)
downloadfreebsd-ports-gnome-f4231d0dbbf6fed8eee1d698564ed1906e9dfecd.tar.gz
freebsd-ports-gnome-f4231d0dbbf6fed8eee1d698564ed1906e9dfecd.tar.zst
freebsd-ports-gnome-f4231d0dbbf6fed8eee1d698564ed1906e9dfecd.zip
Add cvschk 1.12, quick offline checker for CVS modifications.
cvschk is a Perl program which allows you to see the status of your own CVS directories, without access to the CVS repository. It shows which files you changed, made locally, and which ones were deleted. PR: ports/80279 Submitted by: Matthias Andree <matthias.andree@gmx.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cvschk/Makefile32
-rw-r--r--devel/cvschk/distinfo2
-rw-r--r--devel/cvschk/files/cvschk.152
-rw-r--r--devel/cvschk/pkg-descr7
-rw-r--r--devel/cvschk/pkg-plist1
6 files changed, 95 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 46b097c4f520..55d52d3b2606 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -167,6 +167,7 @@
SUBDIR += cvs2svn
SUBDIR += cvsadmin
SUBDIR += cvsbook
+ SUBDIR += cvschk
SUBDIR += cvsd
SUBDIR += cvsdelta
SUBDIR += cvsdiff2patch
diff --git a/devel/cvschk/Makefile b/devel/cvschk/Makefile
new file mode 100644
index 000000000000..4f7a1848d1c6
--- /dev/null
+++ b/devel/cvschk/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cvschk
+# Date created: 2005-04-23
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvschk
+PORTVERSION= 1.12
+CATEGORIES= devel
+MASTER_SITES= http://cvs.sslug.dk/cvs2html/utils/
+DISTNAME= cvschk
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= Quick offline checker for CVS modifications
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+MAN1= cvschk.1
+
+do-configure:
+ ${SED} -e "s,^#!/usr/bin/perl -w,#! ${PERL} -w," \
+ <${DISTDIR}/${DISTNAME} >${WRKSRC}/${DISTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/cvschk.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/cvschk/distinfo b/devel/cvschk/distinfo
new file mode 100644
index 000000000000..2ae358c941bf
--- /dev/null
+++ b/devel/cvschk/distinfo
@@ -0,0 +1,2 @@
+MD5 (cvschk) = 935437b872cab82fcd80c9aa467376ca
+SIZE (cvschk) = 17410
diff --git a/devel/cvschk/files/cvschk.1 b/devel/cvschk/files/cvschk.1
new file mode 100644
index 000000000000..54a2c68cea0e
--- /dev/null
+++ b/devel/cvschk/files/cvschk.1
@@ -0,0 +1,52 @@
+.Dd April 23, 2005
+.Dt CVSCHK 1
+.Os
+.Sh NAME
+.Nm cvschk
+.Nd Quick offline CVS status checker
+.Sh SYNOPSIS
+.Nm
+.Op Fl adhlrtV
+.Op Fl Ar -all
+.Op Fl Ar -debug
+.Op Fl Ar -help
+.Op Fl Ar -local
+.Op Fl Ar -restrict
+.Op Fl Ar -tabular
+.Op Fl Ar -version
+.Sh DESCRIPTION
+The
+.Nm
+utility is a perl program which checks the status of the CVS controlled files
+and gives an ASCII table sorted after the status of files. It works offline,
+without access to the CVS repository.
+.Pp
+The options are:
+.Bl -tag -width Ds
+.It Fl a , -all
+Show all statistics, including the names of files that are up to date, used tags, ignored patterns and more.
+.It Fl d , -debug
+Show debug information.
+.It Fl h , -help
+Print a short usage help.
+.It Fl l , -local
+Do not descend into sub-directories.
+.It Fl r , -restrict
+Do not show the names of unknown files (useful in directories with lots of
+temporary files).
+.It Fl t , -tabular
+Show one file per line, preceded with a status word, sorted by filename.
+.It Fl V , -version
+Print the version and exit.
+.El
+
+.Sh AUTHOR
+This manual page was written by
+.An "Matthias Andree" Aq matthias.andree@gmx.de .
+.Pp
+.Nm cvschk
+was written by:
+.An "Peter Toft" Aq pto@sslug.dk ,
+.An "Ole Tange" Aq ole@tange.dk
+and
+.An "Lars G. T. Joergensen" Aq larsj@diku.dk
diff --git a/devel/cvschk/pkg-descr b/devel/cvschk/pkg-descr
new file mode 100644
index 000000000000..14e38dd24b58
--- /dev/null
+++ b/devel/cvschk/pkg-descr
@@ -0,0 +1,7 @@
+cvschk is a Perl program which allows you to see the status of your own CVS
+directories, without access to the CVS repository. It shows which files you
+changed, made locally, and which ones were deleted.
+
+WWW: http://cvs.sslug.dk/cvs2html/
+
+-- Matthias Andree
diff --git a/devel/cvschk/pkg-plist b/devel/cvschk/pkg-plist
new file mode 100644
index 000000000000..d0b8db40df0d
--- /dev/null
+++ b/devel/cvschk/pkg-plist
@@ -0,0 +1 @@
+bin/cvschk