aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-01-03 21:22:31 +0800
committermat <mat@FreeBSD.org>2018-01-03 21:22:31 +0800
commitf94c0be9433c87594b2ddb224b838f07abed216d (patch)
treec9bf5b66f395b3b00a03888c4a966d90c53e243e /devel
parent0ee96a5dc00ade017288c9fa2931e69168ae3c8b (diff)
downloadfreebsd-ports-gnome-f94c0be9433c87594b2ddb224b838f07abed216d.tar.gz
freebsd-ports-gnome-f94c0be9433c87594b2ddb224b838f07abed216d.tar.zst
freebsd-ports-gnome-f94c0be9433c87594b2ddb224b838f07abed216d.zip
Cleanup Mk/Uses/gnome.mk.
- Remove the use of comp_DETECT. - Remove all comp_DETECT variables. - Remove a use of comp_DETECT outside of gnome.mk - Remove py3gobject3. - Have ports depending directly on devel/py-gobject3 use gnome to do it. PR: 224618 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D13550
Diffstat (limited to 'devel')
-rw-r--r--devel/gitg/Makefile2
-rw-r--r--devel/glade/Makefile2
-rw-r--r--devel/gnome-builder/Makefile2
-rw-r--r--devel/libpeas/Makefile3
4 files changed, 4 insertions, 5 deletions
diff --git a/devel/gitg/Makefile b/devel/gitg/Makefile
index 459cdd88dd50..77dce6154874 100644
--- a/devel/gitg/Makefile
+++ b/devel/gitg/Makefile
@@ -50,6 +50,6 @@ NLS_USES_OFF= gettext-tools
NLS_CONFIGURE_ENABLE= nls
PYTHON_USES= python:3.2+
PYTHON_CONFIGURE_ENABLE= python
-PYTHON_USE= GNOME=py3gobject3
+PYTHON_USE= GNOME=pygobject3
.include <bsd.port.mk>
diff --git a/devel/glade/Makefile b/devel/glade/Makefile
index bc45a2159852..17475e53c329 100644
--- a/devel/glade/Makefile
+++ b/devel/glade/Makefile
@@ -40,6 +40,6 @@ OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT=PYTHON
PYTHON_CONFIGURE_ENABLE= python
PYTHON_USES= python:3.4+
-PYTHON_USE= GNOME=py3gobject3
+PYTHON_USE= GNOME=pygobject3
.include <bsd.port.mk>
diff --git a/devel/gnome-builder/Makefile b/devel/gnome-builder/Makefile
index 8e5fe44f23df..ddb2cd359ad5 100644
--- a/devel/gnome-builder/Makefile
+++ b/devel/gnome-builder/Makefile
@@ -26,7 +26,7 @@ PORTSCOUT= limitw:1,even
PORTDOCS= *
USES= cpe gettext gmake libtool pathfix python:3.4+ pkgconfig tar:xz
-USE_GNOME= glib20 gtk30 gtksourceview3 gtk-update-icon-cache py3gobject3
+USE_GNOME= glib20 gtk30 gtksourceview3 gtk-update-icon-cache pygobject3
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-debug \
ac_cv_path_PYTHON3_CONFIG=${PYTHON_CMD}-config
diff --git a/devel/libpeas/Makefile b/devel/libpeas/Makefile
index 0afff08b014e..575d0c5a9760 100644
--- a/devel/libpeas/Makefile
+++ b/devel/libpeas/Makefile
@@ -39,13 +39,12 @@ PLIST= ${.CURDIR}/pkg-plist
.if ${LIBPEAS_SLAVE} == python
USES+= python
USE_PYTHON= flavors
-.if ${FLAVOR:Upy27:Mpy2*}
USE_GNOME+= pygobject3
+.if ${FLAVOR:Upy27:Mpy2*}
CONFIGURE_ARGS+= --disable-python3
BUILD_WRKSRC= ${WRKSRC}/loaders/python
INSTALL_WRKSRC= ${WRKSRC}/loaders/python
.else
-USE_GNOME+= py3gobject3
CONFIGURE_ARGS+= --disable-python2 \
ac_cv_path_PYTHON3_CONFIG=${LOCALBASE}/bin/python${PYTHON_VER}-config
BUILD_WRKSRC= ${WRKSRC}/loaders/python3