aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-09-07 05:49:50 +0800
committerrakuco <rakuco@FreeBSD.org>2015-09-07 05:49:50 +0800
commitfec81806d5771e856e91d45a8c24c0af40a46f7b (patch)
tree53ec0ee4e336b26875e390f75aaebceaf69cfb6e /devel
parent0759ca1732524a7245935d7325aa00c89dcf05cb (diff)
downloadfreebsd-ports-gnome-fec81806d5771e856e91d45a8c24c0af40a46f7b.tar.gz
freebsd-ports-gnome-fec81806d5771e856e91d45a8c24c0af40a46f7b.tar.zst
freebsd-ports-gnome-fec81806d5771e856e91d45a8c24c0af40a46f7b.zip
New port: devel/libcutl.
libcutl is a C++ utility library. It contains a collection of generic and independent components such as meta-programming tests, smart pointers, containers, compiler building blocks, etc. WWW: http://www.codesynthesis.com/projects/libcutl/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libcutl/Makefile33
-rw-r--r--devel/libcutl/distinfo2
-rw-r--r--devel/libcutl/pkg-descr5
-rw-r--r--devel/libcutl/pkg-plist64
5 files changed, 105 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 20b60ad70536..8a48b7c7bd36 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1112,6 +1112,7 @@
SUBDIR += libcli
SUBDIR += libconfig
SUBDIR += libconfuse
+ SUBDIR += libcutl
SUBDIR += libcwd
SUBDIR += libcxxrt
SUBDIR += libdaemon
diff --git a/devel/libcutl/Makefile b/devel/libcutl/Makefile
new file mode 100644
index 000000000000..ded55b6c149f
--- /dev/null
+++ b/devel/libcutl/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= libcutl
+PORTVERSION= 1.9.0
+CATEGORIES= devel
+MASTER_SITES= http://www.codesynthesis.com/download/${PORTNAME}/${PORTVERSION:R}/
+
+MAINTAINER= rakuco@FreeBSD.org
+COMMENT= C++ utility library with generic and independent components
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libexpat.so:${PORTSDIR}/textproc/expat2
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool
+
+# The checks for external boost and external expat are quite limited and do not
+# add the ${LOCALBASE} paths correctly (libboost.m4 uses wrong paths and
+# libexpat.m4 does nothing at all).
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ARGS= --disable-static \
+ --with-boost=${LOCALBASE} \
+ --with-external-boost \
+ --with-external-expat \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+
+.include <bsd.port.mk>
diff --git a/devel/libcutl/distinfo b/devel/libcutl/distinfo
new file mode 100644
index 000000000000..569c209c2a5e
--- /dev/null
+++ b/devel/libcutl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcutl-1.9.0.tar.gz) = 1b575aa8ed74aa36adc0f755ae9859c6e48166a60779a5564dd21b8cb05afb7d
+SIZE (libcutl-1.9.0.tar.gz) = 1012872
diff --git a/devel/libcutl/pkg-descr b/devel/libcutl/pkg-descr
new file mode 100644
index 000000000000..1e742432b357
--- /dev/null
+++ b/devel/libcutl/pkg-descr
@@ -0,0 +1,5 @@
+libcutl is a C++ utility library. It contains a collection of generic and
+independent components such as meta-programming tests, smart pointers,
+containers, compiler building blocks, etc.
+
+WWW: http://www.codesynthesis.com/projects/libcutl/
diff --git a/devel/libcutl/pkg-plist b/devel/libcutl/pkg-plist
new file mode 100644
index 000000000000..a8e1cb129865
--- /dev/null
+++ b/devel/libcutl/pkg-plist
@@ -0,0 +1,64 @@
+include/cutl/compiler/code-stream.hxx
+include/cutl/compiler/code-stream.txx
+include/cutl/compiler/context.hxx
+include/cutl/compiler/context.txx
+include/cutl/compiler/cxx-indenter.hxx
+include/cutl/compiler/cxx-indenter.ixx
+include/cutl/compiler/cxx-indenter.txx
+include/cutl/compiler/sloc-counter.hxx
+include/cutl/compiler/sloc-counter.txx
+include/cutl/compiler/traversal.hxx
+include/cutl/compiler/traversal.txx
+include/cutl/compiler/type-id.hxx
+include/cutl/compiler/type-id.ixx
+include/cutl/compiler/type-id.txx
+include/cutl/compiler/type-info.hxx
+include/cutl/compiler/type-info.ixx
+include/cutl/container/any.hxx
+include/cutl/container/graph.hxx
+include/cutl/container/graph.txx
+include/cutl/container/key.hxx
+include/cutl/container/map-iterator.hxx
+include/cutl/container/multi-index.hxx
+include/cutl/container/pointer-iterator.hxx
+include/cutl/details/config.h
+include/cutl/details/config.hxx
+include/cutl/details/export.hxx
+include/cutl/details/genx/genx.h
+include/cutl/exception.hxx
+include/cutl/fs/auto-remove.hxx
+include/cutl/fs/exception.hxx
+include/cutl/fs/path.hxx
+include/cutl/fs/path.ixx
+include/cutl/fs/path.txx
+include/cutl/meta/answer.hxx
+include/cutl/meta/class-p.hxx
+include/cutl/meta/polymorphic-p.hxx
+include/cutl/meta/remove-c.hxx
+include/cutl/meta/remove-cv.hxx
+include/cutl/meta/remove-p.hxx
+include/cutl/meta/remove-v.hxx
+include/cutl/re.hxx
+include/cutl/re/re.txx
+include/cutl/shared-ptr.hxx
+include/cutl/shared-ptr/base.hxx
+include/cutl/shared-ptr/base.ixx
+include/cutl/shared-ptr/base.txx
+include/cutl/static-ptr.hxx
+include/cutl/xml/exception.hxx
+include/cutl/xml/parser.hxx
+include/cutl/xml/parser.ixx
+include/cutl/xml/parser.txx
+include/cutl/xml/qname.hxx
+include/cutl/xml/serializer.hxx
+include/cutl/xml/serializer.ixx
+include/cutl/xml/value-traits.hxx
+include/cutl/xml/value-traits.txx
+lib/libcutl-1.9.so
+lib/libcutl.so
+libdata/pkgconfig/libcutl.pc
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/version