aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2018-12-12 08:19:52 +0800
committerwg <wg@FreeBSD.org>2018-12-12 08:19:52 +0800
commit1eeddd11dc13c24a3aecefefe3db86831c67a1e5 (patch)
tree90ce4a2ce4347219ae4b785aad2ec8fd8b74e117 /devel
parent5a6bfed35e2d0ff5d6365d15c9282d176713e0e3 (diff)
downloadfreebsd-ports-gnome-1eeddd11dc13c24a3aecefefe3db86831c67a1e5.tar.gz
freebsd-ports-gnome-1eeddd11dc13c24a3aecefefe3db86831c67a1e5.tar.zst
freebsd-ports-gnome-1eeddd11dc13c24a3aecefefe3db86831c67a1e5.zip
devel/py-pyrsistent: Persistent/Immutable/Functional data structures
Pyrsistent is a number of persistent collections (by some referred to as functional data structures). Persistent in the sense that they are immutable. WWW: https://github.com/tobgu/pyrsistent
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyrsistent/Makefile20
-rw-r--r--devel/py-pyrsistent/distinfo3
-rw-r--r--devel/py-pyrsistent/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b46c598fc404..8cb874a78872 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4964,6 +4964,7 @@
SUBDIR += py-pyrepl
SUBDIR += py-pyrfc3339
SUBDIR += py-pyro
+ SUBDIR += py-pyrsistent
SUBDIR += py-pyshapelib
SUBDIR += py-pyshp
SUBDIR += py-pysparklines
diff --git a/devel/py-pyrsistent/Makefile b/devel/py-pyrsistent/Makefile
new file mode 100644
index 000000000000..0a26b084d2c8
--- /dev/null
+++ b/devel/py-pyrsistent/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= pyrsistent
+PORTVERSION= 0.14.7
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Persistent/Immutable/Functional data structures for Python
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyrsistent/distinfo b/devel/py-pyrsistent/distinfo
new file mode 100644
index 000000000000..0d5e4e1fa10e
--- /dev/null
+++ b/devel/py-pyrsistent/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544544852
+SHA256 (pyrsistent-0.14.7.tar.gz) = 05910b7ff43cec0a853c15da0bfaf2867faa95f29b08e71f5846a195f1f38c75
+SIZE (pyrsistent-0.14.7.tar.gz) = 103848
diff --git a/devel/py-pyrsistent/pkg-descr b/devel/py-pyrsistent/pkg-descr
new file mode 100644
index 000000000000..09eff90a75f9
--- /dev/null
+++ b/devel/py-pyrsistent/pkg-descr
@@ -0,0 +1,4 @@
+Pyrsistent is a number of persistent collections (by some referred to as
+functional data structures). Persistent in the sense that they are immutable.
+
+WWW: https://github.com/tobgu/pyrsistent