aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-01-19 18:28:26 +0800
committeredwin <edwin@FreeBSD.org>2005-01-19 18:28:26 +0800
commit2d1fc716e49b1edc9fc4faac45ff37842d5a7793 (patch)
treedc6b4ded6322b47092d4bc0e5d26182832f4ba79 /devel
parentc961a912b7ea4a59c69d1efd163433c350fffbb4 (diff)
downloadfreebsd-ports-gnome-2d1fc716e49b1edc9fc4faac45ff37842d5a7793.tar.gz
freebsd-ports-gnome-2d1fc716e49b1edc9fc4faac45ff37842d5a7793.tar.zst
freebsd-ports-gnome-2d1fc716e49b1edc9fc4faac45ff37842d5a7793.zip
New port: devel/pear-Structures_DataGrid - a PEAR data structure package
This package offers a toolkit to render out a datagrid in HTML format as well as many other formats such as an XML Document, an Excel Spreadsheet, an XUL Document and more. It also offers paging and sorting functionality to limit the data that is presented and processed. This concept is based on the .NET Framework DataGrid control and works very well with database and XML result sets. PR: ports/76165 Submitted by: Nick Hilliard <nick@foobar.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-Structures_DataGrid/Makefile39
-rw-r--r--devel/pear-Structures_DataGrid/distinfo2
-rw-r--r--devel/pear-Structures_DataGrid/pkg-descr8
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4b92af222823..ffe7c9affc4e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1122,6 +1122,7 @@
SUBDIR += pear-PHPUnit2
SUBDIR += pear-PHP_Compat
SUBDIR += pear-Pager
+ SUBDIR += pear-Structures_DataGrid
SUBDIR += pear-VFS
SUBDIR += pear-Validate
SUBDIR += pear-Var_Dump
diff --git a/devel/pear-Structures_DataGrid/Makefile b/devel/pear-Structures_DataGrid/Makefile
new file mode 100644
index 000000000000..6f1f4dc76c02
--- /dev/null
+++ b/devel/pear-Structures_DataGrid/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: pear-Structures_DataGrid
+# Date created: 12 January 2005
+# Whom: Nick Hilliard <nick@foobar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Structures_DataGrid
+PORTVERSION= 0.6.0
+CATEGORIES= devel www pear
+
+MAINTAINER= nick@foobar.org
+COMMENT= Simple HTML data structure package
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${PEARDIR}/HTML/Table.php:${PORTSDIR}/devel/pear-HTML_Table \
+ ${PEARDIR}/Pager/Pager.php:${PORTSDIR}/devel/pear-Pager \
+ ${PEARDIR}/Spreadsheet/Excel/Writer.php:${PORTSDIR}/textproc/pear-Spreadsheet_Excel_Writer \
+ ${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util \
+ ${PEARDIR}/XML/RSS.php:${PORTSDIR}/devel/pear-XML_RSS \
+ ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
+ ${PEARDIR}/Console/Table.php:${PORTSDIR}/devel/pear-Console_Table
+
+CATEGORY= Structures
+FILES= DataGrid.php DataGrid/Core.php DataGrid/Column.php \
+ DataGrid/Record.php DataGrid/Renderer.php \
+ DataGrid/DataSource.php DataGrid/Renderer/Console.php \
+ DataGrid/Renderer/CSV.php DataGrid/Renderer/HTMLTable.php \
+ DataGrid/Renderer/Smarty.php DataGrid/Renderer/XML.php \
+ DataGrid/Renderer/XLS.php DataGrid/Renderer/XUL.php \
+ DataGrid/DataSource/Array.php DataGrid/DataSource/CSV.php \
+ DataGrid/DataSource/DataObject.php \
+ DataGrid/DataSource/DB.php DataGrid/DataSource/RSS.php \
+ DataGrid/DataSource/XML.php DataGrid/Record/DB.php \
+ DataGrid/Record/DataObject.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Structures_DataGrid/distinfo b/devel/pear-Structures_DataGrid/distinfo
new file mode 100644
index 000000000000..13eb0cacb7f5
--- /dev/null
+++ b/devel/pear-Structures_DataGrid/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Structures_DataGrid-0.6.0.tgz) = eb2ee324875bd14319574db320262e00
+SIZE (PEAR/Structures_DataGrid-0.6.0.tgz) = 24030
diff --git a/devel/pear-Structures_DataGrid/pkg-descr b/devel/pear-Structures_DataGrid/pkg-descr
new file mode 100644
index 000000000000..fe96ed1c4f62
--- /dev/null
+++ b/devel/pear-Structures_DataGrid/pkg-descr
@@ -0,0 +1,8 @@
+This package offers a toolkit to render out a datagrid in HTML format as
+well as many other formats such as an XML Document, an Excel Spreadsheet, an
+XUL Document and more. It also offers paging and sorting functionality to
+limit the data that is presented and processed. This concept is based on the
+.NET Framework DataGrid control and works very well with database and XML
+result sets.
+
+WWW: http://pear.php.net/package/Structures_DataGrid/