aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-12-17 00:49:17 +0800
committerrene <rene@FreeBSD.org>2018-12-17 00:49:17 +0800
commit4909b0f811cf5ad505666da55a2655041c78e236 (patch)
tree892baa84cc0c67b08795b6576e985d83e5a8f6d1 /devel
parent0a0c9722087f1a9b6e1d4506eed21bd6d9b3bcb5 (diff)
downloadfreebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.tar.gz
freebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.tar.zst
freebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.zip
Use regular DEPRECATED and EXPIRATION_DATE variables in an "if FLAVOR" block
instead of flavoring the variables themselves. This caused too much hassle for Tools/scripts/rmport. Discussed with: tcberner
Diffstat (limited to 'devel')
-rw-r--r--devel/libdbusmenu-qt/Makefile5
-rw-r--r--devel/liteide/Makefile5
-rw-r--r--devel/qca/Makefile5
3 files changed, 6 insertions, 9 deletions
diff --git a/devel/libdbusmenu-qt/Makefile b/devel/libdbusmenu-qt/Makefile
index e5a090ef3126..7dee2aa9964b 100644
--- a/devel/libdbusmenu-qt/Makefile
+++ b/devel/libdbusmenu-qt/Makefile
@@ -18,13 +18,12 @@ LICENSE= LGPL20
FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= compiler:c++11-lib cmake:outsource
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= qt:4
USE_QT= corelib dbus gui \
moc_build qmake_build rcc_build uic_build
diff --git a/devel/liteide/Makefile b/devel/liteide/Makefile
index 1bb3891a3828..59db07664aa9 100644
--- a/devel/liteide/Makefile
+++ b/devel/liteide/Makefile
@@ -22,9 +22,6 @@ qt4_CONFLICTS_INSTALL= ${PORTNAME}
qt4_PKGNAMESUFFIX= -qt4
qt5_CONFLICTS_INSTALL= ${PORTNAME}-qt4
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= gl qmake
USE_GL= gl
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
@@ -34,6 +31,8 @@ GH_ACCOUNT= visualfc
GH_TUPLE= visualfc:gotools:77fd0f0:gotools/src/github.com/visualfc/gotools
.if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= qt:4
USE_QT= corelib gui moc_build network rcc_build uic_build webkit xml
PLIST_SUB+= QT4="" NO_QT4="@comment "
diff --git a/devel/qca/Makefile b/devel/qca/Makefile
index 3c208648c191..d3b395f57b2b 100644
--- a/devel/qca/Makefile
+++ b/devel/qca/Makefile
@@ -20,9 +20,6 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= cmake:outsource tar:xz
CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no \
-DPKGCONFIG_INSTALL_PREFIX=${PREFIX}/libdata/pkgconfig \
@@ -32,6 +29,8 @@ CONFIGURE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
CMAKE_ON= QT4_BUILD
USES+= qt:4
USE_QT= corelib moc_build qmake_build rcc_build